Hi

Maybe somebody can give me some advise please. I have the Talon with the extended wings and I must admit I have fallen in love with this Plane! It flies very stable and slow which is ideal for my Aerial Survey Mapping Projects.

This all ended this morning, when sending it on a Mission, the motor ripped the entire section off from the back of the Plane and needless to same, the Talon kissed Mother Earth! There goes my Love Life!

It was the standard Motor size that get supplied by the Company in China. Any ideas?

I am going to buy a new one and need some advise to cover the Body for some extra strength and better surface finish.

Regards

Michael

Views: 1576

Replies to This Discussion

Wow, the only way that could have happened, is that the prop lost a blade, and the resulting vibration tore the motor out.

The Talon is strong enough, if constructed properly........

Give us some pictures, might pick up something.

Michael,

Sounds like too much torque output demand by the ESC?  Wow... That sucks.

Do you have any postmortem pictures.  Would like to see if there is a pattern to the breakup.  And what are you using for autopilot?

ab.audiovideo@yahoo.com 

I have seen two where the engine mount was very loose and I had to add a little glue to stiffen it up. There is a heck of a lot of stress on not much foam back there.

I had this happen with a Mini Talon with landing gear. I had a prop strike happen upon take off that caused some serious vibration at a certain motor RPM. Eventually the vibration jiggled the motor screws loose and the whole thing came off. In my case the prop destroyed half the control surfaces and took chunks off the back of the plane. I was lucky because I shut the motor down before the wires pulled from the ESC. I was able to land with the motor dangling off the back. 

Gary, the motor area is the last one I glue up, liberally, with UHU POR, before joining the two halves.

Being a pusher, with a well balanced prop, I don't see any issues with the design ?????

After reading this, I'm going to wrap the back of mine with strapping tape.  Really don't want to add anymore weight to the motor end but don't want it to shed the weight like yours did.

Hi All

Thanks for coming up back to me. I am busy taking Photos.

Another question....the glue we used does not work...we used 20 minute Epoxy....UHU was used on the 2 main body parts......is there any surface treatment to be done before gluing the parts together?

Regards

Michael

Hi

Herewith the Photos.

Regards

Michael

I started using 'Shoe Glue' or E6000 glue as it's known by in the states. Another 3dR engineer suggested it. It seems to almost melt the foam together. 

Hi Adam

I am using Pixhawk. There is no issue with the Autopilot on the Talon..it flies like a dream.

Regards

Michael

I have seen those loose mounts with ARTFs not a design thing a from the factory thing.

Looks like the Photos did not load.

Attachments:

RSS

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service