Information

ArduRover User Group

Dedicated to the exchange of useful information between members using the Arduino or other families of processors for autonomous rovers.

Members: 575
Latest Activity: Mar 20

Before Posting an Issue

Hi All,

Before posting an issue or a problem in the ArduRover Discussion Forum, please check the wiki table of contents, review the firmware release notes in the subforum, and search that subforum for existing answers to your question. Help avoid duplicate threads by finding other members with the same issue and their solution.

When formulating your post, use a descriptive title such as "rover will not navigate to waypoints in the Auto mode" (not "HELP!" or "Problem").

Please include the following information to help diagnose your query:

  • Describe the problem you are having. What is the expected verses the observed behavior?
  • Provide hardware information such as the brand and version of your autopilot, GPS, radio, and compass, as well as any other pertinent details about your rover setup.
  • What version of the APM: ArdurRover2 firmware version are you running?
  • For navigation issues, provide your tlog and/or dataflash log. Click here for instructions on retrieving a dataflash log.

TCIII

Discussion Forum

autonomous rover- no motors, just servo for steering and actuator for braking- rolling down hill

Started by john smith. Last reply by Ray Quintana Mar 20. 3 Replies

The objective is to build an autonomous gravity racer (no motors, just rolling down a hill) to go through several waypoints. Autonomy through GPS and magnetometer.Was wondering if anyone can direct…Continue

Tags: racer, gravity, 2.6, APM

How should we handle reverse in ArduRover?

Started by Andrew Tridgell. Last reply by Amulya Agarwal Mar 11. 48 Replies

I'd like to add support for the rover using reverse in auto mode, so if it can get somewhere faster by going backwards it will. So I'm looking at how reverse is setup in the ArduRover code, and…Continue

Rover goes in tight circles when in Auto and RTL mode. Error Compass Variance Alert.

Started by Robert Kyamoto. Last reply by Nathan Jones Jan 25. 15 Replies

The rover works completely in manual mode, but whenever I switch to auto or RTL the rover just turns in tight circles. I get an error message "Error compass variance". I recalibrated the compass, but…Continue

Tags: ArduRover

Standard Settings for PixHawk Rover Skid Steering + Sabertooth

Started by Nathan Jones. Last reply by Andre Luiz Jan 16. 7 Replies

I'm trying to get a new rover up and running and keeping hitting bumps...and also my head on the wall! Please help before this beast runs me over lol!Overview: -200lb custom built steel frame rover.…Continue

Tags: SaberTooth, Pixhawk, SkidSteering, Rover

Comment Wall

Comment

You need to be a member of ArduRover User Group to add comments!

Comment by KM6VV on June 26, 2012 at 7:12pm

I see that.  Maybe we'd get a few more answers about using other IMUs, GPS and other modules with the code!

I'm wondering if I should learn ROS, and run from a mini PC.

Alan


Admin
Comment by Thomas J Coyle III on June 26, 2012 at 5:36pm

Hi Alan,

JLN ArduRover is specifically for his project. I believe that there are plenty of other DIY Drones members who would be possibly interested in a general rover group like this one based on the responses I read concerning the Sparkfun AVC blogs posted on the DIY Drones webpage.

Just a thought.

Regards,

TCIII

Comment by KM6VV on June 26, 2012 at 12:58pm

Doesn't JL already have a group?  This one for MPU?

Alan

 
 
 

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service