Damon Pipenberg
  • Male
  • State College, PA
  • United States
Share Twitter

Damon Pipenberg's Discussions

Uploading with GPS Attached

Started this discussion. Last reply by Thomas J Coyle III Jul 7, 2009. 3 Replies

 

Damon Pipenberg's Page

Latest Activity

C S SURAJ commented on Damon Pipenberg's blog post Penn State University ArduPilot Project
"Damon Pipenberg I am using now and arduino Due to interface VectorNAV_100 in SPI mode below is the link of the hardware  http://arduino.cc/en/Main/ArduinoBoardDue I am sending a request in spi to read yaw pitch roll(registry 8) 0x01,…"
Jun 27, 2013
Michel Lubbers commented on Damon Pipenberg's blog post Dead multiplexer?
"I also fried the 74ACT157, I replaced it with a 74HCT157 (cmos), now my servo's run directly to the corner. What could be wrong? Perhaps the gate stays down or something like that. I try a 10k pullup resistor but no positive result."
Aug 15, 2009
Bryan Cuervo commented on Damon Pipenberg's blog post Penn State University ArduPilot Project
"Man, I'm jealous. I never got to work on fun projects like this when I was in school! What is your objective with the glider? Slope soaring or are you converting to electric motor? Have you guys looked at the Zagi 60 electric wing? More room…"
Jul 8, 2009

Admin
Thomas J Coyle III replied to Damon Pipenberg's discussion Uploading with GPS Attached
"Damon, Unfortunately the termination of pin 6, according to Jordi, is not an issue in relation to the upload problem. However, I did add a 10k pullup resistor connected to VCC to the base of Q1 and it did not help to keep Q1 cutoff until I updated…"
Jul 7, 2009
Damon Pipenberg replied to Damon Pipenberg's discussion Uploading with GPS Attached
"Thomas, The config utility has been modified to do this, see my post here. However, some can still not upload with the GPS connected, so I'm afraid the issue isn't quite solved yet. I don't actually have the problem, so it is…"
Jul 7, 2009

Admin
Thomas J Coyle III replied to Damon Pipenberg's discussion Uploading with GPS Attached
"Damon, I got the same voltage reading on the base of Q1 that you did indicating that the GPS should be off during the up load. I believe that root cause of most of the upload problems with the GPS connected had to do with resetting the Atmega…"
Jul 7, 2009
Damon Pipenberg posted a discussion

Uploading with GPS Attached

Some people have been having issues uploading to their ArduPilot while the GPS is connected. I did some investigating today to determine where the issue may be.I did a quick simulation of the circuit that turns the GPS on and off. This is a rough approximation, using a 650 ohm resistor to approximate the load of the GPS.The circuit:…See More
Jul 7, 2009

Developer
Ryan Beall commented on Damon Pipenberg's blog post Penn State University ArduPilot Project
"Actually the VN100 will be completely useless for your project. It doesn't account for Centripetal....has no way too....Doesn't know airspeed or GPS ground speed. It even says it in the manual....well kinda illudes to it. Unfortuneately…"
Jul 6, 2009
Damon Pipenberg commented on Damon Pipenberg's blog post Penn State University ArduPilot Project
"As I said above, we're using a Vectornav VN100 as the IMU, more specifically a AHRS. This has 3 axis of accelerometers, gyros, and magnetometers on a single PCB, and has a microcontroller on-board that implements an extended Kalman filter to…"
Jul 6, 2009
Damon Pipenberg commented on Jordi Muñoz's blog post ArduPilot Config Tool Source Code Released!
"David, I believe that there is a separate problem with the EM406 GPS. I'm afraid my software fix will not fix that problem. For now, it seems that the accepted fix is to disconnect the GPS during uploading. I am using the u-blox GPS, not the…"
Jul 6, 2009
Damon Pipenberg commented on Jordi Muñoz's blog post ArduPilot Config Tool Source Code Released!
"David, Have you tried uploading with the GPS disconnected? Please try that and report back with your results. If that fails, try disconnecting the shield and connecting the FTDI directly to the AP. Damon"
Jul 6, 2009
Maik commented on Damon Pipenberg's blog post Penn State University ArduPilot Project
"Nice project :) Are you going to pick Ardupilot with an IMU as a platform? Are you building one from scratch? I hope you know the Paparazzi project, which is already quite advanced and maybe more appropriate if you only have one summer?"
Jul 6, 2009
Joseph Glanville commented on Damon Pipenberg's blog post Penn State University ArduPilot Project
"Nice looking glider. The VN100 is a very nice piece of hardware too, alot of the hard work of implementing an IMU solution has been done for you in the EKF onboard the chip. Look forward to watching your progress. :)"
Jul 6, 2009
Damon Pipenberg posted a blog post

Penn State University ArduPilot Project

I'm an undergrad EE student at Georgia Tech and this summer I'm working in an aerospace research lab at Penn Sate University, headed by Dr. Jack Langelaan. My project is to outfit a Zagi THL glider with an autopilot system. The reaserch is being funded by the NSF, and the aim is to work on developing open-source autopilot hardware and software, with a goal of having the drones do useful work, such as monitoring meteorological conditionsWe want our autopilot to be based around an IMU. We're…See More
Jul 6, 2009
Jerry LeDrew left a comment for Damon Pipenberg
"Great work Damon .... I am 73 and was about to make an adapter leaving out pin 6.... But now I don't have to ...I am a hardware man more then a software person ...Before I did my first Read- the improvised way I found smoe Extraneous data not…"
Jul 6, 2009
Damon Pipenberg commented on Jordi Muñoz's blog post ArduPilo Config Tool Source Code Released!
"Jordi - not a problem, glad to help. I'm still confused about one thing - what pin does the official DIY drones cable bring out, DTR or RTS? From the schematic on FTDI's site, I thought that it was RTS, in which case the Sparkfun board…"
Jul 6, 2009

Profile Information

About Me:
I'm a student working in Dr. Jack Langelaan's lab at Penn State University. I am working on getting an ArduPilot up and running on a Zagi (flying wing) glider. We plan to make a number of modifications and additions to the ArduPilot code, which will be posted here as they are developed.

Damon Pipenberg's Blog

Penn State University ArduPilot Project

Posted on July 6, 2009 at 10:36am 6 Comments

I'm an undergrad EE student at Georgia Tech and this summer I'm working in an aerospace research lab at Penn Sate University, headed by Dr. Jack Langelaan. My project is to outfit a Zagi THL glider with an autopilot system. The reaserch is being funded by the NSF, and the aim is to work on developing open-source autopilot hardware and software, with a goal of having the drones do useful work, such as monitoring meteorological conditions



We want our autopilot to be based around an… Continue

Dead multiplexer?

Posted on June 30, 2009 at 8:17am 28 Comments

Wondering if anyone might have experienced a problem that I'm having. My ArduPilot has been working fine, but yesterday, the servo outputs suddenly quit working. After doing some troubleshooting, I think I've narrowed the problem down the the multiplexer (74ACT157). It gets power, and gets a proper signal from the failsafe, and I found a 50 Hz signal on the inputs. However, the outputs are always low, at 0V.



I've been using a 4-cell, 4.8V receiver battery to power my setup. When… Continue

Breakout board for Sparkfun u-blox GPS module

Posted on June 23, 2009 at 8:30am 8 Comments

I received my u-blox GPS receiver and connector from Sparkfun recently, and needed a PCB to hook it all together. I've put together a simple layout including a lithium backup battery and a 4-pin 0.1" header to connect it to my ArduPilot.



I've attached the Eagle file for the layout. I case you don't have Eagle, you can get it… Continue

Comment Wall (1 comment)

At 10:10am on July 6, 2009, Jerry LeDrew said…
Great work Damon ....
I am 73 and was about to make an adapter leaving out pin 6.... But now I don't have to ...I am a hardware man more then a software person ...Before I did my first Read- the improvised way I found smoe Extraneous data not like waypoints and my rudder was not responding in auto-mode....Writing new data cleaned it out .... ArduPilot Config. utility works now Thanks to your software change ....
GPS ____UNPLUGED

Tnx agn .... Jerry ( VO1ET )

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service