• Blog Posts
  • Discussions (9)
  • Groups
  • Photos
  • Photo Albums
  • Videos

Gabby Lang's Discussions

Neo-6m GPS no signal.

Started this discussion. Last reply by Don Morrison Jul 19, 2013. 20 Replies

Hello,I've read many threads these past days and before giving up I'll give it another shot...Here's the deal- I bought the Neo-6m from HK, connected to the Crius board and got NO GPS.Trying to…Continue

Tags: U-Center, Ublox, Neo-6m

 

Gabby Lang's Page

Latest Activity

Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"OK, so maybe it was a coincidence that it started working when I switched to a new UBEC. Today it wouldn't boot and I took a look at the board since I had been flying in a dusty/leafy spot yesterday. I brushed off what I thought was a clump of…"
Jul 19, 2013
Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"I'm feeling like I want to start looking at the code (not like I feel like I'm going to understand it very well) to see what it's trying to do on bootup. It seems like there's some sort of hiccup going on here that's more of…"
Jul 14, 2013
Gabby Lang replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Thanks Don, See, that's the thing, I have it connected to a 5 amp UBEC and the jumper is off. I thought that the UBEC would solve it but I got the same results. Thanks anyway, I'll keep looking."
Jul 14, 2013
Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"That's about what it was doing for me. There were two orange RX/TX LED's by the USB connector that would alternately flash and the red LED would flash a few times and that was about all that would happen.  The "manuals"…"
Jul 14, 2013
Gabby Lang replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Dean, I'm only speculating here so please excuse me... When I tried to work the problem I tried to eliminate the smallest details that may be overlooked, like wires, for example. Bad wiring may cause this issue (perhaps you're using one…"
Jul 14, 2013
Dean replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Thanks Gabby, Ive tried a GPS unit from hobby king the uBlox NEO-6M, ive tried 2 different APM boards and the stock 3DR GPS unit, a uBlox aswell to no avail Im really stuck, any ideas? Cheers"
Jul 14, 2013
Gabby Lang replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Hi Dean, my issue was a bit different, the GPS didn't provide any data, whether by USB or bat. However, it sounds like a wiring issue. What type of board and GPS do you have?"
Jul 14, 2013
Gabby Lang replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Don, I have another issue with the CRIUS board, maybe you could help: if I connect the battery, the board flashes twice but does not boot (both UBEC or ESC power), however if I connect the USB first then it boots and stays on after connecting the…"
Jul 14, 2013
Dean replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Ive got the same Issue, I only get a GPS lock on USB, and not on 3S battery. Ive left it on battery for 30mins and no lock, just flashes. Connect it to USB and in under 60 seconds i have a 3d fix. This has happened with 2 GPS units now Any…"
Jul 14, 2013
Gabby Lang replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Don, I have the V. 2 board, but as I mentioned the GPS has been receiving power (the LED came on), and the U-Center was able to initialize a connection (but no data), so that wasn't the issue. Last night I finally got an answer from HK stating…"
Jul 13, 2013
Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Did you get your CRIUS board from Hobby King as well? They had a problem with the voltage regulator on the boards they had made. They released a "Version 2" that fixed the problem. I'm trying to remember specifically what the issue…"
Jul 13, 2013
Gabby Lang replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Hi Don, Thanks for your posts and I'm glad it worked out for you. I have tried the connecting the GPS to the laptop with USB and FTDI board, to no avail. Upon contacting HK regarding this issue, I have been getting very sketchy answers about…"
Jul 13, 2013
Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Solved it. My UBEC wasn't supplying enough power. The GPS wasn't the problem but the tipping point where the whole system browned out. I discovered this by connecting the board to the laptop with the USB cable. Booted right up . . . but…"
Jul 11, 2013
Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"On the CRIUS I need to connect bare ends from the connecter attached to the GPS to the bare ends going into Serial2? on the AIOP. I had started with a Dupont connecter, but I ended up soldering each connection after the perceived loose connection…"
Jul 11, 2013
Jani replied to Gabby Lang's discussion Neo-6m GPS no signal.
"Sounds power or wrong wiring problem? You have correct wiring between APM and GPS and GPS red light goes on after power up? Regards Jani "
Jul 11, 2013
Don Morrison replied to Gabby Lang's discussion Neo-6m GPS no signal.
"I have a NEO-6M running on a CRIUS AIOP. Something is weird where the GPS seems to keep the whole system from booting up. if I unplug the GPS it will boot up fine. Maybe there's still a loose or intermittent connection, but I have my suspicions…"
Jul 11, 2013

Profile Information

Please tell us a bit about your UAV interest
Multicopters.

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service