Max Merfeld
  • Male
  • United States
Share Twitter

Max Merfeld's Groups

 

Max Merfeld's Page

Latest Activity

Max Merfeld replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Thomas, I loaded version 2.20b by the MP and it worked fine on the board.  When I downloaded 2.20b from the git repo master, built, and installed on the APM1.4 board, the accelerometer wouldn't initialize but the gyro would. Since the…"
Oct 2, 2012

Admin
Thomas J Coyle III replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Hi Max, Since I finally got a couple of APM1.4 boards put together to go with a couple of Oilpan V H, I have loaded 2.20a by the IDE and 2.20b by the MP and both worked for me. Did you try using the Terminal mode (CLI) to look at the…"
Oct 1, 2012
Max Merfeld replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Thomas, Sounds good to me.  Sorry I don't have more information on why this revision works and the master doesn't. Cheers, Max"
Sep 21, 2012

Admin
Thomas J Coyle III replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Hi Max, Nice work. Maybe we need to send JLN a note about this issue with v2.20b that you have discovered and maybe he can correct it. Comment? Regards, TCIII"
Sep 20, 2012
Max Merfeld replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Thomas, I just reverted to revision 'c526bba894d5284ad6e8a179aa3006955d295780' and then compiled and uploaded the code and now the board seems to run fine.  I think there have only be a couple of changes to the APMRover2 code base…"
Sep 20, 2012
Max Merfeld replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Thomas, Thanks for replying.  I pulled the newest APMRover2 code from the GIT repo and I believe it is v2.20b.  I am loading this onto an APMv1.4 with a IMU Shield/Oilpan Hotel 1.0.  Cheers, Max"
Sep 20, 2012

Admin
Thomas J Coyle III replied to Max Merfeld's discussion Accelerometer Initialization with APMRover2 in the group ArduRover User Group
"Hi Max, What version of the ArduRover software are you using and what version of the Oilpan are you using? Regards, TCIII"
Sep 20, 2012
Max Merfeld added a discussion to the group ArduRover User Group
Thumbnail

Accelerometer Initialization with APMRover2

I am using an APMv1 with a mega2560 and an Oilpan.  When I load the APMRover2 firmware through the mission planner software, the board works fine.  I downloaded the APMRover2 code from the git repo and I only modified the APM_Config.h file such that "#define CONFIG_APM_HARDWARE APM_HARDWARE_APM1" and "#define LITE  DISABLED".  I am able to make and upload the HEX file to the APMv1 board, but the accelerometer won't initialize?  Are there other config settings that I need to alter?  Any help is…See More
Sep 20, 2012

Profile Information

Please tell us a bit about your UAV interest
Currently working with a tracked UGV and a blimp UAV and trying to get them to cooperatively achieve autonomous missions.

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service