• Blog Posts
  • Discussions (8)
  • Groups
  • Photos
  • Photo Albums
  • Videos

Nathan Smith's Discussions

Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine

Started this discussion. Last reply by Graham Dyer Apr 14, 2013. 14 Replies

I have a quad copter with an APM 2.5 installed on it.  Last week I updated from the stock 2.8.* code to the newest (available through mission planner) 2.9.1.  Immediately after update, everything…Continue

 

Nathan Smith's Page

Latest Activity

Nathan Smith replied to Oliver G.'s discussion Is there a limit for DO_DIGICAM_CONTROL commands?
"Oliver, What software do you use for constructing your 3D model?  I've been looking into this but haven't come across any software that works for me."
Jun 10, 2013
Nathan Smith commented on Mark Willis's blog post Aerial Mapping with multicopter
"Hi Mark, I've been trying to do something very similar with a hex that I have available, but I've been having terrible luck with our cameras.  I've tried a PowerShot A3400IS and PowerShot SX200IS, but both have struggled to take…"
Apr 24, 2013

Moderator
Graham Dyer replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"I can change the wiki but I haven't been following this subject very closely so if anyone could PM me the corrected wiki text?"
Apr 14, 2013
Nathan Smith replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"Is there any general consensus on what's causing the gyros to die?  I just threw out anything I could think of that might have been related, but proximity in time doesn't mean causation.  I'd like to keep from…"
Apr 14, 2013

Moderator
Graham Dyer replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"Glad they're going to replace it for you Nathan, I have a APM 2 board with the exact same symptoms, it's never had a servo plugged in anywhere and has only ever been connected through USB and yet the gyro is dead. There quite a few reports…"
Apr 14, 2013
R. D. Starwalt replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"I knew there was a great discussion about the gimbal connections. HERE is the main thread. HERE is a great diagram showing wiring. -=Doug"
Apr 14, 2013
R. D. Starwalt replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"That is very kind of them. I agree with your analysis above. Looking over the schematics and board layout all the way back to APM2.0 I still can not find trace connections for the +5 on the PWM Output lines - there are only 8, A0 - A7. A8 - A11 are…"
Apr 11, 2013
Nathan Smith replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"I talked to uDrones customer service and they have generously offered to replace the board."
Apr 10, 2013
Nathan Smith replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"After reading quite a bit, I think that I understand how you are supposed to connect the gimbal servo. Remove JP1 (jumper 1) to disconnect the "output" power rails from the analog and APM internal power rails. Connect power to the…"
Apr 10, 2013
Nathan Smith replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"I see the warning that you cited.  Frustratingly, on the AC2_Camera page they show the gimbal's servo connected directly to A11. As I mentioned previously, unplugging all of the external components (GPS, servos, motors, etc.) still…"
Apr 10, 2013
R. D. Starwalt replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"I've been looking over the board layout (for APM2.5.2) and can not clearly see the +5 connection traces (even with all layers applied to the drawing. There was another warning about where not to connect the servos HERE. The embedded link takes…"
Apr 10, 2013
R. D. Starwalt replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"I would roll back to the previous configuration (I think that is what you were trying to do/did), no servo connected. In short take it all apart to the point where it was working so we can determine what is broken. All the 'A' connectors…"
Apr 10, 2013
Nathan Smith replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"Just realized I left off one answer.   The camera was being triggered using the "relay" mode, even though there was no relay attached.  This just sent +5V down a USB cable to a Canon PowerShot running CHDK.  The S and -…"
Apr 9, 2013
Nathan Smith replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"And here I thought I'd given every piece of information possible :) Yes, the quad was flying on 2.8.  I flew it several times both using my radio (Spektrum DX8) and also via pre-programmed waypoints. The quad is the ArduCopter 3DR…"
Apr 9, 2013
R. D. Starwalt replied to Nathan Smith's discussion Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine
"Was the quad flying/working on 2.8? With APM2.5, are you using the 3DR Power Module to power the APM? What was your power source for the gimbal and shutter servo? -=Doug"
Apr 9, 2013
Nathan Smith posted a discussion

Can't connect to APM2.5 on ArduCopter in configuration mode; terminal mode works fine

I have a quad copter with an APM 2.5 installed on it.  Last week I updated from the stock 2.8.* code to the newest (available through mission planner) 2.9.1.  Immediately after update, everything seemed fine, though I didn't try to fly it.  I disconnected power, installed my gimbal (A11) and camera trigger (A9).  When I reapplied power, I wasn't able to connect to it over the 3DR radios, so I tried the USB.  Same thing.  As a last resort, I tried connecting through USB in terminal mode.Here is…See More
Apr 9, 2013

Profile Information

Please tell us a bit about your UAV interest
Multicopters

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service