Robert Baumgartner
  • Male
  • United States
Share Twitter
  • Blog Posts
  • Discussions (17)
  • Groups
  • Photos
  • Photo Albums
  • Videos

Robert Baumgartner's Discussions

Mediatek w/ U-Center?

Started this discussion. Last reply by Robert Baumgartner Nov 16, 2012. 2 Replies

Is is possible to test the Mediatek GPS w/ the u-center software? I've tried connecting w/ FTDI but u-center won't display any data (even though 3D-Fix light goes solid and u-center reports the…Continue

HIL Output from ArduPlane 2.66?

Started this discussion. Last reply by Robert Baumgartner Feb 13, 2013. 4 Replies

I've been working on configuring the ArduPlane firmware to handle joystick-only control a little better. So far all has been going well but now I've run into a bit of a roadblock with HIL simulation…Continue

Please help! APM2 Barometer/Altitude Issues

Started this discussion. Last reply by Robert Baumgartner Nov 11, 2012. 2 Replies

I've been bench-testing my APM2 board and everything is working well enough but I'm noticing an issue with the altitude reading; it's all over the place!After initial startup the APM2 usually starts…Continue

Will 5v FTDI Fry my board(s)?

Started this discussion. Last reply by Robert Baumgartner Nov 14, 2012. 1 Reply

I have a 5v FTDI cable from SparkFun (https://www.sparkfun.com/products/9718) but noticed the one on the DiyDrones store is 3.3v. Before plugging…Continue

 

Robert Baumgartner's Page

Latest Activity

Robert Baumgartner replied to Robert Baumgartner's discussion HIL Output from ArduPlane 2.66?
"I haven't had a chance to look into this for a while. Things have been busy at work. Hopefully this weekend I'll be able to take another poke at it."
Feb 13, 2013
Robert Baumgartner replied to Robert Baumgartner's discussion Mediatek w/ U-Center?
"That's what I thought but thought I would ask anyway. u-Center is a much better program than the MiniGPS! Thanks for the quick answer."
Nov 16, 2012

JDrones
Jani Hirvinen replied to Robert Baumgartner's discussion Mediatek w/ U-Center?
"No it's not. u-Center is specially designed for uBlox chips and not to anyone else. "
Nov 16, 2012
Robert Baumgartner posted a discussion

Mediatek w/ U-Center?

Is is possible to test the Mediatek GPS w/ the u-center software? I've tried connecting w/ FTDI but u-center won't display any data (even though 3D-Fix light goes solid and u-center reports the connection as good; green-light blinking @38,400bps).Is there an additional step to make it work?See More
Nov 16, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion Will 5v FTDI Fry my board(s)?
"Screw it I ordered a 3.3v cable just to be sure. Would be nice to have more action in the tech. support forum though..."
Nov 14, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion HIL Output from ArduPlane 2.66?
"There's an issue for this here: https://code.google.com/p/ardupilot-mega/issues/detail?id=633 The APM does seem to initialize after performing some action (eg. mode change) but I still can't get any RC input/output values using joystick…"
Nov 14, 2012
Robert Baumgartner replied to gregmaan's discussion Trim values from RC at boot time in 2.65 and 2.66
"That's correct when switching modes, but not at startup. trim_radio() does not check the TRIM_AUTO parameter (but it should!) so when called by startup_ground() it resets the values every time. The following code says it all: From…"
Nov 14, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion HIL Output from ArduPlane 2.66?
"Notice all of the chxin, chxout, hilchx values are null; setting a breakpoint in MissionPlanner for the incoming MAVLINK_MSG_ID_RC_CHANNELS_SCALED shows it never arrives. I still haven't been able to locate where in the firmware this is being…"
Nov 14, 2012
Robert Baumgartner replied to gregmaan's discussion Trim values from RC at boot time in 2.65 and 2.66
"I commented on this here: http://diydrones.com/forum/topics/apm2-pid-settings-reset-after-power-cycling You need to comment out this line in the ArduPlane firmware: In system.pde: // read the radio to set trims // ---------------------------…"
Nov 14, 2012
Robert Baumgartner posted a discussion

HIL Output from APM2?

I've been working on configuring the ArduPlane firmware to handle joystick-only control a little better. So far all has been going well but now I've run into a bit of a roadblock with HIL simulation (using X-Plane).Looking through the code it looks like MAVLINK_MSG_ID_HIL_CONTROLS is used to send the positions back to MissionPlanner, which then passes it along to Xplane inputs. My problem is that so far I haven't been able to find where the messages are sent out from ArduPilot. I found all the…See More
Nov 12, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion Please help! APM2 Barometer/Altitude Issues
"Okay thanks; I guess my expectations were just too high. Now at least I know my APM2 is working and not broken! Anyway I guess I know what I'll be buying next :)"
Nov 11, 2012
Craig Fraser replied to Robert Baumgartner's discussion Please help! APM2 Barometer/Altitude Issues
"The "altitude" reading will change for a given location as the barometric pressure changes i.e. the weather. Good luck if you think you're going to get an altimeter that's accurate to within a foot for $200, never mind attached…"
Nov 11, 2012
Robert Baumgartner posted discussions
Nov 11, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion APM2 PID Settings reset after power cycling
"Just another quick note; it looks like at one time or another RC trim was commented out by somebody... In system.pde: // read the radio to set trims // --------------------------- trim_radio(); // This was commented out as a HACK. Why? I…"
Nov 8, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion APM2 PID Settings reset after power cycling
"I found a ticket for this so it looks like a known issue with APM2 joystick-only control: http://code.google.com/p/ardupilot-mega/issues/detail?id=792 I took a look at radio.pde and found that trim_control_surfaces() is saving new values read from…"
Nov 8, 2012
Robert Baumgartner replied to Robert Baumgartner's discussion APM2 PID Settings reset after power cycling
"I did erase and reset through the CLI (in that order) after downloading the latest MissionPlanner (1.2.18) FORMAT_VERSION is 13 Wrote my PID settings and verified they were correct through CLI. Disconnected MissionPlanner, then APM2 USB. After…"
Nov 8, 2012

Profile Information

About Me:
I'm a .NET programmer working in manufacturing design automation and full-time techno geek.
Please tell us a bit about your UAV interest
Drones are a perfect way to tie my interests in programming and electronics together and have fun in the process!

Comment Wall

  • No comments yet!

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service