Steven G
  • Laguna Niguel, CA
  • United States
Share Twitter

Steven G's Friends

  • Mike Klinefelter
  • Mohcine
  • iskess
  • Scott Gardner
  • James Bennet
  • Rob_Lefebvre
  • bc6
  • Andrew Tridgell
  • Jani Hirvinen
  • Paul Marsh
  • Dean

Steven G's Groups

Steven G's Discussions

Pixhawk Aux

Started 19 hours ago 0 Replies

If this is the wrong place to post this question, please excuse me.I'm fairly able on the Pixhawk but I seem to be having trouble getting a couple more PWM channels out. I thought I understood the…Continue

Failsafe, then crash

Started this discussion. Last reply by Steven G Oct 8. 33 Replies

Hello,I need a bit of help. Today, after 2 years and 100's of flights, I lost my plane due to low RSSI Failsafe. The problem is, I failed but not safe.The low RSSI happened without warning. It was…Continue

Terrain Following

Started Sep 14 0 Replies

Those who have successfully tried TF, would you mind making a little step by step? I have tried it and found the documentation lacking and the results, mostly unexpected. So, if someone can start by…Continue

 

Steven G's Page

Latest Activity

Steven G posted a discussion

Pixhawk Aux

If this is the wrong place to post this question, please excuse me.I'm fairly able on the Pixhawk but I seem to be having trouble getting a couple more PWM channels out. I thought I understood the process, using MP planner to assign channels to the Aux 1-6.I'm trying to add 2 Ch to Aux 1 & 2. I've activated them in MP via a "1" in RC9 & RC10. But servos attached to Aux 1 & 2 don't respond?Any help appreciated.If there's a better place to post, please advise. Maybe MP or…See More
19 hours ago
Steven G replied to Gábor Zoltán's discussion Adding extra functions to MinimOSD
"I should have said for Plane."
Oct 10
Steven G replied to Gábor Zoltán's discussion Adding extra functions to MinimOSD
"Can someone say which FW/Char. Set/Programing tool works for sure? Also, is there a way to get the new PH Terrain Follow to read out on MinimOSD? Thank you so much!"
Oct 10
Steven G replied to Steven G's discussion Failsafe, then crash
"Iskess, thank you for your reply. Normally, I use telem and use MP as "black box" flight recorder. This time I was going for a short flight and used only the OSD. I also recorded the video feed. The settings on the flight that crashed,…"
Oct 8
iskess replied to Steven G's discussion Failsafe, then crash
"Since the log you posted isn't from the ill fated flight, there isn't much to take from it other than extracting the parameters. I'm not seeing any issues with your settings. You had it configured to CIRCLE upon FS_SHORT which is what…"
Oct 8
Steven G replied to Steven G's discussion Failsafe, then crash
"Thanks for the support. Just as background, I have a pilots license. I flew small, fixed wing, planes. I would classify myself as a very cautious FPV pilot but not infallible. In this instance, I suppose one could claim pilot error for getting into…"
Oct 7
Mark Jacobsen replied to Steven G's discussion Failsafe, then crash
"> your disappointment shoud be in your own inability to RTFM, and test features before depending on them, aka, flying responsibly. This is Mark Jacobsen, the US Air Force flying safety officer who wrote the aforementioned post about the many…"
Oct 7
Steven G replied to Steven G's discussion Failsafe, then crash
"Tridge and Iskess, On the last post of page 1, I supplied a recent tlog. I would be very appreciative if either of you have a moment to review it. I still can't figure out what went wrong. If I made a mistake or there is an error in the code,…"
Oct 7
Steven G replied to Marc Mosk's discussion Can This Be True.....Lets hope the DOTS dont connect.......
"Hmmm...even if the suppositions are true, which is highly unlikely, would it necessarily be a bad thing. Science, as well as, economics abhors a vacuum. No 3dr, someone else will fill the void. The transition maybe a little painful but it can and…"
Oct 7
John Dennings replied to Steven G's discussion Failsafe, then crash
"Andre K. > your disappointment shoud be in your own inability to RTFM, and test features before depending on them, aka, flying responsibly.   You may want to read (or re-read) the link mentionned above from that US Air Force pilot. Or maybe…"
Oct 6
Steven G replied to Steven G's discussion Failsafe, then crash
"Yep, that's why I was excited about the Terrain Follow feature on Pixhawk. But something did not follow the script."
Oct 6
Steven G replied to Steven G's discussion Failsafe, then crash
"You need therapy if question marks and the word disappointment triggers a tirade...I hope you don’t have any small animals! Perhaps you didn't see that I've been flying  FPV for years, with almost 1,000 flights and this is the…"
Oct 6
Steven G replied to Steven G's discussion Failsafe, then crash
"Iskess, Thanks. That's exactly what I concluded yesterday. On my next build I'll test out the "RC FS" in that manner."
Oct 6
Andre K. replied to Steven G's discussion Failsafe, then crash
"I know, multiple exclamation marks, question marks and "dissapointment"  triggers me pretty well :) Safety is an issue that deserves some extra attention, because we all can/do suffer from bad publicity in this business."
Oct 6
Hein du Plessis replied to Steven G's discussion Failsafe, then crash
"It's happened to me twice where my failsafe kicked in and APM tried to return to default altitude, problem was I was over a hill, so it cratered. Since then the APM code was changed and it would use the glide slope to come back."
Oct 6
Andrew Rabbitt replied to Steven G's discussion Failsafe, then crash
"That's being a bit harsh, Andre.  We'll all make mistakes in these endeavours and pay for them, hopefully only with broken parts."
Oct 5

Profile Information

About Me:
FPV interests
Please tell us a bit about your UAV interest
APM2 is useful for FPV and RTH. Want to learn more...
Hometown:
SoCal USA

Comment Wall (5 comments)

At 12:04pm on August 2, 2012, James Bennet said…

Thanks for the reply and the advice Steven. I *think* I've gone through your checks correctly. Just in case you're able to it would be great if you could let me know if there's anything obvious I am missing here. I've now tried 2 XP machined and 1 Win 7 laptop...

Symptoms: Steady Green LED’s so the units have binded. Units data read but won’t connect in Mission Planner 1.2.1 Mav 1.0

 

APM2 not connected via USB, although it works when it is.  

 

My settings:

 

Using Com 4 set to 57,600, or Com 13 on a Win 7 laptop.

Installed FTD2XX on XP and Win 7.

 

Via 3DR application;

 

Unit One:

SiK 1.5 on HM-TRP

S0: FORMAT=25

S1: SERIAL_SPEED=57

S2: AIR_SPEED=64

S3: NETID=25

S4: TXPOWER=11

S5: ECC=0

S6: MAVLINK=1

S7: OPPRESEND=1

S8: MIN_FREQ=433000

S9: MAX_FREQ=434800

S10: NUM_CHANNELS=50

S11: DUTY_CYCLE=100

S12: LBT_RSSI=0

S13: MANCHESTER=0

S14: RTSCTS=0

 

Unit Two:

SiK 1.5 on HM-TRP

S0: FORMAT=25

S1: SERIAL_SPEED=57

S2: AIR_SPEED=64

S3: NETID=25

S4: TXPOWER=11

S5: ECC=0

S6: MAVLINK=1

S7: OPPRESEND=0

S8: MIN_FREQ=433000

S9: MAX_FREQ=434800

S10: NUM_CHANNELS=50

S11: DUTY_CYCLE=100

S12: LBT_RSSI=0

S13: MANCHESTER=0

S14: RTSCTS=0

 

Click reset on APM2 as some suggest. APM 2 powered by ESC, blue GPS lock ok. SERIAL3_BAUD: 57.

 

Both units flash red when reading. Upgraded Firmware on both.

 

I am completely out of ideas :-(

At 1:47am on August 3, 2012, James Bennet said…

You make some excllent points there. I will ensure all the settings are the same. With regards to the Port Settings I've set everything to the same speed, 57 across the board. MP can deffo read the radios so they are working which is encouraging. Power is set to 11 as I am in the UK. I'll pump it up to test though. 

I dont get flashing red on the air side, so I wonder if APM2 is throwing data at it? When working does the airside start flashing red even before MP is connected? Or does it wait for the handshake and connection to be estabilshed before it starts sending data? I am wondering if I need to do anything to get the APM2 to start sending telem data to the radio.

The connections look fine, the TX/RX leads are crossed. Good point though, that would seem like the obvious problem.

Most interestingly you mention that you need to hit "connect" in MP, there seems to be conflicting info on this on the forums and even MP itself has a pop up saying it's not required unless using mavlink. The Com port and Baud speed must be set right as I am getting the settings from the radio's when I hit load. When hitting connect I get a timeout after 30 secconds. I've seen people mention heart beat messages but I've not seen where they are displayed.

Thanks again for all your advice, I'll try setting all the remaining settings the same, bump up the power, and try to hit connect more often. Failing that I've emailed the support team earier in the week so I hope they may get back to me at somepoint soon.

James

At 7:42am on August 3, 2012, James Bennet said…

Steven,

Almost got it... the telem lead I was using had the TX/RX ports crossed, using another lead where they are not the red light on the air side radio flashes away.

The problem I have now in MP is a "serial link isn't fast enough" regardless of what settings I use. Anyway at least I am on the right track now.

Thanks for all your advice and help,

James

At 9:04am on August 3, 2012, James Bennet said…

Right all up an running, the only issue is getting a GPS lock when using the radios/powered by the ESC but that seems to be a common problem.

Thanks again,

James

At 9:01pm on August 21, 2012, Dean said…

Hi Steven,

Sorry you are having this problem.  Can you send a clear macro closeup from a good camera and lighting of front and back of the PCB? 

Dean

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

© 2014   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service