Steven G
  • Laguna Niguel, CA
  • United States
Share

Steven G's Friends

  • Mike Klinefelter
  • Mohcine
  • iskess
  • Scott Gardner
  • James Bennet
  • Rob_Lefebvre
  • bc6
  • Andrew Tridgell
  • Weiliang
  • Jani Hirvinen
  • Paul Marsh
  • Dean

Steven G's Groups

Steven G's Discussions

Bad AHRS, Bad Accel Health, Bad Gyro Health

Started Feb 15 0 Replies

I recently started getting numerous "Bad ___ Health" warnings. When I roll back the FW to 3.1.1, they stop. Does anyone know what's up?I see that Bad Accel Health is a big topic right now. It may be…Continue

Latest release 1.3.16 WP table something wrong.

Started this discussion. Last reply by iskess Dec 12, 2014. 4 Replies

I just updated MP to 1.3.16 and the WP altitude, command table is scrunched up in the left hand corner. I need to revert as the table cannot be used.Continue

Low Level Long Period Y axis oscillation

Started Nov 29, 2014 0 Replies

Hello,I'm not sure if this is the right place to ask this. I have my Bixler pretty much tuned but have noticed a long period vertical oscillation. It's very minor but shows up in otherwise great HD…Continue

Serious Problem in the current beta MP

Started this discussion. Last reply by Steven G Nov 16, 2014. 6 Replies

I was having many problems with 3.1.11 MP release. So, rather stupidly, I updated to the latest beta. Most of my prior issues were gone, good.I do a pre-launch calibration after the accels and…Continue

 

Steven G's Page

Latest Activity

Steven G replied to Gábor Zoltán's discussion Adding extra functions to MinimOSD
"I'm fairly certain on the Pixhawk there is no need to adjust the settings. I've never adjusted mine and the MinimOSD works fine. Of course, it won't hurt anything if you do change as recommended above."
Thursday
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Download logs in MP using Data Flash Log Tab. You can analyze and graph them from there as well."
Feb 22
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Did you try the method suggested above? That is, shorting the PM input to bleed off any charges which seem to affect IMU2. It has worked for a lot of people."
Feb 22
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Quite awesome. Good stuff!"
Feb 19
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"This is a fantastic find!! It explains my issues much better than the "micro-fractured" solder joints. This is along the lines that I suggested in an earlier post. Great detective work. Since "shorting" the Vcc connection…"
Feb 19
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Just curious, what led you to this approach?"
Feb 19
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Rob, First, I fly fixed wing but commenting, seeking help in a copter thread. There may be differences by virtue of the FW. That said, my specific experience wrt "bad accel health" does not lead me to conclude there is a solder joint…"
Feb 19
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Craig, Thanks for the input. Are you stating that the IMU failures have not been intermittent? When they fail, they fail hard and not soft? I guess I didn't understand it that way. Further, by deduction, the failures or should I say warnings,…"
Feb 18
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"You were not out of line. My point was simply I am not certain the root cause has been found. Maybe I just haven't seen all the facts and data. None the less, intelligent and polite discussion, including challenging hypotheses, makes for more…"
Feb 17
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Huhh? So if the problem is intermittent and one sends the log that happens to be when the accel is operating within normal limits, is it an okay accel? If only some small number of accels were affected by a solder joint anomaly due to an incorrect…"
Feb 17
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"I'm also a EE. I've worked on many detailed Failure Analyses, as well. A cracked solder joint on a SMT device could show up as intermittent with vibration or thermal excursion. In fact, I have seen this before. One could stretch and say…"
Feb 17
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Are you saying only accel x acts up and not Y and Z? It's very strange that rebooting can clear the problem. Of course, I am not privy to the root cause of the failure, the manufacturing process that Craig has alluded to. Your point is also…"
Feb 17
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Craig, et al, I sounds like 3DR has determined the root cause of this issue and contained it. Can we assume that all Pixhawks that are currently shipping have been screened for the Accel anomaly? Thanks!"
Feb 17
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Today, I flew my plane with the same Pixhawk that had Bad ___ Health warnings. Latest MP and 3.2.2 plane FW. This time, I had only a bad AHRS warning. I believe this was do to the GPS not having sufficient sats and/or HDOP. The warning did not go…"
Feb 17
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"I would contact tech support first. You do hav Pixhawk? Not a ***hawk?"
Feb 16
Steven G replied to ThatJoshGuy's discussion Pixhawk BAD ACCEL HEALTH APM 3.2 - collecting data
"Read Craig's replies to my questions above. I think the answer you seek is there. Short answer, rapid temp. changes affect some sensors, causing instability."
Feb 16

Profile Information

About Me:
FPV interests
Please tell us a bit about your UAV interest
APM2 is useful for FPV and RTH. Want to learn more...
Hometown:
SoCal USA

Comment Wall (5 comments)

At 12:04pm on August 2, 2012, James Bennet said…

Thanks for the reply and the advice Steven. I *think* I've gone through your checks correctly. Just in case you're able to it would be great if you could let me know if there's anything obvious I am missing here. I've now tried 2 XP machined and 1 Win 7 laptop...

Symptoms: Steady Green LED’s so the units have binded. Units data read but won’t connect in Mission Planner 1.2.1 Mav 1.0

 

APM2 not connected via USB, although it works when it is.  

 

My settings:

 

Using Com 4 set to 57,600, or Com 13 on a Win 7 laptop.

Installed FTD2XX on XP and Win 7.

 

Via 3DR application;

 

Unit One:

SiK 1.5 on HM-TRP

S0: FORMAT=25

S1: SERIAL_SPEED=57

S2: AIR_SPEED=64

S3: NETID=25

S4: TXPOWER=11

S5: ECC=0

S6: MAVLINK=1

S7: OPPRESEND=1

S8: MIN_FREQ=433000

S9: MAX_FREQ=434800

S10: NUM_CHANNELS=50

S11: DUTY_CYCLE=100

S12: LBT_RSSI=0

S13: MANCHESTER=0

S14: RTSCTS=0

 

Unit Two:

SiK 1.5 on HM-TRP

S0: FORMAT=25

S1: SERIAL_SPEED=57

S2: AIR_SPEED=64

S3: NETID=25

S4: TXPOWER=11

S5: ECC=0

S6: MAVLINK=1

S7: OPPRESEND=0

S8: MIN_FREQ=433000

S9: MAX_FREQ=434800

S10: NUM_CHANNELS=50

S11: DUTY_CYCLE=100

S12: LBT_RSSI=0

S13: MANCHESTER=0

S14: RTSCTS=0

 

Click reset on APM2 as some suggest. APM 2 powered by ESC, blue GPS lock ok. SERIAL3_BAUD: 57.

 

Both units flash red when reading. Upgraded Firmware on both.

 

I am completely out of ideas :-(

At 1:47am on August 3, 2012, James Bennet said…

You make some excllent points there. I will ensure all the settings are the same. With regards to the Port Settings I've set everything to the same speed, 57 across the board. MP can deffo read the radios so they are working which is encouraging. Power is set to 11 as I am in the UK. I'll pump it up to test though. 

I dont get flashing red on the air side, so I wonder if APM2 is throwing data at it? When working does the airside start flashing red even before MP is connected? Or does it wait for the handshake and connection to be estabilshed before it starts sending data? I am wondering if I need to do anything to get the APM2 to start sending telem data to the radio.

The connections look fine, the TX/RX leads are crossed. Good point though, that would seem like the obvious problem.

Most interestingly you mention that you need to hit "connect" in MP, there seems to be conflicting info on this on the forums and even MP itself has a pop up saying it's not required unless using mavlink. The Com port and Baud speed must be set right as I am getting the settings from the radio's when I hit load. When hitting connect I get a timeout after 30 secconds. I've seen people mention heart beat messages but I've not seen where they are displayed.

Thanks again for all your advice, I'll try setting all the remaining settings the same, bump up the power, and try to hit connect more often. Failing that I've emailed the support team earier in the week so I hope they may get back to me at somepoint soon.

James

At 7:42am on August 3, 2012, James Bennet said…

Steven,

Almost got it... the telem lead I was using had the TX/RX ports crossed, using another lead where they are not the red light on the air side radio flashes away.

The problem I have now in MP is a "serial link isn't fast enough" regardless of what settings I use. Anyway at least I am on the right track now.

Thanks for all your advice and help,

James

At 9:04am on August 3, 2012, James Bennet said…

Right all up an running, the only issue is getting a GPS lock when using the radios/powered by the ESC but that seems to be a common problem.

Thanks again,

James

At 9:01pm on August 21, 2012, Dean said…

Hi Steven,

Sorry you are having this problem.  Can you send a clear macro closeup from a good camera and lighting of front and back of the PCB? 

Dean

You need to be a member of DIY Drones to add comments!

Join DIY Drones

 
 
 

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Drone Delivery Challenge, is here

© 2015   Created by Chris Anderson.

Badges  |  Report an Issue  |  Terms of Service