Just another ArduPilot flight test... with on board & HD ground video, see tip stall recovery...

ArduPilot_251 flight test with AP Throttle control from Mark Colwell on Vimeo.


ArduPilot 251, ArduIMUv1, Shieldv1, uBlox, Elevon mixing on a Stryker II with onboard video and HD ground video, sorry no telemetry. Winds 10-15 with some gusts to 20mph. Tip stall due to low throttle center speed setting and maneuvering in Fly-By-Wire mode. Next flight I climbed to safe altitude then landed in Stabilize mode with throttle cut off. Landing was smooth in gusty conditions! Next time testing with latest rev and more power for a longer flight, maybe fly to to some waypoints too...

ArduPilot 251 test flight with AP Throttle control HD ground video from Mark Colwell on Vimeo.



Views: 165

Tags: 251, ArduIMUv1, ArduPilot, Elevon, II, Shieldv1, Stall, Stryker, Tip, mixing, More…recovery, uBlox


Developer
Comment by Mark Colwell on March 10, 2010 at 9:18am
Alex,
I plan to use Sony Webbie for on board HD recording and standard NTSC video out for FPV on 910mhz Tx
Ground video was made with this camera too. I also have Jazz 178 HD and DXG-567V HD cameras both work great, but don't have a tilt head.

Developer
Comment by Mark Colwell on March 10, 2010 at 9:34am
I will pass on any compile errors/ fixes with my config.h file. on file rev I down loaded yesterday.
This is r842 renamed to ArduPilot_251_2 for my local use.
I want to move onto your latest code with Elevon settings.
Looks like Jason made more gps sim &parser fixes now were at rev r846

Current compile error:
.../core.a(wiring.c.0): In Function 'millis':
.../wiring.c:66: multipule definitions of 'millis'
.../ArduPilot_251_2.ccp:3821: first defined here

Thanks, I am uploading throttle & alt hold changes to Stryker II for some testing, its cold here with no wind...
last test flights only used 510 mah...
Hope to fly for 4 mins..
Comment by Rana on March 10, 2010 at 10:05am
Mark, wonderful videos and great work by you !

Developer
Comment by Mark Colwell on March 10, 2010 at 12:23pm
Got TM working now, xBee needed firmware reset again.., but it is sending mixed binary and ASCII, will t/s later after I fly new PID setting for throttle & pitch & nav. Off to field now as wind is picking up and starting to gust..

Developer
Comment by Mark Colwell on March 10, 2010 at 4:18pm
Stryker II only has a few more landings left, like this one...

System damage reports:
Power train,
APC 7x4 EP prop broken off both sides, replace with APC Gas 7x3 $1.95
Motor mount ripped off, $2 flexable superglue and carbon fiber, New mount for contest $5
2250 mAh test battery has one bad cell now, $60 new 4s 2650mAh 40c for contest

Structural,
starboard side,
Tears in foam on both sides of vertical fin up to spars, $1 Liquid Nails or lo temp hot glue.
New foam body $21 for contest.
Control horn ripped off, but still on wire z bend, $0.50 superglue and add some carbon fiber.
Stripped servo plastic gears, replace set $2.49

Made several test flights, my observations:
1. Don't flight test with a weak or old battery
2. make smaller PID p changes, over correcting in pitch and over powered throttle in FBW mode
3. Start FWB mode at about 150' when testing throttle or pitch PID changes, 50' higher than normal
4. Train left hand Learn to use Mode switch when panic ensues, place in Manual vs FBW and relax
5. Don't ground test with a weak or old battery
6. Flying in snow is fun!

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2014   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service