1/ Software Update on the integration of Remzibi OSD and APM

I am just updating Blake's and binzi's Blog contents:  Blake and binzi

I do not know how to make a firmware for APM Planner, so you will need to use Arduino GUI tool

 

Replace your ArduPilotMega folder with the ArduPilotMega folder from APM2.1.2-OSD.zip:  APM2.1.2-OSD.zip

 

Configure the APM_Config.h to your need

//to deactivate use OSD_PROTOCOL_NONE
//#define OSD_PROTOCOL OSD_PROTOCOL_NONE
#define OSD_PROTOCOL        OSD_PROTOCOL_REMZIBI

// port 3 is the telem port on the shield
#define OSD_PORT            3

// set a radio switch to activate/deactivate the OSD output :

// below 1450 will display the OSD

// above 1450 will stop displaying the OSD

#define OSD_MODE_CHANNEL    6

// choose your unit to display the disctance to waypoint in feet or meter
#define OSD_UNIT            OSD_UNIT_METER
//#define OSD_UNIT            OSD_UNIT_FEET

Then follow the normal process from the wiki above.

http://code.google.com/p/ardupilot-mega/wiki/Code

 

2/ Hardware

To connect your APM with the Remzibi OSD, you need to have a cable from Telem port to Remzibi GPS port. GND and TX (from APM) are enough.

If you do not see any OSD info at first, stop your camera feed to see if the OSD shows up anything. You might be starting in the wrong TV mode (PAL/NTSC). You just have to push the OSD button for about 1 second.

 

3/ Remzibi

You need to use Remzibi OSD software from Remzibi site and update your layout with APM.bin and flash the firmware using ARDU firmware (Announcement) in the same software.

Note: for metric or feet units , be carefull to use the right unit in the Remzibi OSD software. You need to change the APM_Config.h for feet/meter of the next waypoint in the status at the bottom

 

4/Usage

Once everything is connected, normally the APM sets HOME for the OSD once it gets a GPS_fix. If you connected your OSD after that, then you can just push the OSD button once to force the HOME location on the OSD.

The arrow and distance from home will always display home direction and distance to home direction. It won't show the next waypoint direction (too complicated yet )

 

5/ what's new

I have updated all the units and it should be displaying proper values now

 

Views: 4127

Comment by Matthias Badaire on June 15, 2011 at 2:34am

@Peter : Thanks for the bin

@Luke: If you use a laptop on the field and it might make sense indeed.

Or (like me) you do not take a laptop and you want to keep it lightweight, then using xbee makes no sense as :

- you need to add xbee on the plane

- xbee on the ground

- an OSD on the ground.

You do not save weight on the plane and have a new source of interferences in your vehicule.

For reference about OSD from diydrone, check the last part of the announcement here :http://diydrones.com/profiles/blogs/diy-drones-2011-product

@Johann:

- did you flash the OSD using ardupilot layout (menu->View->OSD Layout->Ardupilot)

- do you have home set : click once the button on the osd to set home. AH does not show until home is set

Comment by Luke on June 15, 2011 at 1:12pm
Matthias, thanks for that link. I had not been subscribed to blog posts at that time so I missed it - very informative, and very exciting stuff coming our way.

For FPV I would only want the OSD on the plane, but for UAV stuff I am going to have telemetry anyway. Sometimes I will have a camera on board my UAV, so in these cases, OSD on the ground might be less hassle.

I am going to test, but will also be excited to see DIY Drones OSD when it comes out.
Comment by Whooper on October 8, 2011 at 4:25am

Hi, I followed the instructions above (using latest 2.24+remzibi code), flashed the OSD with APM.bin and connected gnd and tx (out) from APM. OSD output shows ardupilot configuration correctly on the screen but no data is received from the APM. Also channel 6 has no effect. Anything different required in the set up for the latest code?

Comment by Hubert Czajczyński on October 28, 2011 at 10:33pm

Mathias, Tutorial says to connect APM to OSD via telemport but on my board i don't see any ports or pins on telemport. Do i have to solder a pins to that ?

 

Greetings

Comment by Matthias Badaire on October 29, 2011 at 6:37am
Yes you have to solder some pins on it.
Comment by Hubert Czajczyński on October 31, 2011 at 8:22am

OK thanks, which version of remzibi OSD firmware are You using ?? Do i have to download completly new firmware or just .bin ??

Comment by spagoziak on November 23, 2011 at 12:27am

Is it possible to connect both a generic xbee (like the one from goodluckbuy) and remzibi simultaneously?  Something like make a Y line out of serial tx and send it to both rem and xb, then ground them all the same, and send the ard tx to the xb rx?  

Comment

You need to be a member of DIY Drones to add comments!

Join DIY Drones

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service