Thanks for the good feedback - I think this small update should address most comments... 1.6.02 now up on google.  If you joined the beta test group give it a few hours and it should automatically go to your phone (or you can log in and force an update).

# 1.6.02
* Fix problems where the screen joysticks directions could be reversed
* Add an on-screen panic button to cancel RC override
* Allow phone sized devices to show joysticks (in landscape orientation)
If someone else can confirm that the screen joysticks work well for them (_be careful_) I'll promote this build to not be a beta...

Views: 480

Replies to This Discussion

Thanks Kevin for this update!

Hi Kevin,

My thoughts on 1.6.02

1) Portrait mode on Nexus 7 no longer works. Just a black screen with no Google Earth and one can not switch between screen modes like before

2) Throttle - zero at midstick is a bit bothersome as it is VERY easy to drop the throttle to zero without even hardly trying

3) Yaw scaling is not proportional to joystick input. zero to max in a heartbeat

4) Servo directions ARE working properly now.

5) It appears that the joystick issue of being greyed out and only randomly appearing is now fixed on Nexus 7

6) Disconnect button works like a charm

Couple of concerns:

Is there a way to program a "lock" on landscape mode when using joystick? I did have the program bomb ("Unfortunately Andopilot has stopped working" message) when I switched from landscape to portrait (I tried this even though portrait mode is not working for me). My fear is that there will be a glitch on transfer from landscape mode to portrait mode which could render the disconnect unusable , thereby no control from any source.

And lastly, probably not possible,... but what to do if Andropilot does bomb while on joysticks? Not sure if there is a clever way to program the model to go into some kind of failsafe...

Thanks for the improvements! Andropilot is exciting!


My Comments on 1.6.02

First Kevin thanks for a great app....I am running megapirateng on a crius v2 board....9xr radio...I have both a Pipo-s2 and a Droid Razr Maxx.with 3dr Bluetooth bridge connectivity...I can't get the joystick to appear on Razr Maxx 4.2 screen...On the Pipo with a 4:3 1024X768 screen it looks a little cramped when I I turn on joystick...not sure you have config for 4:3 1024x768 any event the joystick will appear on pipo but when I try to throttle up the motors do not spin....I can use RC 9xr with no problems....I did notice that the copter will disarm sometimes when I tried to use rc panic all this could be related to megapirateng but andropilot has worked flawlessly with it up till now...I also have a Galaxy 2 which I will test with later and report back to you...Regards,Paul

On more careful review the layout on pipo for joystick is fine...only left yaw arrow overlaps the letter e in throttle...probably not an if I arm with andropilot on pipo S2 the joystick doesn't work...then I hit panic button to disable...copter stays armed and when I throttle up with 9xr instead the motors spin...however as soon as I throttle down to zero copter automatically disarms...hope this helps in debug...let me know if you would like me to test further...

hmm - can you point me at the source code for the megapirate ng?  I bet they might not support the needed RC_OVERRIDE message...


Here you go Kevin...let me know if I can be of further assisstance...

yep - I don't think there is much I can do - it looks like they removed support for the message we use to send up RC_OVERRIDE data:

interesting - I'll check on a nexus 7 tonight.  thanks for the great report.

On any orientation change I turn off stick overrides until you next press the stick.

If andropilot bombs, it will stop sending GCS heartbeats to vehicle.  after three secs vehicle will undo the overrides.

Hi Kevin can you point me to the place in the Arducopter code where this message is supported and its exact message name.. This is the function with OVERRIDE:

        // allow override of RC channel values for HIL
        // or for complete GCS control of switch position
        // and RC PWM values.
        if(msg->sysid != g.sysid_my_gcs) break; // Only accept control from our gcs
        mavlink_rc_channels_override_t packet;
        int16_t v[8];
        mavlink_msg_rc_channels_override_decode(msg, &packet);
        if (mavlink_check_target(packet.target_system,packet.target_component))
        v[0] = packet.chan1_raw;
        v[1] = packet.chan2_raw;
        v[2] = packet.chan3_raw;
        v[3] = packet.chan4_raw;
        v[4] = packet.chan5_raw;
        v[5] = packet.chan6_raw;
        v[6] = packet.chan7_raw;
        v[7] = packet.chan8_raw;
I find this function in both Arducopter and Megapirate...perhaps I am not finding the correct one in Arducopter?

oops!  I must have mis-grepped, I didn't find that version in megapirate when I searched the first time.  Can you send me a param file from your vehicle?  My new theory is that one of the params I look for to do joystick 'safely' is missing...

thanks for the portrait thing!  Fixed a typo.  will be out with new button tonight.  I'll also change the range on throttle.

I think I just found it.  Does megapirate include "FLTMODE1 through 6" in your parameter list? (or MODE1 through 6)?  If it is missing I'll need to add a check for that...



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service