First let's not get crazy but I was so excite to get this installed and be done with my ground station setup.
I bought this apm switched and can't get it to work with my flysky re-i6s I tried on one of the switches but it only sent the signal for 1000/15000/2000 Pwn signals
But at least it was lighting the lights on it correctly but only send those three signals

Then I tried the pot for channel 5 but the i6s operates a little oddly but I still think it's possible. I'm getting good volts but the lights aren't coming on. I can get the modes to move with moving the pot so I know the resistance is being sent correctly. So I think it's something with the pot telling the tx that's sending pwm and not voltage. So I'm just wondering how I can get it to send the right signal from either straight from the switcher or from the pot.

INSTALL INSTRUCTIONS::: SEE PIC WITH MARKUPS

Views: 736

Attachments:

Reply to This

Replies to This Discussion

I've had a similar issue with the same mod (taranis though). On my taranis two of the wires were mislabeled.
I think it was ground and signal, but check with a multimeter.
I removed the pot completely and rewired the mode switch in its place, (crossing the mislabeled wires) then everything worked as it should.
If that fixes your problem, donate the $10 to Ardupilot.org
I've tried directly connecting the wires in several configurations straight to the connections that go to the board. What's the proper way to check with my multimeter. I've gotten the bolts to change with the movement of the pot. I'm wondering if since the resistance is changing that I need to have a way to feed from the pot on high to the switcher input so then it's regulating from the switcher and not from the pot.

Hello Seth,

Your topic is interesting :D lol, but thanks, i came to help only..

Did you recalibrate your TX in the mission planner, before u do this make sure the channel 5 is functioning, for exp: simply connect a servo to ch5 and see if it moves, if so then do the calibration,, Because i had a similar problem that the switch is not working in the plane, but the mission planner shows the modes are changing, so i re-calibrate the radio in the mission planner so the APM will read ch5.

Good Luck.

Best Regards

you need to remove the pot: having the mode switch and pot in either series or parallel is asking for problems.  To test with a multimeter, the easiest way in this case is to assume that the Vcc wire is Vcc, and check to see which of the other two has the lowest resistance.  Whichever it is will be GND, the other SIG.

Ok I figured it out after taking a break from it. Problem was that the switch wouldn't allow intermediate pwms. So, I focused back to the pot. You can't just hook directly up to the pot wiring because I think the resistance doesnt like getting filtered through the little microchip that turns it into a pwm signal (It MIGHT work fine if you just use that 6 position pot wiring with little resistors between each position, but this little board didn't like it). SO I wired directly from a 3.3v solder pad on the board and a negative solder pad on the board then only hooked up the signal wire directly to the signal input on the board plug. And BOOM the board lit up, and I could change the pwms live in mission planner. This i6s is the steal of the century with a 10 channel receiver. I know it's probably not as high quality as a futaba or spektrum but I love how programmable it is especially that I can directly hook it to my pc and it acts like a joystick with several inputs.
I've got some pics I took so others with this issue can solve it easily.
Thanks everybody for the input!

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service