This is the second time... First time burnt 1 Hitec servo, this time 2 Hitec servos

My setup:

Powering the APM 2.5 from two power sources, both 5v (removed JP2 of course)

Heli: Futaba RX with 3 - Hitec HS 5245 MG for the collective, 1 Futaba S9275 (its OK)

Also powered by USB (5v)

I had no problems having all three powering the APM at the same time...NONE...

My conclusion:

I had all three powers plugged in at the time, the only thing in common, that I can come up with in both situation... I did a "erase", "reset" then "reboot" to clear out the previous parameters.  Has anyone else experienced this type of problem??

Any in put will be appreciated.

Thanks, Brian

TREX 500 FB

Views: 2466

Reply to This

Replies to This Discussion

I fried a servo by shooting 100hz, but I take very long time.

Fried two more servos during setup.

I stated at the beginning “Powering the APM 2.5 from two power sources, both 5v (removed JP2 of course)” It should be JP1. Anyway, with both power supplies hookup, the problem happens when I plug in the USB and start the MP set up on the Heli. I had a digital volt meter and all sources were 5.0V. I decided to disconnect the power to the OUTPUT side and jumper the power from INPUT to OUTPUT…. Now just having one power source and the remaining servo seems to be fine when hooking up the USB and going thought setup. Looks like at least a “work a round”.

Waiting for more servos to do another test. $40 buck a servo is draining my hobby funds quickly.

Brian TREX 500 Futaba

Hi folks,

Now this is elementary, how to change the refresh rates of the servo connected from the mission planner. I already fried two futaba 3305 servos while testing on the bench. I use APM 2.5, 3DR 933MHz radio

Karthik,

      You can only change the refresh rate of channels 1 ~ 8 at the back of the APM by modifying the RC_SPEED parameter (default is 490hz).  The problem though is that it will affect the update rate to the motors as well so you could end up with lousy performance.  If you use channels 10 or 11 on the left side of the APM, they're update rate is 50hz but sadly you can't adjust it.

Hi Randy,

I could not find this parameter, i have loaded Arduplane firmware for it bcuz mine is a BWB a/c.

Hows it going?

I've burnt out analogue servoes, and no im on digital metal gears from hitech.. they dont seem to overheat or anything now, but theyre rather slow to respond and are not synchronised... no ideas what to do next..

Did you get any more info about your problem(s)?

This isn't scientific, but if you power up the servo and apply pressure to the servo arm with you finger so that the servo has to fight back to maintain the position, you will be able to feel/hear the servo arm pulsing at ~50hz on an analog servo. A digital servo will feel much smoother and have a more pronounced motor buzz because of the higher frequency internal motor drive.

Hi,

How can this be configuered in arduplane?

there is no RC_SPEED parameter.

Thx,

Gábor

I think plane always updates the servos at 50hz.  It may not be possible to adjust it for plane because generally the speed at which you need to update the control surfaces is much less than you need for a quad.

Thx Randy!

I wasn't sure about this.

It was strange that the first 4 channel is steady as a rock, but the last 4 is jumping randomly sometimes.

I was thinking if thies channels have higher rate like 100hz or more.

What is the difference rally?

Thx again,

Gábor

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service