Hi,

 

My setup is as follows

Easystar w brushless

APM with mediatek 1.6(updated firmware yesterday, went fine)

software is the 2.012 you get when you do "upload firmware" in the planner.

 

Manual works

Stabilize works

RTL works 

 

Auto works like this:

 

I make a a few waypoints, same alt (80 meters) and a few hundred meters apart (a triangle shape for example)

 

I take of on manual in some direction. Switch on "auto" and the plane make its way up to 80 meters and heads off to WP1.

 

After a circle around WP1 it heads of to WP2 but after a few seconds it looses alt in a "stairway" fashion but the direction to WP2 is correct. The throttle comes on and off during this.

 

Just before the plane reaches ground i can save the day by switching to RTL. Motor kicks in and up to 80 meters again and heads back home and loitering above my head.

 

I have checked the waypoints in the planner by read it back and it looks correct. Always 80 meter height.

 

Have anyone else had this experience?

 

All the best

 

Stefan

 

 

Views: 166

Reply to This

Replies to This Discussion

Are you using an airspeed sensor?

 

Do you have "Absolute Alt" turned off (unchecked) in the Mission Planner?

 

Have you tried an Xplane simulation? It would be interesting if you see the same problem there.

Thanks Chris,

 

No airspeed sensor yet (but i have one that i will install now)

 

"Absolute Alt" is checked

 

I will try Xplane

Try it with Absolute Alt unchecked. You're probably flying higher than 80 meters above sea level. Absolute Alt is ALT above sea level, ie, absolute, not relative to launch.

Ill try that.

 

Hey! XPlane is only USD 29! I thought it was like USD 99.

Success! I unchecked "Absolute Alt" and it did the waypoints. My life is complete!

Absolute Alt(itude) should not be used unless you have gone round and checked every waypoint height precisely. Otherwise uncheck Absolute Alt and it will be relative to you home location (which is setup during the startup process immediately after powering up the system).

This would make your 80m altitude plan be 80 metres above your home location and hopefully safer than its stairway descent plan :)

Also I you attach a log of the flight (however brief) that can help.

Glad its all working.

Thanks to the advice of this thread and several others from people who were confused by this issue, Michael Oborne has updated the Mission Planner to make Relative Altitude the default. You can download the new version 0.4.2 here:

http://code.google.com/p/ardupilot-mega/downloads/list
One last addition to this topic while it still is hot: Are the values for the loiter radius etc in feet or meter? My plane's loiter is almost aerobatic with very sharp turns. My radius value is 60 and i assumed this was in meter.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service