Hi all,

I have a pair of 433mhz 3DR radios. One of them "lost sync" during a firmware upgrade. Now it has the red led on solid whenever it is plugged in, and all attempts to communicate with it fail.

Is there any way to unbrick this radio?



Views: 1939

Reply to This

Replies to This Discussion

hmm - have you tried the "force bootloader mode" steps listed here? https://code.google.com/p/ardupilot-mega/wiki/3DRadio

Yep, just tried that, no dice I'm afraid.

If the red led is on solid then it means it is already in bootloader mode, and is waiting for a new firmware. So the real question is why it doesn't come out of bootloader mode when you upload a firmware.

What happens when you try to upload a firmware to it?

Cheers, Tridge

Well, before, it was saying "could not identify radio" after trying a few things. But I just tried again, and it programmed the radio just fine! I think I may have an intermittent solder joint issue. I keep reflowing the joints but the radio is not reliable... e.g. I think it lost sync when uploading firmware when I stressed the connector a little.

So, in summary, it's fine now, sorry to waste your time!

By the way, thanks for all your amazing work, Tridge!

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service