I was having some problems with my quadcopter (running the APM 2.5) shooting off in random directions when I put it in Loiter or RTL modes.

After doing some reading I came to the conclusion that this was probably due to interference having an effect on the built-in compass on the APM. I bought myself a nice new 3DR GPS module with the built in compass thinking everything would b resolved, but when i've tried to do the compass calibration to give me the magnetic declination offset numbers, the numbers are so crazy that that the AMP won't allow me to arm.

I've tried it several times, even went out into the middle of a field to do it, but the numbers that are returned are up in the thousands.

If disconnect the Mag lead from the APM, and select 'onboard magnometer' in the MP, and do the dance again, i can get much more sensible numbers (inside the recommended -150 to 150). 

The problem with this is that my quad still shoots off at top speed in a random direction when i put it in Loiter.

Any suggestions???? I assume he new GPS with compass module is compatible with the APM 2.5?

Views: 1471

Reply to This

Replies to This Discussion

Can you post a picture of your setup. It ususlly really helps with these kind of issues. Thx

One additional question to go with Bill's request for pics. Did you cut the "Jumper Trace" for the internal magnetometer to disable it? I just did this on my APM 2.5 and it made a world of difference in the "Auto" modes.

Link to instructions for cutting the trace: http://copter.ardupilot.com/wiki/common-external-magnetometer-for-i...

That's a good point and you can use the terminal to verify that you cut the track by typing test then compass if should fail to initialize.

Thanks guys, i'll try that. I must admit that's the first i've heard of having to cut a jumper trace. 

The coexistence of on board compass and external compass give you very odd result of compass calibration.

You may not cut the trace of internal compass trace on APM 2.5. However, sometimes the internal compass is appears even three times CUT and confirmed by microscope. There is some APM2.5 board that could not disable on board compass by cutting "Jumper trace". 

I have the same issue. I have cut the trace, and tested with Ohm meter, that there is no connection. And the internal compas is still active. If this is correct, how do we disable the internal compass.   

Thanks  HC

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service