So I finally added the 6th wire to my version 1 (3DR) telemetry radio and its not receiving any heartbeat packets. And if it does it takes forever to establish a link. Sometimes it only gets 1 Heartbeat packet.

Views: 1430

Attachments:

Reply to This

Replies to This Discussion

Show me picture of your connection (both ends - 3DR radio and PX)

.
Attachments:

So I tried the second suggestion first changing the parameters although I realized it was for 3DR radio + miminOSD, and it still doesn't work.. (I think maybe I should change the parameters back to the original.

How do I disable RTS/CTS (HW flow control) - where can I find this.

https://groups.google.com/forum/#!topic/drones-discuss/B65edf_LC9U

Beside this try to experiment with different SR* params (remember to use correct telemetry port).

I'm using telemetry port 1

Read Google groups thread I've posted above.

okay so its still not working here are the parameters I changed

Attachments:

Disable HW flow control for PIXHAWK: BRD_SER1_RTSCTS set to 0, BRD_SER2_RTSCTS set to 0.

Then disable this for 3DR Radio.

Like take out the RTS and CTS wire(s) out of the air radio so they aren't connected to the pixhawk?

It doesn't matter if you'll disable this params - they will be not in use anyway, but to make sure - you can disconnect them.

I set them to 0 but it still wont work... I don't want to really tamper with the 6 pin wire I just created. Is there any thing else I can do ?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service