Just downloaded 2.0.8 from the planner.  The winds here in the UK are making a real nuisance of themselves at the moment but despite the weather I was able to do a brief test and it flew okay in Stable mode.  However, I see that the yaw 'unwinding'* issue is still there.  Several people have mentioned this and yet it has remained a small but noticeable problem for some time.  Would it help if I made a short video of the problem so that the project team can see what is happening or is it a known and difficult issue to resolve?

Nigel

 

* The yaw unwinding issue as far as I'm concerned is where you provide a yaw command, the copter then rotates but when you release the rudder stick the copter rotates back in the direction it had come from around 10 or 20 degrees.

Views: 224

Reply to This

Replies to This Discussion

I have just tried it with the compass disabled and it doesn't seem to make a huge amount of difference.
I haven't tried altering the yaw PIDs.  This is for two reasons really - first, I have an absolutely stock quad and so I'm hoping that the code, when finished, will work well with it 'out of the box'.  Secondly, I don't have time at the moment to give such experiements a proper try.  That's why I'm really hoping we can get the Ardustation working - it will be a really neat way of quickly changing PID values without taking my precious PC out into the field.  (That's why I'm hoping Phillip Smith's Ardustation additions to the AC2 code will make it into the standard code.)
I'm trying to fly with 2.08 but I aways have the same problem: motors wont rise together when I increase throttle. When I upload the code from planner (0.4.35) it works fine, but when I download from arducopter download section "Arducopter 2.0.8.zip", compile and upload, it doesn't work properly.
The reason I need to use from source is that I'm using RFBee and not XBee for telemetry because RFBee doesnt have 57kbps, only 38kbps.
I'm used to the setup process and everything is very well configured, I'm sure there is something in the code or in default PID that makes it happen. When I download from planner it works fine, but I don't have telemetry...
Here is a picture of my sensors just after power on and arm motors:
Attachments:

Please update to 2.0.13 in the downloads section. Most of the Yaw problems are fixed.

Thanks!

Jason

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service