After a week spent working on my Arducopter 2, I have still failed to get it airborne and I've broken two props already. In the interests of other people avoiding the misery I've  had to go through, I'll post my lessons/experience here in a summarised form. The brevity of what I've written doesn't reflect the amount of effort put in, or combinations of solutions attempted. I'll conclude with that I think the problem is and I invite suggestions from more experienced users.

My first mistake was to not check that the GPS cable was plugged into the correct port. I believe my AC was shipped with it plugged into the incorrect port, and this prevented it from arming. I spent a long time trying to get the motors to arm, setting up again & again, trying different TX/RX combinations and even switching between two APM1.4s that I have. Eventually I pulled out the GPS and got it to arm, and that prompted Chris to suggest that I may have it plugged into the wrong port. Given that the ports on the IMU and the APM board are identical, some sort of warning about this in the 'Troubleshooting' page may be helpful.

However my problems were not over. I then could not get the AC off the ground - it flipped first time out and broke a prop. I went through the appropriate troubleshooting menu for flipping and wobbling and got no further.I decided to change radios from DX7 to DX8, because the latter has a throttle curve and permits very slow throttle advance - allowing one to catch a flip before it goes over and analyze it. I couldn't get an AR7000 or AR8000 to send signal to the APM, eventually an OrangeRX 9 channel worked. I did some slow 'flips' and noticed that it was pitch instability - in both directions, implying that the stabilizing compensation was reinforcing rather than offsetting a change. Roll and yaw stability seemed to be working.

I ran the latest firmware, reset everything and saw that various sensor feedbacks in the APM Planner were now garbage (fluctuating all over the place). I switched IMUs again, set everything up again, and my second IMU showed stable feedback although the compass on this one seems to be broken. Nevertheless, encouraged by the stable gyro feedback I decided to try to fly again. I set up and slowly raised the throttle, but although I tried to catch it, this also ended in a flip and another broken propeller.

This is about as much as I can stand at the moment. Given that there are two different issues on two different IMU boards & that I have ruled out all other options, I have to assume that they are both faulty. My question then is - has anyone else been sent out-of-box faulty goods by uDrones? Is quality control an issue? I don't know if sending the boards back to them will help, but maybe someone else has done this and had success?

I also fly a GAUI 330x with a HoverFly Pro board, and I also fly two MK hexas, so I'm not a total newbie when it comes to quads. I've just never had this many problems on any one project.

Views: 2281

Reply to This

Replies to This Discussion

Oh, also, triple check your esc/motor orientation (for +, ESC#3 should be forward CW, ESC#4 to the rear CW, with ESC#2 to port CCW and ESC#1 to starboard CCW) See


If these were swapped around, it could account for the behavior of tilting in the wrong direction I think...


I'm thinking you've checked all these, you are more experienced than I... but its worth mentioning at risk of annoying you :)

You know, that sounds almost like the APM was mounted backwards (or motors plugged in the wrong order). Are your front motors of your quad (is it a quad?) on channels 1 and 3, and rear motors in 2 and 4? If they were mixed up, it would end up increasing the pitch in exactly the wrong direction when it tried to correct it by increasing throttle on those motors, trying to bring it level again.

I just realized you are more experience than I am. I can only dream of having MK hexa, its exaclty what I wanted to build but cant afford it.

Anyway, an interesting result on the hand test. It was a bit the same with my 3rd quad when I loaded v39 on it (first firmware on that frame) I recheck everything time and time again no luck. It will always dip in random direction and hand test ill go crazy. Nothing was change on the frame/motor/prop and others except the firmware. Not that I am suggesting it could be the case with your setup. Others may be right this could be hardware and possibly a short somewhere.

Excellent news guys - my Arducopter has finally flown!

The help I got on here was key - thank you Mike, Jeff, Jason, Chris, u4eake , Matthew and Helldesk. In the end, Helldesk put his finger right on it, although I guess anyone who suggested motors/sensor inversion was on the right track. I did what was suggested by Helldesk and swapped ESC connectors by using servo extension leads. I swapped the two CW motors and the two CCW motors, mostly because this was the easiest first option, did the hand test and I could feel it was now inherently stable. Next was a ground launch and I got it airborne! I've now done about 20 mins of airtime with it and all is well.

In trying to understand this problem, everything points to a sensor being mounted reversed on the board. The 'motors' test in the CLI passes correctly with the orginal wiring, so the software and radio configuration was originally correct. I found this page very helpful:

And to quote it:

"If the multicopter is tilted along an axis and quickly flips on that axis, this is an indication that either the sensors are setup backwards (if you are buidling your own Shield) or the motors are setup backwards..."

Which brings me to the issue of the quality of workmanship at uDrones. Both my pre-assembled Arducopter and my additional APM1.4 were bought from uDrones and both arrived faulty. The AC board has a sensor reversed and the other board has haywire sensors on all 3 axes. These faults cost me a lot of time and frustration and I will be taking this up with uDrones. You pay a premium for pre-assembled equipment precisely in order to avoid these problems, and this adds to my ire. I'd like to thank Chris Anderson for fostering accountability by bringing Gigio from uDrones into our discussion.

Next steps - fit my XBee set and start practicing autonomous flying!

Glad to hear you got it up and fkying. I still cant stop drooling at your multirotor collecttion.


I guess I was lucky as my first ever board was a pre-assembled one from uDrones my other 2 were soldered by me so far all have no problem (crossing fingers. Hope you get it sorted out with uDrones.


Hey Jeff,

The MK Hexa's are for professional AP work, so not that expensive if you can expense them as capital assets! I agree that the RTF versions are insanely expensive, but I have a friend who was happy to solder them for me for a reasonable fee.

The Gaui is for learning & practice, and have I crashed that thing! Its got to be the most resilient frame in the market, my last crash ended in about 15 pieces, I put it back together again and flew it the next day. Even my HoverFly board still worked after that crash, although the buzzer has expired.

Had a sad story for my gaui 330x. It was my first ever quad and had a few flights with 344 but the first time I flew 30ft it decided to fly vertical I coutered with full roll but if I release it will just go back to vertical. Cut story short I had to kill throttle before I hit anyone. It landed over the trees but never found it. Had a RF6014HS (only spare at that time) on it with a BN battery. I guess that was my learning curve lol.


My quads are for hobby, photography and RC merged together, thats why I cant justify the MKs.

Hope to see vids of your flight soon...



I already offered you an apology for any inconvenience caused by this situation.

We do care of the quality of workmanship here, we fly in our own hands one and each AC we sell during a week, and we test all the APM's sensor values before ship them out. We have direct communication with 3D Robotics Hardware Test team to resolve any fault we see before and after the AC integration. We have some sort of experience with customers having troubles to use the AC they just received, so I think that communicating to us since the beginning was the best option for you. This tells me that we need a big advertise in my store front page encouraging customers and visitors to contact our Tech and Use Support, by email, phone or skype.


By reading this last comment, realized where is the problem. You bought this AC ready to fly almost 5 months ago. By that time, we offered AC only in plus mode (now we have an option, x and + mode), so now that you updated the code directly from the Mission Planner, the uploaded code is by default in x-mode. Check that, and also for flying it in x-mode you need to turn your APM 45 degrees to the right. 


The IMU haywire sensors on all 3 axes problem will get resolved probably by erasing your eeprom using the "erase" command in CLI. Reseting the board with the "reset" command wont initialize correctly you eeprom.

We haven't had any RMA (return material authotization) for any ready-to-fly Arducotper, and this is because we fly them here, before they ship out. we deliver all around the world, so we don't play around sending merchandise that won't work to the other side of the globe.


So I'm really happy to assist you personally by phone or by skype, as well, any other Udrones Store customer or DIYdrones blogger can contact us in case of any technical and usage support, general customer support, or as always, if you have any questions or queries what so ever, please don't hesitate to hit us up on


Definitively, you will find help by posting a problem in this community, it's impressive how quick you get a solution, and we are all very grateful for this, but also, I invite you again to conatct us for a personal audio/video assistance.


Gigio   -    Udrones Store Manager


Thanks Gigio for this comprehensive feedback. The only explanation I can give for how an AC test flown by you guys could not be flown in that same configuration by me, is that I swapped out IMUs a few times between my two APM1.4s. Its possible that the IMU now on my APM board in the AC is not the original pairing. However, that IMU is the one with 'haywire' sensors so it begs the question of how that one also passed testing.

Its true that I bought this equipment 5+ months ago and it sat in storage until I had time to get to it, I also changed the frame configuration from '+' to 'x'. The initial position I rotated the APM to was incorrect, as revealed by the motors test. However I then positioned it correctly according to the motors test, so at the time I attempted to fly it the configuration was 'correct' according to all the tests in the CLI mode.

I have erased, reset and re-uploaded firmware multiple times in order to correct the IMU with haywire sensors, but none of this has helped. I have also moved the board 2m away from my PC, in order to get it out of the influence of electromagnetic interference, but this hasn't helped either. Incidentally, the compass feedback is also all over the place.

Chris Anderson will be in South Africa this weekend and he may be able to pay me a visit. It will be interesting to get his take on this issue.

Jeez John,

As I would NOT have helped you?

Ok, joke, but my ArduCopter has been flying successfully for the last 3 months or so, and my UAV plank has done a number of successful missions(sounds professional, doesn't it !)

Yeah, we also had one sensor board with a definite fault, and one maybe.

All the ones I've assembled seems to be working...........

You're welcome to pop around, just give us a call, in case I'm working late, or away.



Gustav you are a legend - you helped me way back with my VHF radio and I know you would have, but you also live halfway across the peninsula and typing my problems into the forum was just faster!

Send your Arducopter on a mission my direction and I'll send mine to you? Just have to be careful of the Cape Town TMA :)

Seems like my roll sensor is not healthy, the pitch one aint doing too well either (see screencap) but I'm sending this IMU to uDrones for them to take a look at. I've also since had an in-air tumble with my flying AC, but I think that is a dodgy motor or ESC. I've ordered some new ESCs, motors and hexa frame and I plan to build a new hexa from scratch.

We must get together on a good flying (ie windless) day, I can bring Tyrone as well, but only when he's finished his current job for me.


Was that screen cap with the motors running, or the quad standing still?

Did you do the calibration sequence?

I do most of my setup in CLI, must be the old DOS background :-)

Tell you what, once it's finished I'll send my stealth UAV your way, and back !

I'm hoping it'll do the yearly Long Run, 100 Km.

The route only requires 11 way points, to stay in sight of the road :-)

What is Tyrone doing for you?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service