This is a discussion re the ArduCopter-3.1 AutoTune feature.  A place for people to report successes and failures, ask questions and get answers.

The AutoTune wiki page is here.

 

Views: 74287

Reply to This

Replies to This Discussion

Hi Wessie,

I would suggest dropping Stab_P back to suit your taste but keeping the Rate P I and D terms the same. The Stab_P result from Autotune is as responsive as I would recommend you going but reducing it will give a softer feel.

This should not have any negative effect on Loiter though, provided you can fly well in stabilize. 

Here is the logfile.

Attachments:

Hi Leonard,

Thank you for the feedback, it is really appreciated. I attached the log for the above video. Very curious to know if it shows anything specific that I can further tune out. thanks again!

Attachments:

Leonard,

I could not reply to your reply requesting experiment of 30% reduction on Rate_P and, if required, Rate_D... too reply levels?

Anyway, reducing Rate_P resulted in significant improvement, that is smaller oscillations of approx. same freq.  Reducing the Rate_D as well effectively eliminated the oscillations altogether.  Very nice!

Thanks for the guidance... something about handling gimbals should find its way into the instructions... might save other from bugging you about it.

Cheers,

Karl

P.S. In performing this test, I discovered that the gutters on the high side of my house need cleaning.  Any way to put a gutter cleaning system into the development plans? :-)

Thanks Leonard, this is great to know. Will definitely have a go at it, in "lite" version with no addional gimbal/mass, and share experience here. Hopefully this week-end ...

 

Hi Peter,


When 3.1 goes live, this will be the support thread for it as well as future releases:

http://ardupilot.com/forum/viewforum.php?f=25

For comparison, here is the one for Plane 2.76

http://ardupilot.com/forum/viewforum.php?f=77

Hi Karl,

I actually found your post after seeing Joe's picture below. Initially I was worried he was giving a creteque on my advice :-) 

I am very happy this experiment worked! The information will go into the wiki but I am still working out what we need to say (read learning). Once we release 3.1 I will try to help knock something up. Then I will ask for feedback and suggestions here.

Thanks again!

Hey Raph,

Could you post a couple of pictures of your machine. And could you also tell me exactly where the CG and the motor positions are?

Hi I have just uploaded RC7 ready for the next calm day when ever that happens.

I use the range video mount http://www.rangevideo.com/index.php/accessories/vibration-mount/ran... for my APM 2.5.

Do you think this is too soft and will cause issues with the autotune?

Stu

Hi Leonard,

I am traveling but will post monday when I return. Excuse my ignorance, but what do you mean by CG and motor positions? 

Did an Auto Tune yesterday in 12-15 mph winds with Rc7 and all went well but had to make a lot of flight corrections to keep machine nearby.  Redid today in calmer conditions and was surprised when I had a RTL near the end of the roll phase.  Switched to Stab, then Althold, and resumed auto tune to completion.  After landing I discovered my Fence Radius was set to 100 feet and that is what caused the RTL. Just wanted to say I was surprised that everything worked with this kind of interruption in the Auto Tune. Great job.

All works great, and my quad flies like it is on wires. Very responsive and snappy on controls. Just wanted to let you know.

If weather holds I will do missions and test out the Toy mode tomorrow.

Thanks for all the great work.

Joe

x525 frame, 3DR APM2.5, blue motors, and non-SimonK ESC.  RCDome used for mounting gear.

Attachments:

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service