This is a discussion re the ArduCopter-3.1 AutoTune feature.  A place for people to report successes and failures, ask questions and get answers.

The AutoTune wiki page is here.


Views: 74337

Reply to This

Replies to This Discussion

I have found that having a secondary sprung mass, (i.e. a camera gimbal), has a very strong influence on the correct pid settings. In fact if this mass is very large and the mounting very soft (i.e. contains also the battery) then it may not be possible to dial in stable flight at all.....

The two parts will just oscillate against each other.

The rules for success is to have mounting points at the extremities and no softer than is required after a proper motor/prop. balance and keep everything light..... 


I would forget those motor mounts as they will cause a secondary oscillation between their natural frequency and that of the motor control outputs. 

Thanks Denny, yeah I'll be swapping those soft motor mounts for hard ones today.

I'm also wondering if the dampers on the gimbal are too soft. Seems like all of the unwanted movement on the gimbal is due to the whole gimbal itself wobbling, but I'll have to see if this wasn't just caused by the motor mounts. It's the rctimer 3 axis nex5 gimbal. Don't really know if much can be done to stiffen the gimbal dampers. I've heard people stuffing them with cut up earplugs, but not sure if that's really effective...

I loaded the 3.1rc8 to my apm2.5 (no external mag) to try out the autotune function.
My test setup is a F450 frame with 900KV motors, gemfan e-props 10x5, 20A esc SimonK flashed running on a 3S battery.

After running through the necessary checks and calibration processes I put it in alt hold and let its do his autotune stuff.

Afters a few minutes autotune function was completed and the quad flies flawless.
I saw that there will be some more wind tomorrow so I'll try out the loiter and RTL as well.

Nice job to the developers!


I see the latest mission planner 1.2.89. the FW is 3.1. is the 3.1 now official? with autotune and no more beta?


    Yup, sure is.  Release discussion is here!

It was a vibration problem. So I solved that problem with a better vibration damping hardware and had to reduce the THR_ACCEL_P value to 0.4. Thanks for your support!

I just had a crash in auto-tune. It seems that it was ready auto-tuning the roll axis and was going for pitch axis. It looks like a motor failure but not sure because it just started to tune the pitch axis so it could be a software problem also. If some can take a look to the logs it would be great.


I'm sorry Linus but while trying to look at your logs I've found that there's a fair bit of corruption of the data meaning that I'm unable to open it in mission planner.  Normally log corruption is caused by an unreliable connection between the computer & apm often caused by a bad USB cable so maybe you can try again with another cable?

I still have it in the APM, I can download again. Let me come back with the new file. Anyway with Mission Planner 1.2.88 it loads well and I can plot all variables, I just tried downloading and loading in the log browser for dataflash logs.

If I use autotune can I then save the pids, download to stable release and re-enter the new pids?

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service