This is a discussion re the ArduCopter-3.1 AutoTune feature.  A place for people to report successes and failures, ask questions and get answers.

The AutoTune wiki page is here.

 

Views: 74458

Reply to This

Replies to This Discussion

After few more attempts I had finally somewhat succeeded. I did two changes at once, so not really sure which one helped more. At first switched from 'X' frame configuration to 'V'. And then also put more weight on the copter - 3300mAh 3S battery together with the Mobius cam. Total weight went up by ~180g, all quite evenly distributed under the copter.

Autotune was then quite straightforward in this configuration. Finished with these values, perhaps a bit too low in my eyes. However the result seems to be pretty stable. The copter is quite sensitive to the proper balancing. To attach the battery to it so that the COG is where it should be is important. If it is not placed where it should be, copter just keeps flying forwards or backwards by itself.

Stabilize R & P: 6.000

Rate Roll P: 0,0550

Rate Roll I: 0,0550

Rate Roll D: 0,0050

Rate Pitch P: 0,0350

Rate Pitch I: 0,0350

Rate Pitch D: 0,0095

Anyway, I'm still very interested in some hints how to make the autotune to finish with lightweight configuration (2200mAh 3S battery, no Mobius cam attached). 

Attachments:

Hi, i try autotune with pixhawk and there is just the roll tune no pitch ....

Papayou,

     I think this likely means that the autotune has failed to find good PIDs during the roll tuning and has given up.

Hi thanks for reply,

i managed twice before and since i changed propellers is not working anymore......

I changed eprop 8x5 with tmotor 10x3,3.

I will try to delete pid preset in pixhwak before ?

Hi, 

I try AutoTune on a Tricopter x900 from HK and APM 2.6 runing on FW 3.1.5

setup is:

RcTimer 2812-880KV Brushless Motor

ESC 30A Simonk Firmware

10 x 4.5 Gem Props

Dynam 2600mA 4C

Ublox Neo 6m with compass

The problem is that the copter increse the throttlr from 532 to 800 just a few seconds after I engage autotune.

in steps:

Take off

Switch to AltHold

Engage AutoTune

now the copter rolls a few times left and right and all a sudden it raises up in the air.

switched to Stabilize mode, gained controll

back to about 6m alridude

switch to AltHold

engage AutoTune

same thing, rolls a few times than raises up again.

in the log file you can see this starting with line 1359 CTU thrin=532 out is 535

after that Throut rises to exactly 800 and the copter starts to gain altitude until I switch to stabilize mode to cancel autotune.

Things I did so far:

re flashed Firmware (with erase and reset) 

changed Flight controller from other quad I have

I have no idea what I'm doing wrong or is wrong. Please any ideas are welcome. attached one log for reference.

The copter fly's well in Althold and Loiter

cheers

Attachments:

Hi on my last autotune i swith in stabilize mode not in alt hold and autotune is ok 

Before i couldn t have autotune correctly with alt hold 

Top notch documentation Jim, thanks a million. Some of these tips should be added to the wiki!

Just finished a perfect autotune and my copter is flying on wires! I would like to say a major thanks to the Arducopter Devs!

I have the same issue as Papayou.

I'm flying a TBS Disco on 4S, DJI 920kV motors, DJI 30A Opto ESC, DJI 10x4.5 props, Pixhawk, GoPro Hero 2, FatShark 250mW 5.8GHz and a FatShark FPV camera. Using an X6R for the receiver and also have a Teensy 3.1 set up with my 3DR telemetry to get telemetry back to a ground station and my Taranis.

I've done my manual tuning and things seemed to be in a good state so I saved those settings. Then I tried auto-tune while in AltHold and it starts off fine moving in the roll direction, granted it's moving off in one direction, and then after a while, I bring it back and let it keep going. Then it just stops without going through to the pitch sequence. I flip the switch back to LOW to get original PIDs and then back to HIGH and land, arm, and read the parameters but they're the same, so I assume it didn't complete as Randy indicated.

I don't have logs right now but can upload them later tonight but is what Randy says true that if it can't find a good PID setting for roll, it stops? That would be useful to have in the Wiki at the very least. I have the GoPro video of it trying as well.

I'll get logs up tonight and will also be sure to check the CG to make sure it's alright but if I remember correctly, it's pretty close and if anything, is only off in pitch if it's off at all.

Looking at vibration as well, I found I'm within +/- 1 for Y but it's more like +/- 1.5 for X and am not sure what else to do there. It's still in the +/- 3 that I saw in the manual so I haven't worried about it.

Okay, here are the logs.

Log 1

Log 2

I also just checked the CG and it looks like it wasn't balanced front to back properly but it's pretty close side to side so I'm not sure why it wouldn't get the PIDs properly for roll and move on to pitch.

Hi there,

I have a success to report. Maidened my mapping quad today (680mm, CF frame, 3509 380kv motors running on 6s 4-8ah, 15x5 CF Props). Went straight onto autotune after checking out basic controls. Autotune ran fine, although I think I made the mistake of invoking it too late (about a minute into the flight) which gave a bit of bounce right at the start of the next flight when the battery voltage was a bit higher. I ran autotune for a second time right at the start of flight two and that sorted things out.

I thought this report might be handy for the devs as autotune is not supposed to handle larger quads with low kv motors and big props that well. I didn't have any problems with it, but I did pay a LOT of attention to dealing with vibration while leaving the Pixhawk mount sufficiently stiff.

Thank you all for the awesome work you do!

Attachments:

Hi There,

I've got myself a problem/issue which I just can't fix or get it working.

The drone is just not getting into Autotune mode, I've tried everything but It just refuses.

I have done the same on different quads which is working fine, but on this one... poeh.

I have a APM 2.5 Flightcontroller within a Discovery frame with a 30AMP ESC and 700KV motor setup.

Today I did a full erase of the Eeprom and Factory reset and worked my way around through the entire wizard and put every in place.


Started off with the default parameters where I found that it oscillates a bit so I tuned down the RateRoll P from 0,1500 to 0.1080 where it stopped and felt a lot better. It was actually flying not bad apart from a couple of twitches when doing some stronger Elevator or roll inputs.

I went into the field and put the drone in ALT Hold mode, then switched to autotune mode but nothing happened.

I've tried things over 2 months finding out what may be the case, but now I'm all of options.

Which factors can disable going into autotune?

If there is more information needed, please let me know, Il provide everything I can.


Thank you so much.


Regards

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service