This is a discussion re the ArduCopter-3.1 AutoTune feature.  A place for people to report successes and failures, ask questions and get answers.

The AutoTune wiki page is here.

 

Views: 74336

Reply to This

Replies to This Discussion

Linus, then things become simpler.

If your copter is not holding altitude when in alt hold is engaged, then clear your logs, do a short 1 minute alt hold flight, and post your flight log, perhaps even the Tlog to the "AC 3.01 released" thread sothat maybe someone can have a look there. Perhaps is the GPS or Baro acting up, but you should not try AutoTune untill the underlying problem is sorted.

Once that issue has been resolved, then by all means come back to this thread and move on with the AT issues, if any.

Ok,fair enough,thank you

PS:when i put bigger prop on top ,instead same size  (motor 4 and 6)multi goes up..problem is i am waiting props from China,so i cant try ideal combination with bigger prop down but it looks to me same props would be better solution for controler and for simplicity..we only lose few minutes of flight anyway..

and weather is nice...

Thanks for understanding Emin!

By using the same props (but opposite direction) on the upper and lower positions, you may loose some flight time and you may get better yaw one direction compared to the other. But I think it is a better solution than your current layout.

Hello everyone,
I wanted to submit my log after a crash, I have successfully carried out the autotune, then I tried to fly with the new parameters apparently everything is ok, then I tried a quick turn right then left and went into the quad fast swing that does not I was able to check and did a flip, fortunately without damage.
tomorrow I'll try 3.1.RC8.

Crash Check it worked great the engines stopped immediately.
Great job guys, great team.

Greetings to all

Attachments:

By the way, in case people didn't see it I've added a demo video to the autotune wiki page.

Hi

I had a similar problem with Alt Hold and Loiter not holding.

I did a compassmot and found since I had replaced my motors that this value was very high (58%)

I had to move the external gps/compass up 75mm away from everything which gave me about 10%.

I then had a very good Alt Hold and Loiter which then enabled me to do a successful autotune.

Good luck.

How do you tell from the logs whether or not autotune has been envoked and if its actually working?

I titally agree with you...

I'm managing to complete my autotune successfully (without gimbal, battery mounted centrally), and the copter looks to fly well with the new PIDs however as soon as I bolt the gimbal back on (1kg of gimbal + camera) I get a reasonably violent high frequency oscillation which I can't get rid of until I drop the rate D from 0.015 to around 0.010. Even after that, it looks like the whole copter still isn't flying completely smoothly, as my gimbal is still shaking around a lot on it's dampers, which I think is because the copter is shaking rather than the gimbal PIDs being bad.

I just rebuilt it today to have the battery on top of the centre of the main frame plate, as previously the battery was mounted a reasonable way rear of the CG and I thought this was this cause of my bad performance, but turns out it's not.

It's a UAP2 quad, and I have the motors on the vibration isolation mounts (http://www.shop.aglhobbiesllc.com/Motor-Mounts/Anti-Vibration-Mount...). Not sure if this is the cause. Might have to try swapping the mounts and see if I can get improved performance.

Autotune log is here:

Hi Glenn,

Something that has worked in the past is to reduce both Rate D and Rate P by 30%.

However, if this doesn't work the you will probably need to make do with manual tuning.

I am sorry but Autotune doesn't handle the extra degree of freedom the camera gimbal creates.

Hi Fabio,

I have been looking through your logs but I can't determine what has caused your crash. It looks like you were using your original pids, not the autotuned pids. However, I don't like the tune you are getting (at least from this starting point).

If you want to try again I would start from default pids, 
Rate_P 0.15

Rate_D 0.004

I would be interested to see if this results in a better tune for you. I suspect that it won't make any difference but it might be worth a try.

I am very sorry that you are having so much trouble with your tuning and that we don't seem to be able to sort out your problems. This is the first release of Autotune and we have some ideas about how we can make it more robust but that won't happen until the 3.2 release.

Hello leonardthall,

Thanks for the reply, my copter with pid default is stable loiter, althold, but it's reactive little, and no overshoot, starting with the default values ​​and the values ​​acquired made ​​autotune makes it very responsive and if it becomes stressed unstable with the possibility of doing a flip.
I guess it depends on the values ​​higher P Rate Rate-D, the instability could decrease by reducing the value of Rate-D.
greetings

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service