This is a discussion re the bad Accel, Gyro and Baro values that we're seeing with ArduCopter-3.1.  The increase in the SPI bus speed from 500khz to 8Mhz has exposed a hardware problem on some boards.  That hardware problem is that the 3.3V regulator has been blown so all sensors are running at 5V instead of the intended 3.3V.


How have these regulators been burnt out?

  • Attaching a radio receiver or MinimOSD to the APM while the APM is only powered through the USB (see video below)

  • Some clone boards seem to come from the factory with blown regulators.  3DR boards might also come with blown regulators although they do a specific check of the regulator as part of the regular QA process.
  • It is not (as far as we know) actually caused by the AC3.1 software itself, it just exposes the problem.  You could prove this to yourself by checking the 3.3V regulator (see video above) before and after the upgrade.


How can we fix the regulator?

Option #1:  If it's a new board (so that it's less likely you burned it out yourself) you could report the problem to the retailer that sold you the board and ask for an replacement.  If it's 3DR it's called an "RMA".

Option #2: if you're handy with a soldering iron you can replace the regulator yourself.  On the APM2.5.2 (and higher) boards it's not that difficult.  On the APM2.5 it's far more difficult.

For APM2.5.2 : TPS79133DBVR

For APM 2.5: MIC5219-3.3YML TR

How can I stop it from happening again?

Do not connect any devices such as a radio receiver, MinimOSD, GPS, etc while the APM is powered especially while powered only through the USB cable.

Attaching a 100uF capacitor across any of the APM's radio input's 5V and GND pins will stop the regulator from being blown by plugging in a receiver.  video here!

There are very few reports of regulators being blown twice and no reports of it ever failing in flight.


Below are some graphs of the types of values that we are seeing on these boards.

Views: 105745

Replies are closed for this discussion.

Replies to This Discussion

Oh, so the Ubec spikes to 8 or 9 volts before settling at 5v?  I didn't know those ubecs did that, I can't imagine the APM electronics like going that high even for a short time and can easily imagine that's what's killing the 3.3V regulator.  It'd be great to figure out if that was the cause (or if you can verify that it is spiking at startup) because I can imagine a lot of people are doing what you're doing so we should update the wiki.

Hi Randy yes it's only milliseconds and my multimeter is a cheap one so it would be good if someone with some good gear to confirm the spike, for what it's worth all my ubecs in parts box did it.

Andrew, I wouldn't be surprised if HK is selling a bad batch. My defect one is a HK board as well and had those startup issues since I got it new. With the 3.3V regulator replaced and the same UBEC I never had another issue so far.

On the other hand I never checked my BEC voltage during startup but just assuming if that would be killing it then there would me plenty ppl having such issues?

My second board sits now in the same quadcopter and doesn't have an issue either with the used BEC.

Both mine were bought a month or apart and worked fine for a few weeks before the symptoms.

I would think HK has sold a bucket load of these by now and alot are powering the same as me so we'll see if the reports start rolling in as people migrate to the newer firmwares.

I just checked, I bought mine on August 1st. I don't know if you read my earlier description. My first symptom with that board was that it wouldn't boot unless powered a little delayed after BEC and ESCs were powered up. And I put the HK board in a quadcopter that I run before with a RCtimer board with no such problems. That's why I assume that my HK board had that 3.3V issue since I got it new.

Now with the new SPI bus speed that 3.3V defect showed also in the HUD with twitching. Mine was not as bad as Bruce's rolling HUD but it was not flyable after upgrading to the new speed.

Replacing the 3.3V regulator resolved both issues twitching is gone and booting works without my special 2 stage power up procedure. I can plug everything in and all boots together now.

Maybe I can check the 5V with my scope and see how it comes up during startup. What kind of UBEC do you use? I use currently the 3A low noise UBEC from HK.

Hi, yep mine was doing the same, only would boot with UBEC already powered then plugging into APM, that's why I looked to see if the UBEC had a spike as that was the only reason I could think of being the problem.

I am using this;

Ok, I just did the power up with both the UBEC and the 3DR power module (see below). I didn't see that overshot that Andrew was measuring and I repeated it a couple times. Pretty much the same curve each time for both power supplies. The UBEC goes straight to the 5.2V and the 3DR module does it even more straight :)

HobbyKing UBEC 3/5A Low RF Noise Power-Up

3DR APM Power Module Power-Up ... (Yes, I am not only Chinese ;)

Ok thanks Detlef, back to square one.

Nice graph!

I'm a big fan of the power module.  It's saved me so many hours in support (and many user copters as well) once it started becoming standard issue with the 3dr APM set because it makes powering the copter so much easier to get right.  It may seem a little pricey at $25 but it's actually money well spent 'cuz it's so critical to get right.

Ah, lets blame the cheap Chinese :) my RCtimer doesn't recognize the flash ram (that's why I got a the HK board) and my HK board had the voltage issue. I guess I am not having any luck with those. If I buy another one I might opt for a 3DR this time :)

Besides that power supply you also get the voltage and amp sensor with is - considering that I would say not bad at all that price.


Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service