This is a discussion re the bad Accel, Gyro and Baro values that we're seeing with ArduCopter-3.1.  The increase in the SPI bus speed from 500khz to 8Mhz has exposed a hardware problem on some boards.  That hardware problem is that the 3.3V regulator has been blown so all sensors are running at 5V instead of the intended 3.3V.


How have these regulators been burnt out?

  • Attaching a radio receiver or MinimOSD to the APM while the APM is only powered through the USB (see video below)

  • Some clone boards seem to come from the factory with blown regulators.  3DR boards might also come with blown regulators although they do a specific check of the regulator as part of the regular QA process.
  • It is not (as far as we know) actually caused by the AC3.1 software itself, it just exposes the problem.  You could prove this to yourself by checking the 3.3V regulator (see video above) before and after the upgrade.


How can we fix the regulator?

Option #1:  If it's a new board (so that it's less likely you burned it out yourself) you could report the problem to the retailer that sold you the board and ask for an replacement.  If it's 3DR it's called an "RMA".

Option #2: if you're handy with a soldering iron you can replace the regulator yourself.  On the APM2.5.2 (and higher) boards it's not that difficult.  On the APM2.5 it's far more difficult.

For APM2.5.2 : TPS79133DBVR

For APM 2.5: MIC5219-3.3YML TR

How can I stop it from happening again?

Do not connect any devices such as a radio receiver, MinimOSD, GPS, etc while the APM is powered especially while powered only through the USB cable.

Attaching a 100uF capacitor across any of the APM's radio input's 5V and GND pins will stop the regulator from being blown by plugging in a receiver.  video here!

There are very few reports of regulators being blown twice and no reports of it ever failing in flight.


Below are some graphs of the types of values that we are seeing on these boards.

Views: 105461

Replies are closed for this discussion.

Replies to This Discussion


     I wouldn't trust the CLI's GPS test too much.  I've heard a few times that it displays garbled messages.

     The GPS not powering up and I guess you don't see the little blue light on the APM lighting up?  I guess you could check the power coming out of the wires that attach the GPS to the APM similar to how you probably checked the voltage on the I2C cable to the compass.  I think the GPS needs 5V though so when you find the correct pins it should show 5V.


Thank you for the reply and the idea.  I just checked and according to my meter, IC2 is at 3.1v, the TOP GPS port is at 4.7v and the SIDE GPS port is at 0.

Does that make any sense?  Or, could it be my meter's setup?




     Ok, so I tried this on my APM2.5 which is a-ok and found the same results as you...which of course means that we are both likely measuring the wrong pins on the cable with the white connectors (i.e. the GPS cable coming out of the side of the APM).  After checking the eagle board files, it looks like we need to check the pins that are one in from each side (i.e. pins 2 and 4).

Did you check the voltage at the pins where your GPS connector plugs into?

You should see 5 volts I believe. I was told that GPS units runs on 5 volts.

That 3.3-volt regulator shouldn't have anything to do with the GPS module as far as I know.  

Opps... Forget that I asked the above question Michael. You already took that action. I don't know how but I didn't see all those communication between you and Randy:)

Randy, Alex,

Okay, I checked the following.  My APM 2.5.2 has a 6-wire GPS cable (1 red / 5 blk)

I tested the TOP GPS port and far end of the 6-wire cable that plugs into the uBlox.  Pins 1 and 6 net 4.7 volts.

I tested each pin on the SIDE GPS port, also 6-wires.  Pins 2 and 5 also net 4.7 volts.

Randy - Your image shows 5 wires.  Do I have different hardware?

Also, when I power up the APM via USB, I do get the red (A) and blue (C) "police" LED's for several seconds and then a constant blinking of the red (A) LED.

The green "Alive" LED next to the top GPS port is steady and the orange Tx LED blinks as needed.

When I boot the APM via USB with the uBlox connected to the TOP port I don't get power.  I wonder if I did something to burn out the GPS?  It worked fine prior to my regulator replacement.

When connected to MP the HUD reports No GPS.  Also, gpsstatus and gpshdop both show 0 in the status window.



Hi Michael,

I just checked my APM 2.5 (Original 3DR) board for you. My GPS harness has 6 wires as yours and it connects to the side port. The top port is using 5-pin socket. This gotta be the old style. Maybe the MediaTek GPS uses the 5-pin socket not sure...

I am also not sure why Randy referenced the 5-pin socket when telling you how to check the voltage. I would like to know as well...

Okay on my board (when powered with a 4s lipo battery), I get 4.95 volts at the top (5-pin connection) when measured the two outer most pins. But strangely, I get negative voltage. So where it shows red should be black and where it shows black should be red. Not sure why??? 

When I measured the 6-pin connection, (I did this by pulling the 6-pin wiring harness from the GPS module because the pins are so close to each other I didn't want to risk shorting anything.), I get nothing when I measured the two outer most wires. 

When I measured the 2nd ones from each end (which would be pins 2 and 5), I get 4.95 volts but again I get negative. 

I am really confused with this negative voltage. Why is it negative??? I hope Randy can explain it...

One last thing is that I have red and also the blue LED activity on the board while the GPS is connected.

There is also a blue LED on my ublox GPS. When the 3D fix is acquired, the blue LED on the board goes solid and the blue LED on the GPS starts blinking.

So if you aren't seeing blue LED activity, it is sure that there is some problem...

Okay, I found the reason why I was getting negative voltage.

My 6-wire GPS harness is the problem. The red wire plugs into where it says GND on the GPS board and the black wire plugs into where it says 5v.

So that confused me. But how this happened is beyond me!!!

Did the 3DR made a mistake while assembling these harnesses? Wierd!..

once something positve, I have 3 boards in operation that are in daily use, now with the 3.1 and they have no errors.
now I have a clone from china, have the board 12 hours a computer and had no problems.
according to what I read here, but would at least have to turn out a board.
I have been well received by customers no negative info.

Ah right.  So the cables and maybe even the APM2 has changed at some point.  I didn't realise that.  On my APM2.5's GPS ports, both the upper and side ports have only 5pins.

Now I have two types of cables as well, I have a 5-to-6 pins cable with brown ends that can connect to the latest 3dr GPSs.  I also have a 5-to-5 pin cable with white ends that can connect to the older 3dr GPSs (mediatek and Ublox without the built in compass).

On the white 5-to-5pin cable the pins are like in my picture above.

Thanks Randy but I have the older version Ublox GPS (no built-in compass) and mine is using 6-to-6 pin cable with white connectors.

It doesn't match with any of the stuff you mentioned above. 

How is that possible?

If I were to replace my (dead) older uBlox GPS for my 2.5.2 board, can I use the 3DR MediaTek unit?  Or, the newer uBlox with external compass?  I am trying to learn what my options are.  

What are the gotchas of buying a gray-market uBlox GPS from eBay / China?

I obviously want to keep the costs as low as possible since I have a Pixhawk and new uBlox on backorder from 3DR.

Again, thank you for the guidance.




Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service