This is a discussion re the bad Accel, Gyro and Baro values that we're seeing with ArduCopter-3.1.  The increase in the SPI bus speed from 500khz to 8Mhz has exposed a hardware problem on some boards.  That hardware problem is that the 3.3V regulator has been blown so all sensors are running at 5V instead of the intended 3.3V.

 

How have these regulators been burnt out?

  • Attaching a radio receiver or MinimOSD to the APM while the APM is only powered through the USB (see video below)

  • Some clone boards seem to come from the factory with blown regulators.  3DR boards might also come with blown regulators although they do a specific check of the regulator as part of the regular QA process.
  • It is not (as far as we know) actually caused by the AC3.1 software itself, it just exposes the problem.  You could prove this to yourself by checking the 3.3V regulator (see video above) before and after the upgrade.

 

How can we fix the regulator?

Option #1:  If it's a new board (so that it's less likely you burned it out yourself) you could report the problem to the retailer that sold you the board and ask for an replacement.  If it's 3DR it's called an "RMA".

Option #2: if you're handy with a soldering iron you can replace the regulator yourself.  On the APM2.5.2 (and higher) boards it's not that difficult.  On the APM2.5 it's far more difficult.

For APM2.5.2 : TPS79133DBVR

For APM 2.5: MIC5219-3.3YML TR

How can I stop it from happening again?

Do not connect any devices such as a radio receiver, MinimOSD, GPS, etc while the APM is powered especially while powered only through the USB cable.

Attaching a 100uF capacitor across any of the APM's radio input's 5V and GND pins will stop the regulator from being blown by plugging in a receiver.  video here!

There are very few reports of regulators being blown twice and no reports of it ever failing in flight.

 

Below are some graphs of the types of values that we are seeing on these boards.

Views: 105111

Replies are closed for this discussion.

Replies to This Discussion

You are 100% correct. The eagle file is current.
Keep in mind, this goes back to the beginning of the APM2.5
This fault, has not caused an issue due to the fact that flash can handle the higher voltage.

This will be fixed on the next layout revision, but it is not considered a critical issue.

My scope is a little older DSP based USB scope with 200MHz and 5 giga sample/sec. Its fairly quick but not too accurate down to the millivolt.

Unit #1 & #2 where just the BEC to a 3S Lipo and measuring the non load output - real short wires.

Unit #3 is actually wired in my plane with aprx 8" wires with a 3DR power module in the middle. The power module powers exclusively the APM and the BEC powers 6 servos and the RX.

Unit #4 sits in my quad copter with aprx 6" wires and powered everything, APM. GPS, RX, OSD, and 2 servos. Its the oldest HK BECs and I think its a different version than the V2.0 as it regulates pretty accurate the 5V not 5.2-5.3V and the power-up curve looks different.

What I didn't expect to see were those high drops down to aprx 4V when I moved the servos. I thought to be far away from the max 6A in order for it to shed volts to keep the current within limits - or its just not very good at handling current spikes.

That's why my first thought was that Philips BEC maybe is acting up on the digital servos and sharp inductive loads but as he states same happens direct on a battery powered setup with no BEC. I guess there are some nasty servos out there.

This was the unit #3 in my plane at power off. I only did one screenshot yesterday as there was nothing special. Besides that my plane has probably some high capacitance because the voltage dropped pretty slow down to 0V. 

I put all screenshots and pictures here: http://1drv.ms/MWz8in

Actually to isolate the cause of the noise, we put a diode inline on the vcc, and measured either side of the diode. That confirmed the spikes were coming from the servos, not the BEC

I would guess if Guaifi still had 5V on the 3.3V supply with the 3.3V regulator removed and cutting the Vcc A & B lines to the level translator chip has helped to get rid of the 5V then maybe his voltage level translator had and internal short/failure?

I would guess having the signal level swapped it only stresses the voltage level translator since Vin on the A port is rated at max 4.6V - don't know how high or stiff the ATMEGA CPU 5V output would be to give it a sweat. Since it is translating a communication line its probably by the nature of the signal safe to ignore besides that shifting level is not working.

A normal RX has to take quiet some abuse if I see that :)

YES, you are correct:

I didn't tried yet the dataflash because I couldnt solder the 2 red wires changing 3.3 and 5V so my level shifter is OFF and my dataflash is not working for now.

Also, dataflash never worked (with firmware 2.9b before cutting lines) so it was bad from factory.

But I checked all the rest and that was the problem.

Also, I didnt checked which one (A or B ) side of the level translator is the 3.3 or 5v but sure you are right and data lines are the problem and not the power lines. But, changing all the data lines in that chip is IMPOSSIBLE! SURE!

And about the people who ask me why about others ¿?¿? I don't know, maybe there are diferent batch of PCB. Mine is from HobbyKing, color black. Weeks ago I didn't understand why other people change the regulator and said that it worked but mine not changing or putting one external....

Also I didn't realice that I was flying with version 2.9b and 5V on all sensors (LOL!)

I only want to contribute, there is a problem in my board with the level shifter, I solved mine (except for the dataflash). Try yourselfs.

Maybe, if your problem is having 5V on 3.3v regulator AND your dataflash doens't work this is the solution. For other cases, check.

Sorry about my english (but sure you understand better than my spanish).

Guaifi, I think its a great find!!

Its just not the cause for the general failing 3.3V regulator problem that's discussed here.

Here's a discussion I started last year about the issue with servos.

http://www.diydrones.com/forum/topics/helicopter-avionics-power-supply

It's an even bigger problem on helis which tend to use big, fast, powerful servos, and they often all move at exactly the same time.

I fixed mine using replacing the regulator but mean while it was down i ordered a another APM. Then i noticed something. The magnetometer connector plug on my old apm is soldered wrong way so thats why i blew my regulator. First i thought it was the cable that was crimped wrong but i was wrong. Its the APM connector.

Other than that i noticed something else. New APM is clearly smoother than my old. My quad used to turn to left while its descending now it does not do that on my new APM and really stable using same config file.

Hans, are you sure about that?

It is the 4-pin I2C connector you are talking about right?

I want to make sure about this because I am about to switch to external regulator on my APM 2.5. I will be using that I2C connector...

 

yes, I will make a small video about it. Just use your multimeter to check where the ground pin and the 3v line is on the both your external compass wires and the APM. Don't do the same mistakes i did.

Mostly you have to be worried about when external magnetometer comes with an GPS unit. Then ground wires on the Magnetometer and the GPS is connected together. So if you connect both GPS and the Magnetometer, you are toasting your APM, if the connector is soldered wrong way.

Is this on genuine 3DR boards, or clones?

I've heard of some clones coming with magnetometer cables that have the power and ground wires crossed.  But you're talking about the actual socket on the board?

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service