Hi.

I have a problem after updating AC to 3.2.1 from 3.1.5.

When in Loiter, the the speed of the motors rev up and down/pulsate quite rapidly. This was working fine when I was using previous versions of arducopter.

I have downloaded the logs, and have looked into accX, accY and accZ. These seems to be inside the range specified in the wiki at arducopter. (Log_vibrations.bin)

Please have a look at the Log.bin, and note the difference between ThrIn and ThrOut when I'm in Loiter mode.

 

Anyone having any idea what the problem may be?

Views: 27357

Attachments:

Reply to This

Replies to This Discussion

oops.. the log file..

Attachments:

Hi Marko, thanks for replying... I don't like to problems in the logs so I am going to switch that Power Module out.  Its not 3DR but in an HK one.

Power Module HK

But I have never had problem with my 3DR Modules... have run those on all my quads... that being said, I give up at this point with tuning and firmwares and am going to try out the hardware change.

Thanks again for replying... 

Cheers

So, here are the results of a new PM put in place....

It seems to me, your power module just not have enough power.

Still having the AltHld problem Changed several Parms Is the real problem vibrations ?

Pleas have a look.................

Attachments:

Well, from a quick glance your X/Y are well over the -/+ limits of -3/+3

Your Z is well over the -5/-15.

I would definitely fix the Vibrations...

Was your crash significant? Any damage?

High vibrations, you have to resolve that, here many great info to do it  http://diydrones.com/forum/topics/vibration-isolation-and-dampening...

I remember that on APM there was recommendation to add a Cap on one of the channels to reduce VCC spikes.

Any recommendations or process on the Pixhawk ?

Hi Tsahi

The power supply issues are supposed to be solved. However I notice the APM 2.7 has a 150uf filter cap. If you look in the log at VCC you see a lot of spikes. I have added a 2200uf 16volt cap across the 5.3 volt output in the APM power bec and covered it with heat shrink. I then looked in the log again and noticed a marked decrease of spikes so I believe its worth the effort.

Cheers Henny

Hi Henny,

do you know if its also possible / recommended on pixhawk as well ?

Thanks LTMNO for looking at my log. Been working on  vibrations just had a test flight

and vibrations are better but AltHld still not good. This is my third build and never had this much problem. This frame looks like a TBS but is not TBS.    APM 2.6 (frame type set to V)

810Kv 10x4.5 3 cell 3.2.1 FW PS: crash was just a tip over.

Attachments:

It will be pretty hard to get rid of vibrations with 810kV + 10x4.5 + 3 cell.

I have 850kV motors + 4S and still rpm's are not high enough to keep vibrations in lower harmonics.

How much does your copter weight?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service