Hi.

I have a problem after updating AC to 3.2.1 from 3.1.5.

When in Loiter, the the speed of the motors rev up and down/pulsate quite rapidly. This was working fine when I was using previous versions of arducopter.

I have downloaded the logs, and have looked into accX, accY and accZ. These seems to be inside the range specified in the wiki at arducopter. (Log_vibrations.bin)

Please have a look at the Log.bin, and note the difference between ThrIn and ThrOut when I'm in Loiter mode.

 

Anyone having any idea what the problem may be?

Views: 27535

Attachments:

Reply to This

Replies to This Discussion

the 3.2.1 is not quite perfect 3.1.5 is much more 'stable,moreover the 3.2.1 detects many more 'vibrations

Could you try out 3.2 firmware? I think it is closer to 3.1.5 than to 3.2.1.

I down graded both my quads to 3.2.0 because it is more stable and you get poshold.
Can someone please point me in the right direction to download 3.2.0?
Go into mission planner and half way down on the firmware page is a option for previous firmware. Click on the pull down box for previous firmware and select 3.2.0 the quad firmware should now show 3.2.0 vesion under the quad picture. Now upload the firmware.
Thanks but I am using Apm Planner on Linux. I don't have that option. All I have is a manual, current(stable), or beta option. I can't find the hex file to do the manual option.

Jesse, if you use Linux, it is very easy to get the source from Github and compile your own binary to load.  Alternative is go to Github and search for the old version.  The binary firmware file are hex files on Github depending on your configuration.  Here is a link to guide information on how to load firmware http://firmware.diydrones.com/

Here is the link to the folder for Version 3.2 ArduCopter Stable V3.2 firmwares 

All prefixed apm2- will be what you need for APM 2.5 or 2.6 boards.  Depending if you are setting up a quad or Y6 or hexacopter or whatever, you look for the specific folder name with the configuration as suffix.  For example if you are looking for the quadcopter firmware then you need apm2-quad.  Inside the folder apm2-quad directory is the hex file for setting up an APM board to control a quadcopter configuration.  Download and safe it to a folder and manually load it to your board using the "load custom firmware" button in APM Planner on the bottom right corner of the screen.

Good Luck.

FW3.2.1 I solved by lowering the value of the parameter PILOT_ACCEL_Z FROM 250 TO 50 NOW is VERY STABLE IN FLIGHT and should not be more 'up and down

Got it! Thanks a lot for your help.

FW3.2.1 I solved by lowering the value of the parameter PILOT_ACCEL_Z FROM 250 TO 50 NOW is VERY STABLE IN FLIGHT and should not be more 'up and down

Have you been decreasing this parameter gradually or set 50 from the beginning? 

Do vibrations on graph decrease or it just makes system insensitive?

PILOT_ACCEL_Z - maxium acceleration used when pilot is controlling the altitude.

Something tells me, that we can get issue on Auto missions. Do you have an opportunity to see how well it behave in Auto flight?

Seems like I'll be flashing my quad twice a day :D

By the way, while flashing 3.2.1 on MP 1.3.25 *4444 build at some point MP gets "Not responding", you need to know that process is still going on under the hood. Quite creepy moment :) 

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service