WARNING to TradHeli users:

Do not attempt to fly AC3.3 until you hear otherwise from me.  I have not even bench tested it yet, let alone test flown it.  There are quite a lot of changes that have gone in that could be crash-o-matic for helicopters.

AC3.3 release for Tradheli is likely to be delayed.

This post will serve as the official release progress thread for TradHeli.

Warning: DO NOT FLY RC6!  It has a critical bug that will likely end in a crash.

Warning for RC5:

RATE_YAW_FILT_HZ param will change defaults from 5Hz to 20Hz to be more suitable for helicopters.  If you have never changed this parameter from 5 before, then it will automatically update the value to 20 without warning.  This much faster filter will probably require reduction in your P and D terms, and the yaw may oscillate badly.  Be prepared to retune these.  As a safety measure, probably cut them in half for your first take-off.

Warning #2 for RC5:

I accidentally broke the Landing Detector.  It will probably never trigger.  You should land in Stabilize mode, or be prepared to shut down the motor as soon as it touches the ground in Alt_Hold, Loiter, Auto, etc.

Views: 19529

Reply to This

Replies to This Discussion

The payload goes up front.  There's actually a nadir mount camera installed in this view, but it is shrouded. The payload if very flexible.  Very easy to integrate almost anything you want.

What I wouldn't give for one of those helis and the time to fly it...... That my friends, is the dream.

I'm struggling to get my Logo 400 to fly in Alt Hold without it bouncing up and down. What am I doing wrong? Log file attached.

Thanks in anticipation.

Attachments:

It's the althold parameters. I'm running fixed rpm and use collective to maintain altitude so I'm not sure if its a "power" parameter or I need to change something to do with pitch. Here is another log file.

Attachments:

Happy Days! I've solved the problem. Mission Planner has a minimum Throttle_Accel_P at 0.5 and in the extended parameter screen it won't let you input a value below this number. I set Chan 6 from 0 to 0.5 and found the best setting to be about 0.3. I've set Throttle_Accel_I to 0.6 and Throttle_Accel_D to 0.001 and all is now well in AltHold and Loiter.

For traditional helis, someone needs to change the minimum setting if possible.

Excellent info! Just setting up my first 3.3.3 in a TRex500 so I'll be trying your params.

I notice there are apparently 3 versions of 3.3.3 here:

http://firmware.ardupilot.org/Copter/stable/PX4-heli/

v1, v2, v4What difference between these?

As long as I'm in question mode, what is PX4-heli-hil??

Might be even more useful if unarmed it sets low, but armed it does passthrough from Tx - then could be used for gov/elec motor control.

Rob_Lefebvre said:

Hi Steve, I actually added an official kill switch function for 3.3.  Actually, it's called Motor Run Enable.  It's just another Aux Servo Output function.  You can slave it to any output.  It simply sets PWM at min for that channel when disarmed, and then max when armed.  I think this should be sufficient to trigger an ignition system?

We are moving support for the Trad heli to the new forum http://discuss.ardupilot.org/c/arducopter/traditional-helicopter

I encourage you to post over there

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service