I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

Views: 292967

Reply to This

Replies to This Discussion

Interesting bug I think.  loaded the latest and with fonts and all.  I get a good first screen with all the data correct.  then every minute or so I get a small crowded OSD in the middle of my screen with 8 lines of info right in the middle of the screen. then after a minute or so it flips back to the good screen.   the config I pushed was default first screen and nothing on the second screen.  why is it switching on its own.  and why is it going to this little screen that I did not config?

Ideas?

Hi every one

My Minim OSD does not want to display current draw or RSSI. Both values are however correctly displayed in my Mission Planner when I connect it over USB on Laptop.

I use APM2.5 and a 3DR power module. The OSD is brand new.

All settings are correct: Current sensing on pin A12 and RSSI on pin A0.

Volts are correctly displayed in OSD and MP (pin A13).

Has any one came accross this problem yet?

Hi every one

My Minim OSD does not want to display current draw or RSSI. Both values are however correctly displayed in my Mission Planner when I connect it over USB on Laptop.

I use APM2.5 and a 3DR power module. The OSD is brand new.

All settings are correct: Current sensing on pin A12 and RSSI on pin A0.

Volts are correctly displayed in OSD and MP (pin A13).

Has any one came accross this problem yet?

Hi Ben,

Read here

Hi All,

This has been a good, informative thread and I do not want to have to close it because of politics. As DS has said, start a new thread to address the political aspect of drone safety and the media. Please lets continue to just address the MinimOSD in this thread.

Regards,

TCIII Admin

Agreed & done. Apologies for taking my discussion OT.

OK all...I'm sure this has probably been addressed previously but I haven't found it.  I'm having issues with the MinimOSD (latest firmware and all) and a GoPro Hero 3 camera (latest firmware as well).  Here's the situation:

  • Had OSD working properly with Hobby King camera prior to buying the GoPro
  • I've now installed the GoPro but I get no video from it.  I can see the OSD information but no video from the GoPro.
  • I am using a proper USB to composite cable for the Hero 3 (i.e. the 10-pin mini USB)
  • I can get video out of the GoPro if I go directly from camera to a video display device such as a computer (in other words...I've verified that the USB cable works properly)
  • I've updated the OSD firmware and character set a couple times now...no change.
  • I'm powering the OSD and transmitter from a dedicated power supply at exactly 12 volts
  • I'm not sending power to the GoPro but I am sharing the ground with the OSD and transmitter
  • I've tried bypassing the transmitter and sending OSD and video directly to the display device via hardwire connection...no change.
  • I've turned on the Hero 3's wifi while connected to the OSD just to see if I can get video from the camera that way.  Video feed over wifi is successful.
  • Here's the most interesting symptom...If I slowly decrease the voltage I provide the OSD from 12 volts down to ~9.5 volts, I can get the camera video to sporadically appear.  Sometimes it takes the place of the OSD overlay and sometimes it is combined with the OSD overlay...just depends on the voltage I send the OSD.  So....it's acting like the OSD is just plain overpowering the video signal from the camera.
  • The OSD and the camera are both set to NTSC video standard

So there's my situation.  I've come to the end of ideas on where to go from here.  Any help or guidance would be greatly appreciated.

Cheers,

Wayne

I'm sorry if this has been asked before, couldn't find it in the search.

The temperature is internal in the board right? Is there a way to add an external sensor besides the one 3DR sells? I have a few micro temp sensors from eagle tree I would really like to use. If anyone could help me out with some base code to work off of that would be tremendous!

Thanks!

John

is it possible to monitor a secondary voltage input ?

Unfortunately the APM doesn't allow for it.

is it an hardware/conception limitation or can i modifiy the loop code in APM to read a free analog input with adc (or take one which i don't use) create and generate a new mavlink command (or take one already existing that i dont use in minimosd) and modifiy in minimosd code for custom draw/units ?

(i understand those stuff won't be editable from MissionPlanner)

or, as the rushduino impl for minimosd and multiwii or mniOPOSD impl, modifiying the minimosd hard and code to read an extra analog input

Hi all.

Thanks to MinimOSD Extra developers. Based on this code, I made version for YS-X4/X6

http://www.youtube.com/watch?v=gmqjYyZUFG8

Details on rcgroups thread http://www.rcgroups.com/forums/showthread.php?t=1893795 

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service