I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

Views: 291179

Reply to This

Replies to This Discussion

Miguel

Thanks for developing the high vertical speed warning.  Ran quite a few tests to determine a preferred unit setting, in both metric and imperial.  Finally set it just below RTL ascend speed.  Video here includes the new setup.

Noel,

And I thank you for this great test / tutorial video regarding vspeed warning ;)

( great aerobatic maneuvers with those birds :) )

Miguel

Nice!

I really enjoyed watching! ;)

Thank you very much! 

Gábor

What setting did you arrive at?

Why not. :)

I will talk it over.

Hi Nathaniel! Sorry for such a long delay but I just noticed that the reply was cut off. This forum does that a lot! Anyway to continue… It works with any receiver that outputs rssi as PPM.

http://www.mictronics.de/projects/ppm-to-analog-converter/

Thanks, those birds are regular visitors.. my favourite, herons, I think that day.  Was not expecting a direct path though!

Steve, I have been trying imperial measurements lately even though I grew up with metric.  Our final settings was 36 units in ft/m.  I think my RTL ascends at 250 cm/s ~ 8.2f/s.  So, we conclude don't put it too low, as it defeats the purpose if it keeps warning.  We also think it is good to trigger when Failsafe RTL kicks in, and also during yawing/filming, sometimes I accidentally lower the thrust and begin dropping from high altitude.  For metric, I will probably set it at 2m/s = 12 units .  May know better after a few field missions.

Well I did just the opposite. Grew up with imperial then moved to brazil which is mostly metric. Actually they are half and half. Many things in inches when you buy things that are older. I guess in the beginning the were not metric so the older stuff kept it's measurement in inches.

I will set it at 2m/s for now and adjust with some testing.

Why is it I see my HAM callsign in the OSD PC config app, but it isn't on my actual HUD?  Everything else the PC program set up is on my OSD the correct way.

Hi,

It should be where you have configured to.

the behavior is: it is on in the first minute after boot.

Than it comes up in ever y minute for a sec.

Gábor

Hi I have a problem here... I had apm 2.5 and minimosd working perfectly on my old skywalker but then I crashed it and totalled it. I have just now got everything transplanted in an x8 and everythings working good on the OSD except for the GPS... It never says how many sats have been found or the lat/lon but on MP it says I have a lock with 7 sats..? By the way i'm using the mediatek gps... Really annoying because the GPS fix warning never goes away...

Nevermind I figured it out sorry... Problem was too much voltage into APM... It's really picky about needing exactly 5 volts and no more to run at... A little difficult when running high voltage sevos...

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service