I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

Views: 291123

Reply to This

Replies to This Discussion

I trying  to setup my minim osd v.1.1 many times, but i have problem with character set update . See the image in attachment. I use ftdi basic usb adapter 5v from sparkfun and 12 volts power cable , just 3s battery in minimosd.

I use 2.3.2.0 CT (MinimOSD-Extra_Copter_Pre-release_2.4_r719.hex )and the latest character set from :http://code.google.com/p/minimosd-extra/downloads/list. I try to update deferent character set (2.3.2.0, 2.4) but i have the same issue. Please help me!!!!!

Attachments:

Charilaos, i can't reply directly to you for some reason.  Maybe you need to reply to my first question in the thread..

My guess is that you haven't successfully updated the character set yet OR the .mcm file in the directory with the OSD_config.exe file isn't the one you uploaded onto your board.  In other words, the .mcm file needs to be named (MinimOSD_2.3.2.0.mcm) exactly for the application OSD_config.exe to load it into the config tool.  You may need to rename the file MinimOSD_2.4.mcm to MinimOSD_2.3.2.0.mcm and restart the Config Tool to get the character set to display correctly in the Config tool...  

Thank you for your response Paul.

I followed your instructions. The result is better but as you can see some objects are not visible. Look at my attachment..This is the panel1 with the default objects.I use it just to test.The objects that are not visible, they are not covered by others. I used ct 2.3.2.0 with MinimOSD-Extra_Copter_Pre-release_2.4_r719.hex and the file MinimOSD_2.4.mcm renamed to MinimOSD_2.3.2.0.mcm for character set.

Attachments:

hmm...  it does look better Charilaos.  Did you try reloading the character set after you renamed the file?  I'm loading the Extra_Plane version so i don't know if there are differences that might be causing that problem.  Have you ever used the MAX7456Charwizard.jar tool?  i've attached it.  Just double click it from your pc and it should open.  It's a character editor/reader and will let you compare .mcm files...

Attachments:

Hi Paul,

Great to know you have found the reason of your none updating charset issue.

We should include it in a "troubleshooting" wiki área ;)

If you could, please post videos of your flights. Videos are a great tool to catch bugs or just too see people enjoying our efforts to make minim osd fw better :)

Miguel

Hi Charilaos,

I wouldn't rename the charset files because it can become very difficult to help people debbuging issues as we upgrade the charset/CT Tool versions.

Next CT Tool release will be 2.4.0.0 and will present automatically MinimOSD_2.4.0.0.mcm charset.

There are a couple of people having a similar issue as you report.

Since I couldn't yet reproduce this issue with my setup, I would like to ask you to do a debugging test:

1 - Connect minimOSD to PC and open CT Tool. Choose the COM port.

2 - On CT Tool Panel 1 uncheck the "Home distance" panel

3 - Click "Save current tab to" (these way we guarantee it is "erased" from minimosd)

4 - Now on CT Tool Panel 1 check the "Home distance" panel

5 - Move the "Home distance" panel around the screen and place it in a different location (this should enforce coordinates location update)

6 - Click "Save current tab to"

7 - Unplug minimOSD from PC and connect it to your FPV gear.

8 - Check if "Home distance" panel appears where it should.

Miguel

First of all: thank you so much for all the hard work you've done with this excellent firmware.

I was about to order another RSSI DAX for EzUHF to get RSSI in MinimOSD on a new plane I'm building. But when installing the latest MinimOSD Extra I suddenly made note of some changes in the RSSI menu. I could choose PWM RSSI from one of the channels.

So, I configured RSSI on channel 8 in EzUHF config and choose channel 8 for RSSI in MinimOSD. Wow. RSSI in MinimOSD without the $50,- adapter or any extra cables.

In the beginning it said -nnn% for max and +nnn% for min, but after a connection with the RAW option selected I could read that PWM 993 is max and PWM 1568 is min. At least for my 4 channel EzUHF Rx...

After entering 1000 for max and 1500 for min everything is better. I was not allowed to choose 993 for max or 1568 for min. So the way it works now is that 103% is max and -20% is min. But that's ok. :-) 

 Yes i tried many times with the same resaults. The MAX7456Charwizard.jar tool its very useful.Thank you. But i think that my problem is in the .hex version. I try to compile the Revision 725 but the version maybe has problem.

------------------------------------------------------------------------------------
In file included from ArduCam_Max7456.cpp:4:
ArduCam_Max7456.h:78: error: expected class-name before '{' token
ArduCam_Max7456.h:84: error: 'uint8_t' has not been declared
ArduCam_Max7456.h:84: error: 'uint8_t' has not been declared
ArduCam_Max7456.h:87: error: 'uint8_t' has not been declared
ArduCam_Max7456.h:91: error: 'uint8_t' has not been declared
ArduCam_Max7456.h:91: error: 'uint8_t' has not been declared
ArduCam_Max7456.h:98: error: 'size_t' does not name a type
ArduCam_Max7456.h:99: error: 'uint8_t' has not been declared
ArduCam_Max7456.h:100: error: 'BetterStream' has not been declared
ArduCam_Max7456.h:102: error: 'uint8_t' does not name a type
ArduCam_Max7456.cpp: In member function 'void OSD::init()':
ArduCam_Max7456.cpp:38: error: 'video_mode' was not declared in this scope
ArduCam_Max7456.cpp: In member function 'void OSD::setMode(int)':
ArduCam_Max7456.cpp:109: error: 'video_mode' was not declared in this scope
ArduCam_Max7456.cpp:110: error: 'video_center' was not declared in this scope
ArduCam_Max7456.cpp: In member function 'int OSD::getMode()':
ArduCam_Max7456.cpp:123: error: 'video_mode' was not declared in this scope
ArduCam_Max7456.cpp: In member function 'int OSD::getCenter()':
ArduCam_Max7456.cpp:138: error: 'video_center' was not declared in this scope
ArduCam_Max7456.cpp: At global scope:
ArduCam_Max7456.cpp:162: error: prototype for 'void OSD::setPanel(uint8_t, uint8_t)' does not match any in class 'OSD'
ArduCam_Max7456.h:84: error: candidate is: void OSD::setPanel(int, int)
ArduCam_Max7456.cpp: In member function 'void OSD::openPanel()':
ArduCam_Max7456.cpp:177: error: 'row' was not declared in this scope
ArduCam_Max7456.cpp:177: error: 'col' was not declared in this scope
ArduCam_Max7456.cpp: In member function 'void OSD::closePanel()':
ArduCam_Max7456.cpp:206: error: 'row' was not declared in this scope
ArduCam_Max7456.cpp: At global scope:
ArduCam_Max7456.cpp:212: error: prototype for 'void OSD::openSingle(uint8_t, uint8_t)' does not match any in class 'OSD'
ArduCam_Max7456.h:91: error: candidate is: void OSD::openSingle(int, int)
ArduCam_Max7456.cpp:236: error: no 'size_t OSD::write(uint8_t)' member function declared in class 'OSD'
ArduCam_Max7456.cpp:251: error: prototype for 'void OSD::control(uint8_t)' does not match any in class 'OSD'
ArduCam_Max7456.h:87: error: candidate is: void OSD::control(int)
ArduCam_Max7456.cpp:268: error: prototype for 'void OSD::write_NVM(int, uint8_t*)' does not match any in class 'OSD'
ArduCam_Max7456.h:99: error: candidate is: void OSD::write_NVM(int, int*)
-----------------------------------------------------------------------------------------------------------------------------

Also i looked in the osd_panel from arduino and i sow diferences between CT tool and arduino code.

I dont no what to do except to i wait for new stable version in quadcopter

Thank you

Hi Mighuel

and thank you for your response!

please look my attachments . I folow your instructions.

Attachments:

I have a pixhawk coming in and want to know if anybody got rssi working with minimosd?
 And i want to have a 5v input just like i having now on the apm on the a1 voltage input.

I know i can work with the channel 8 option but i have a digital rssi convertor for ezuhf to 5v

Hi Charilaos,

In your posted images you point some issues that I think may not be issues:

throttle sign -> removed deliberately to save code space

GPS Sign -> It shows that "X" sign when there is no gps fix. 2D fix shows a small antenna and 3D fix a big antenna.

ground speed sign -> should only be shown if checked in CT Tool config tab (bug found, it's an issue indeed)

msl altitude sign -> should only be shown if checked in CT Tool config tab (bug found, it's an issue indeed)

This bug I found is regarding CT Tool Config tab, in the "Show sign before value:" group.

The checked options are making osd behave strange.

Charilaos, xoltri and Hein,

Could you please try to uncheck all that  "Show sign before value:" options and see if it works ok?

I'll be fixing this bug during this week ( starting tomorrow :) )

Miguel

Hi Miguel

and many thanks for you hard work for us....
I have already uncheck all that "Show sign before value because if it is checking i have the image result.

Thank you...

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service