I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


Views: 291889

Reply to This

Replies to This Discussion

Hi Mark,

Please tell us a bit more about your setup:

Are you using copter or plane?

What flight controller fw version?

Which minimOSD fw version are you running?

Also, please post the latest SR0 / SR3 parameters you're using.

If your using an APM, in your dataflash logs try to check the PM message to see the CPU load (if there is many slow loops or not). For example, when CPU is overloaded with critical jobs, it stops sending telemetry data.


Hi Miguel,

Here is the info:

I'm using Arducopter (I only have SRO/SR! it appears).

Flight controller FW is 3.1.1 RC2 (Latest). I did try it with other versions without change.

MinimOSD Extra 2.4 R719

Settings attached


Hi Mark,

SR1!? wow! I'm using latest stable (3.1) and I have SR3 params.

Untill now you had to set SR3 params to get minimOSD to work with Arducopter so maybe SR1 params are a renaming of previous SR1?

I'll try to test it with the latest beta later today.


Hi Miguel,

Yes only SR0 and SR1, at least that I can see.

As I say the only thing that doesn't work without the telemetry link initiated is Voltage and Current, once the link is established they start. They do update once on arm and again once on disarm but this really isn't much use...

What does SR1 do as mine are all 0?

I too am having the same issue, i get the message NO MAV DATA, ive tried to update the SR3 but it does not appear to exist in mission planner.

version 1.2.92

2.4 r719 minimosd extra

my sr1 are all 2 apart from SR!-PARAMS which is 10

Hi Mark,

SR1 is new for me :)

In Arduplane version SR0 was refering to usb serial port while SR3 was telemetry port.

In Arducopter (at least until AC 3.1) both serial ports are shared. That's why for copter we need to set SR0.

Now with that SR1 params I wonder if Arducopter devs splitted the ports like it is in plane.

If so, and if SR1 is related to telemetry port then setting SR1 params should "do the trick".

I really should test it later today.

Are you using APM or Pixhawk?



throttle sign -> removed deliberately to save code space

Is this just the sign in front of the value and not the value itself?  Or has the entire Throttle panel been removed?

Hi Josh,

Just the throttle sign before the value.

The value itself and the % sign after remain there :)


Hello, I am using apm 2.6. And I'm using arduplane firmware.

I tried treating SR1 as SR3 copying the values like for like to no effect unless there is a stage I'm missing.

Still all the osd will display is NO MAV DATA

As always, you're the best.  Thanks so much for all the work you guys do on this!

I'm using an APM Miguel.

Thanks for the help....

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service