I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:

Added:

- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading

- RSSI

- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)

Enjoy

Views: 292732

Reply to This

Replies to This Discussion

I am not getting mav link data after loading the latest firmware and char set for OSDMinim-Extra R800 (from link above).

Some characters are missing such as the Throttle sign and Latitude and Longitude signs.

Everything was working fine using Arducam OSD...

I have reinstalled the firmware and char set several times but still no mav data...

I have the minimOSD V1.1 connected using the 3dr cable from Pixhawk Telem 2 port...

The instructions here https://code.google.com/p/minimosd-extra/wiki/APM

specify for the APM - is it the same for the Pixhawk?

It says to edit SR0 and SR1 which on the Pixhawk I believe those to be serial outputs; SR0 for USB, SR1 for telemetry output1 and SR2 for Telemetry Output 2. Therefore the only changes I require to make would be for the serial output going to the minimOSD right? In my case I have the minimOD connected to Telemetry Output 2 = SR2...

I need some clarification - I have already adjusted the values it describes in the above link with no joy.

The answer is - The settings are for apm only, and for Pixhawk it depends on what port you are running the minimOSD from. I was using telemetry port 2 = SR2. So I made the changes to the SR2 settings and now it all works :)

Hi Guys,

Finally got a chance to go out at fly with the OSD on today its very cool. However it may be because it got a little wet but in the van sorting it out i had all the data i wanted updating fine. When i went to fly however i stopped geting any updates to the OSD. Still had text but it was as if it was frozen. Video was still fine. Now im thinking this might be due to a bit of moisture getting in (flying in snow (stupidity)) but was wondering if it had been reported before?

Rob

I've tried to modify the code in order to read Battery B.  The readout is hardcoded for now to show in the middle of the display.

I've configured my APM 2.7 to read A0 and transmit 'voltage2' over mavlink.

Unfortunately I see garbled characters instead of numerals. (I did use the upload Character_Updater_FW.hex - MinimOSD_2.4.0.2.mcm - <mycode>  methodology to minimize any upload follies.  The battery A readout I enabled  displays fine.

I am willing to go farther (because its almost useless to me without this feature), but require a way to display debug information.  Since the serial pins are used by the APM-MINIMOSD connection, I'm not sure of what I can do.

Else, if I can't show debug info while executing the code, I am at a severe disadvantage, and will humbly ask instead for those who are more knowledgable about the code to perhaps take a peek at what I've done. 

I know this will benefit many fixed wing FPV folk in addition to myself.

I am glad you are still working on Bat B. Hope you get the help you need.

Did you know the EagleTree Vector OSD has four battery voltages :-O

Awesome work Gabe. Thanks for making the minimosd so much better for the community.

I have a small request to get ezuhf rssi working correctly. The rssi value that ezuhf puts out is inverted so 0% on the OSD is full signal and 100% is no signal. If I put the raw value in back to front (low value as max and high value as min) it stops the rssi from working at all. Is it possible to either have an invert signal button next to the rssi channel select in the minimosd setup or re-do the code for min and max to allow for reversed numbers? Everything else is perfect :D
Hi glen, just reverse the channel in your ap. hth.

Hey Glen,

I suspect you're the guy asking about this on youtube too?  In case no, I just want to stress that you really should be choosing LINK over RSSI on EzUHF anyway, as it has some heuristics that better estimate link quality, where the RSSI is only one of the data elements in the link quality but there for, if I recall correctly, legacy applications.  Oddly enough, my RSSI does work fine if I only choose that, or at least it did when I was tinkering last year, but maybe something has changed in the EzUHF firmware since upgrading to the latest version that is producing the behavior you're seeing.


Good luck!

Hi Guys am new to this MinimOSD in my Skywalker plane and have been doing a lot of reading over the weekend about it.  I have a little problem that maybe some one can help me with.  If I install the 2.2 version all symbols etc appear fine on my screen but it does not show me the CRUZ mode and mah used instead of %.  OK I thought no problem will update the latest R800 using the above link.  Now a lot of symbols on the screen are goble dee gook. Going back to 2.2 sorts the problem out again.  So I read some more and thought it was to do with the character set in the latest CT it reported the character set as 207.207.207 or some thing like that, I then blew in the Character_Updater_FW.hex and updated the character set to the one in the FW & Char directory and that appeared to go just fine.  So I put back the MinimOSD_Extra_Plane_R800.hex file into the unit and configured it the way I want my screen to look and still the wrong characters on the screen like the compass rose and horizon being the worst.  I really would like to have all the latest symbols on the screen when flying am at a loss as what to try next so am hoping someone might be able to give me a clue here??  TIA

I have this problem, i have never been able to upload a new character set and i know they arnt uploading because i have tried editing out every single symbol so they are all transparrent and this is viewable when you preview the character set on the config tool. But when i upload it although it says "done" the character set clearly hasnt updated as the original character set is still viewable. Would really like to hear how this works.

Hi Robert I am not sure that mine is the same as yours as the latest version of the CT reads the number of the character set currently installed and it has clearly changed from the older number after my update but hey maybe I am wrong about that too.  I really do want to run the latest version as it has the icons and labels etc that I need to match my APM firmware and setup.  Here's hoping

Hally

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service