I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


Views: 292958

Reply to This

Replies to This Discussion

hey, have anyone come across the following minimosd behavior:

works fine for 10-15 power cycles, than all of a sudden you see garbage characters all over the free from OSD info screen. Places where OSD info is supposed to be shown are displaying correct OSD characters like horizon, altitude, GPS and so on. 

When this happen I have to re-flash both firmware and char set in order for the minimosd to work again. Have tried 2 different OSDs: witespy with KV team mode and a crius one.  flashed with minimosd extra 2.4r726 and minimosd_extra2.4 mcm char set. 

Also, I have 2 cam setup a sony 700tvl pilot and gopro routed to switch -> minimosd -> vtx. very often OSD info disappears altogether from the pilot cam view, while at the same time gopro feed has correct OSD info. not sure if these 2 issue are related. This happens with both minimOsd boards as well as 2 different video switches. 

I haven't seen this but I have seen plenty of weird stuff. I found that going back to the last STABLE FW and uploading the LATEST character set and THEN uploading the LATEST FW gets things as good as they get. I believe R800 is the latest "package".

There is a charset uploading firmware in the R800 package to support this.  You can load that, upload the firmware, then re-upload your vehicle-specific code.

Hello Guys,

Here is where i am up to and very confused. If someone could post a link or explain/help that would be ace!

I have the minim osd and my telemetry hooked up though a y cable.

With the minim osd connected or not i can talk to and from my pc through telemetry how ever if i have the telemetry plugged in i cannot see the OSD on my video feed just the video. Sometimes i do get OSD but it useually  only lasts 20 seconds before freezing. When i dont get osd atall i get the osd booting page but when that is over all the test dissapears. The video still transmits fine.
With telemetry unconected i get a good solid osd

Any Ideas?



Do you have Tx connected to OSD? Don't. Enable Telem in MP

Hi I have clicked the enable telem in MP button but to no avail. I have:
APM >> Telemetry
5v >> 5v
gnd >> gnd
TX >> RX
RX >> TX


5v >> 5v
gnd >> gnd
TX >> RX

Telemetry works all the time
OSD only works consistantly when telemetry is unplugged
It will sometimes work for a few seconds and then seems to stop updating
Or it will go throughthe boot up screen and then just display video without the text overlay.

Hope im pointing you guys in the right direction



Yep, happened to me. It looked like my entire screen was composed of repeating "crystals" except for the OSD text, which was clear. I assumed it was just a bad Minim, and replaced it. Then, after a couple of months the replacement did the same thing. Now that can't be a coincidence. So on a hunch, I reflashed everything on the Minim and it was perfectly clear again. I'm not sure which copter version it was, but one of the 700+ series betas. I now have the 800 on it and so far so good.

thx Tom, please advise where you got the 800 version? 

what you describe is the correct way to connect everything. I have problems every once in a while one out of 10 times the OSD will not boot. it will not show any Mavlink data but it sounds like yours is a lot more unpredictable than that
Read somewhere someone had a similar problem and updated to the 2.4 pre release and that fixed it so will try that tomorrow. Its not a well known issue then?


I had a similar problem with my quadcopter's OSD. It has telemetry plugged in, no problems with that. When I switch on my TX, the overlay works fine, but as soon as the gps show the number of sats, the overlay will turn of. If I press reset the overlay will show up for a second or so.

I have the same board on my Tarot Hexa and the OSD is working perfectly.

So here is my fix:

I remembered a while ago that turning on warnings to display on the overlay was causing problems, but I know this was fixed in later versions of the firmware.

The display of information for my quadcopter's OSD is different from my Hexa, so this morning I changed the display to look exactly the same as the hexa and I have changed the Panel toggle channel on the config page of the GUI from Ch8 to Disabled to see if this helps.

The OSD is working now. I believe some of the selection of information to be shown on the panel makes the overlay disappear as soon as you connect the telemetry radio or in my case when the sats are displayed.

One other thing  I have seen with the minimosd is that it is difficult to completely reset its memory. Running EEPROM Clear alone is not enough and you will get funny looking text. Only way I get my minimOSD to work correctly is to burn the bootloader with USBASP programmer board.

Try the above and let me know. You never know, maybe this will work for you.


I thought i would step through different changes one at a time and i started by using the latest config tool i could find.... I think it now works still doing some testing but its not crashing and always seem to boot up properly :) Will report back is anything changes.

Thanks for you help


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service