I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


Views: 292941

Reply to This

Replies to This Discussion

I have tried a bunch of suggestions but still cannot get the minimosd-extra to update apm info. It is like the minimosd-extra is not requesting the apm info. Like I said it works perfectly if I load arducam-osd 2.2 on it so I think that proves out my wiring and hookup. So is it just a bug in minimosd-extra 800? Should I try an earlier minimosd-extra? If so which one and where to get it.



Hi guys and gals! Back again to say I tried loading minimosd-extra 2.2 and it still does not get info from APM. Realoaded arducamosd 2.2 and that works perfectly. This is driving me nuts because I really want to use extra with the small charsets but I can't until I get it to update properly. Very frustrating. Any help would be greatly appreciated.




When a new version? RSSI for r800 not working via mavlink in apm copter 3.3 rc5!

I wonder if this has anything to do with my problem and a possible solution. After searching around the web and reading through the issues on minimosd-extra site I realized that even though I made the changes to my SR0 and SR1 values in mission planner only the SR1 value changes took. No matter what I do it will not let me change the SR0 values. I make the changes and write the parameters but when I refresh they are back to what they started at. I have been reading about people having this problem with Pixhawk FC but I am having the problem with APM2.6 3.2.1 FC. Could that be why minimosd-extra is not requesting data? Or rather why the APM is not seeing the request properly?



Desperately trying to get this sorted out. Is there anyone here familiar with coding minimosd-extra? Was looking at code on google site and mavlink.ino caught my attention. I don't really know about coding but I did notice that in the code of mavlink.ino it seems to be requesting to get APM info from MAVLINK_COMM_0 which I am assuming translates to SR0 in APM parameters. Since I cannot get my SR0 values to change then I am wondering if that is causing my no APM info problem. Also wondering if changin g this value to MAVLINK_COMM_1 might make it correspond to SR1 in parameters which I am able to change and that might fix my problem. Just an idea. Any input would be welcome.



Hi John,

I'm sure that it doesn't have nothing to do with the communication channels.

From what I remember arducam-osd was sending the"mavlink stream request" message on boot and also from what I remember, minimosd-extra isn't - to save program space.

I know that there was/is an option in mission planner to set the mavlink stream to be always running without the need to request it.

Maybe that's all you need.

And I take the chance of this post to advertise the OSD I'm developing for apm/px4 :) - AlceOSD

Video from today's flight (full flight):

Tanks for the reply Luis. It would be great if you could remember what exactly that option is in mission planner since I cannot seem to find it in the parameters. BTW- your alceosd looks awesome and maybe I would eventually upgrade to that but first I would really like to get these 2 minimosd boards working to my liking with minimosd-extra!



Sorry, I missed this post!

And I take the change to announce that the AlceOSD project has been invited to join diydrones github!

You can find it @ https://github.com/diydrones/alceosd



Is there any way to support a 10S battery with minimosd-extra? The CT only allows up to 25.5v.. I guess 1 Byte for Voltage :/ Is it safe to recalibrate my voltage sensor to an arbitrary value (less that 25.5v)?

I have APM 2.6 + 3dr radio + Mavlink OSD 2.0 (R800 firmware, TX not connected) + 3dr Power module. Have a strange trouble:

When I try to run copter with my radio, after power on, OSD is working and showing horizont, flight mode, but battery voltage is not shown (0 V, 0%). I tried to reset APM, OSD - no results, I see 0 Volts. Then, if I try to connect through APM Planner, everything start to work OK, I see voltage. If I disconnect, everything is going fine - I see voltage. 

So I think first connection to APM through APM Planner changes something inside OSD (or APM?). How can I fix this? 

Zlodei, which AC# are you running? 

ArduCopter V3.2.1 (36b405fb)

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service