I have started to add functions to MinimOsd code.

At first i did it for myself only. Added many functions i thought i need. Then opened this thread.

after a while, Pedro and later Miguel came, and things started to happen fast. :D

They have optimised the code and added even more things to it.

They have worked hard on CT, and it became a great tool!

Thank you Bough! :)

By now MinimOSD-Extra got a pretty advanced OSD.

Here it is in action:


- Changeable unit measurement (US, metric)

- Airspeed

- Home alt

- Battery Percent

- Battery used mah

- Current Draw

- Time From Startup (cleared at takeoff to show exact flight time)

- OSD Menu

- Variometer

- Wind horizontal speed and direction, and also the average wind speed of the last few minutes. 

- OSD on/off

- Switchable secound screen

- WP distance

- WP heading

- Crosstrack error

- Warning messages for Lost GPS fix, Stall, Overspeed, battery volt, battery Percent, RSSI

- Efficiency, glide distance & thermic notifier. 3 in one panel

- OSD Brightness

- HAM Call Sign

- After flight summary

- Trip distance

- Temperature

- Smoothened horizon

- Real heading


- Vertical speed

This functions can be turned on and off, and placed on different screens now, by the Config. tool.

Also RSSI, switching mode and channel and unit measurement, Stall speed warning, Overspeed warning, Battery warning volt, Battery percent warning, RSSI warning,  can be set in new Config Tool.

We built in a new way of setting video standards. Now OSD does not guessing anymore :). You can set it fixed from CT. It is in "Video Mode" menu.

Here is how it looks: (This video is a bit outdated, sorry. I will make a new one soon.)

The MinimOSD-Extra project is here: Link

This project is the developing version of the official Arducam OSD located here: Link

The latest stable version is: 2.2

The latest version can be downloaded from here: MinimOSD-Extra R800

Username: MinimOSD_Extra

Password: Top_Secret

CT is included. (The FW for Plane, Copter, Character upload and the character file is in the "FW & Char" directory inside CT directory)

We are sharing it to see videos you make using it! :)


Views: 292432

Reply to This

Replies to This Discussion

Is there any way to support a 10S battery with minimosd-extra? The CT only allows up to 25.5v.. I guess 1 Byte for Voltage :/ Is it safe to recalibrate my voltage sensor to an arbitrary value (less that 25.5v)?

I have APM 2.6 + 3dr radio + Mavlink OSD 2.0 (R800 firmware, TX not connected) + 3dr Power module. Have a strange trouble:

When I try to run copter with my radio, after power on, OSD is working and showing horizont, flight mode, but battery voltage is not shown (0 V, 0%). I tried to reset APM, OSD - no results, I see 0 Volts. Then, if I try to connect through APM Planner, everything start to work OK, I see voltage. If I disconnect, everything is going fine - I see voltage. 

So I think first connection to APM through APM Planner changes something inside OSD (or APM?). How can I fix this? 

Zlodei, which AC# are you running? 

ArduCopter V3.2.1 (36b405fb)

hm... did you set your SR parameters? 

Sure, exactly like here

And I saw at one Russian forum the same problem (not solved). This is not critical bug, but I need laptop in the field to use my copter...

many-many problems in comments https://code.google.com/p/minimosd-extra/wiki/APM exactly like my:


Comment by Jarda.Vi...@gmail.comFeb 13, 2015

Hi, I have the following problem:

I have connected OSD (one wire not connected) and BT module (both tx and rx) to the FC. If I turn on the FC and FPV receiver, the OSD shows only basic data (roll, pitch, mag..), but not others (such as the battery current and voltage).

When I connect anything via BT (computer, phone) the BT obviously asks for all information and the FC starts sending all data, also to the OSD (even if BT is disconnected later).

But I would like to have the OSD showing all data, even without connecting BT device. I've tried the setup above, but without luck. Any ideas what could be wrong?? Thanks!

for me, I sometimes get "no mavlink" I think this is an issue with the serial output of pixhawk/apm.....  I usually short circuit the power module input plug (without batteries) this solves the problem. 

What are you doing exactly? I think I need developers help, this is unpleasant bug. Many users got this issue

exactly "short circuit power module input plug (without batteries)" I use anything I have on my hand for this- a key or a coin oe a paper clip.. anything metal to short input pins. this drains the capacitors and allows to power the board "afresh"  

IMHO need adaptive current version r800 to ArduCopter 3.3.

Example, on my system (arducopter 3.3, pixhawk original) not work RSSI. In stats missionplanner RSSI is present.

Me too, it is actually I think an AC fault... I have this happening on and off on AC 3.2.1 usually AC relash on pixhawk solves it for me. Sometimes it is RSSI, sometimes it is GPS status and number if satelites...  Sometimes OSD shows some crazy values for voltage and current. Reflashing OSD doesn't help, but reflashing AC does.. 

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service