Got a brand new, factory built, (and tested?) Arducopter.

 I'm a seasoned RC flyer, I've set up the drone in the Mission planner, Uploaded 2.9.1 Quad firmware, Radio calibration is correct.

Couldn't get the Automatic ESC Calibration, ESC's would beep continuously.

I manually calibrated each ESC with my RX and they worked, all motors ran, reconnected the signal wires to my Rx, powered up TX and Arducopter, and ESC's beep properly, but, no motors turning.

I checked "Motors" in the CLI, and the test runs successfully.

APM Amber light blinks; shouldn't it be solid? 

On LiPoly connection, the APM LEDS light in the following order:

Blue and red simultaneously.

Blue and red alternately,

Red only blinking,

Then blue solid with Red blinking.

Please help?



Views: 493

Replies are closed for this discussion.

Replies to This Discussion

Sounds like the drone needs to be armed. If you cannot arm the motors you may need to recalibrate your radio. Also, make sure your flight mode switch is in stabilise.

Tried "arming" the drones, re-calibrated my Radio in Mission Planner, and yes, Mode is set to Stabilize.

Still no joy

One thing to note is that after arming the APM will take about 5s to respond while it goes through initialization. 

With props off, have you tried with the APM connected to MP so you can watch the HUD for ARM/DISARM changes? Once armed and throttle is applied you should see on the failsafe tab, that the APM is commanding higher PWM signals to the motors.

Sounds like you've executed all the required steps, it can be frustrating sometimes though.

Arducopter motors are working now.

In retrospect, I think your advice about, "arming the APM will take about 5s", worked.

Just wasn't patient enough.





Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service