I recently purchased a set of 915Mhz 3DR Radios from the store and am having trouble verifying the behavior of the 'air' module using a USB-to-TTL device.

The 'ground' module is v1.1 and the mission planner was able to load its settings correctly.

For the 'air' module the mission planner and the radio config tool yield an error message - "Failed to enter command mode", when I attempt to load the settings from the device. The green light stays solid for a second and then flashes steadily as soon as it is plugged in.

Any advice?

-Error Message-

-Port Settings-


Views: 3341

Reply to This

Replies to This Discussion

Maybe you've got your RX and TX wires reversed? (RX on one board should go to TX on the other, if memory serves). I'm not familiar with that particular USB-to-serial board. 


(Although I had to wire Rx to Rx and Tx to Tx.)

Time for coffee..

Im confused what exactly your comment means. I have some 3dradios from udrones and one of them (the "air') is stuck w/ a solid green LED. I am have tried connecting it sing the supplied USB cable and the green remains solid and any attempt using the config tool to do anything fails with a "Fail to enter command mode" error.

Any tips are appreciated.

Are you trying to reprogram your radio?

The solution here comes from the most common problem with serial comms. Does TX go to TX or RX on the connect to device, and the answer is that "it depends". If you have a master (DTE) connecting to a slave (DCE). TX goes to TX and RX goes to RX, if are connecting Master to Master you need to swap RX and TX.

http://code.google.com/p/ardupilot-mega/wiki/3DRadio for more info

Does that USB-TTL use a SiLabs chip?

Im just trying to get the two radios to connect. I thought perhaps the air radio might need a firmware flash,but first i wanted to verify that it responded to commands. The strange thing is its Green LED is always solid even when the other radio is disconnected/off.

Pardon my ignorance but i have no idea which radio should the master and which the slave. Looking at the cabling neither of them have any crossed wires. The wires are standard without any crosses.

I bought the kit so im assuming everything should be correct. If not which should the master and which the slave ? What does a typical kit look like, ground=master and air=slave. Looking at the pics above, i notice there are a few crossed wires, im assuming that is done to swap the TX and RX. My cabling came without any crossing and i have not attempted to change this. See attached pic.


The strange thing is the "air" radio when connected to via USB seems to see AT commands, as the red LED flashing to match at the right time. The problem is it just does not respond at all. The 3DRConfig utility complains w/ a "Fail to enter comand mode" as described above.

Should i short the CTS and GND and try and enter bootloader mode and send a new firmware ?


The way you have it set up should 'just work'. That's my experience. You can try and reflash the dead radio. That may work if the FW has been corrupted. FYI: There is no difference between the 'air radio' and the 'ground radio' just there location ;-)

And my original post was in response to the solution that Boston UAV had found to reprogram his radio. When I was talking about master & slave I was talking about the serial interfaces, i.e the one on the computer that connects to the serial interface on the radio.

In your case you should be able to reflash with the FTDI cable you have without swapping wires. Boston UAV was using a similar but different adapter.

Thanks Bill, shorting the CTS and GND, then let me upload the latest firmware. After that the Green LEDs on both radios show they are connected so thats sweet.

As a ref im putting a link below for others.


jump to 

Forcing bootloader mode

Silicon Labs CP210x USB to UART Bridge

I must thank you very much. I have a same problem and try to solve it but it feel not work. 

Your suggestions helped me a lot. 

What have you tried to do ? Have you tried any of the things that Bill or myself suggested ?

I do follow Chris Anderson suggested. 

"Maybe you've got your RX and TX wires reversed? (RX on one board should go to TX on the other, if memory serves). I'm not familiar with that particular USB-to-serial board."

it work for me. 

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service