ive installed my airspeed indicator but when i tested it in console mode under test the data output i got was nanm/s and it didnt change when i try breathing in the tube

i checked that voltage is presant but im not sure how to check the analoge output has anyone seen this please



forgot to add i changed the firmware to the dec 13 version and it didnt change

Views: 3221

Reply to This

Replies to This Discussion

Which air speed sensor are you using?  This one or This one


If you are using the MPXV7002DP then check the following on your air speed sensor.


No air pressure in pipes:

Pin 2 & 3 = 4.9v
Pin 2 & 4 = 2.46v
Pin 3 & 4 = 2.42v

Air pressure in bottom tube:

Pin 2 & 4 = 4.8v
Pin 3 & 4 = .03v

Air pressure in top tube:

Pin 2 & 4 = .03v
Pin 3 & 4 = 4.86v

I have shown the pin numbers on the file attached, the voltage did not change on pins 2 & 3 throughout the tests.



Please post back with the additional informtion.


Kind Regards







thanks Martin the sensor i have is the MPXV7002DP and i have all the voltages you specified  ok so i assume the sensor is working fine


ill try reloading the firmware with a fresh file and see if that helps

If the volts match those I posted the sensor is ok, the issue is some where else, check all solder joints, cables etc.





Martin thanks for your help i found my cable has a break in the data line its a new cable so it was the last thing i checked but ive got it all working fine now :)

That's great news, an easy fix for sure.






i have the same problem with nanm/s message

but i have tried every thing and i can not find the failure

i have supplied the AD Port at the OilPan by 2V / 1,8 or 2,2

but it is still not working 

any other idea ? 



Hello Chris,

Have you got the same sensor as show above in the post I made a while back? If so have you tried to check the voltages as shown, if you have the same sensor and the correct voltages then there has to be another issue somewhere in the system.
Please let us know where you which sensor you have.




i have the other MPXV 5004

without pressure it has about 1,5V out

and this rise and falls about 1V by different pressure


but the sensor can not cause the problem

if i get the Airspeed AD IN some voltages from 1 -3V

the board shows me no real messuared value

only nanm/s






Hello Chris,


I have not got a great deal of experience with the 5004's if the voltage is changing when the pressure changes then there should be a signal for the air speed, I'm sure you have done this already, but no harm in asking,

Config.h file set up correctly?

Have you checked the solder joints?

Have you checked the lead to the airspeed / IMU?

Could you post a screen shot of the CLI window showing the results of the tests you are running.








>>>>Config.h file set up correctly?

// Are you using an airspeed sensor? Choose DISABLED if not.


>>>>>Have you checked the solder joints?

i have checked them all and i am not a beginner for electronics


>>>>Have you checked the lead to the airspeed / IMU?

i have told that i have made test without the Sensor

by direct test votlage of 2,5V to this ports


>>>>Could you post a screen shot of the CLI window

it shows only  nanm/s



you try to help me, that is nice of you

but your hints are simple easy and things they are tested first by some one with electronic knowledge

wires etc. are first things that should be tested

and i wrote before that i have tryed to give a correct usable voltage to the port for example airspeed etc

at moment it looks for me that the AD In Port for Airspeed is damaged and

cant be read correct

or perhaps i have made a fault at Firmware compiling

the Ardurion shows no error past verify and compile

then i can easy upload to the board

with the correct setup at config.h




Hello Chris,


What happens when you add this code to the Config file:


#define AIRSPEED_RATIO 0.1254

FYI, I had something happen today on this subject; It was rather amusing in the end; so I just had to share...

I happend to be switching back and forth between ACM and APM codes today, just messing around with HK's GCS; and such. But at some point I noticed the airspeed sensor had stopped responding in the APM CLI test. Not really paying any attention, I couldnt say exactly when it had stopped working. It had me stumped for a bit, checking cables, voltages; and even to the point of removing it and putting it on another APM/OP I have... Long story short, but to resolve it (insert drum roll here) all I simply had to do was 1) RELAX; and 2) do a reset in setup mode; and all is better...

Ya I know, I know; just fall back to basics...

Did you plug it in (lol)


(PS I have a 5004 as well)

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service