Hi All,

All flights have stopped!  All six of my motors are pulsating with no rhyme or reason.  Now I'm afraid to fly at all.  I've rebooted, reloaded, recalibrated, tried different batteries and even upgraded to the latest firmware 2.8.1.  Nothing seems to help.  I run all motors on the ground or in the air and at random times, all motors spike with power.  Anyone have any ideas what could be causing this?

I've uploaded a log to show what's happening.

Thanks for the help,

Views: 346


Reply to This

Replies to This Discussion

"and at random times, all motors spike with power. "

I am clueless when it comes to the log files, but a couple of thoughts:

All motors spike at the same time?

Can you reproduce it on the bench with the props off?

My guess is yes. Also with the log it's easy to view, just open mission planner, click on the Terminal tab and click the Log Browse button. Select the file and open. To see a graph of the motors, scroll down into the data till you see a label on the second column that reads MOT. The columns labeled 1 thru 6 are the motors themselves. These columns are actually columns 3 thru 8. Apparently columns 1 and 2 do not have labels. Now click on any value and select Graph This Data button. You can repeat this to see other values graphed up to 5 items. The first value is displayed in red and other values take on different colors. To see that all the motors on doing the spike in power, you may need to clear the graphs and just display one motor at the time.

I really should have posted this message under ArduCopter 2.X, do you have any idea how I can move it there?



     I've looked at your logs and it appears that you've got some interference on your throttle channel.  So it's not an APM issue so much as a radio issue.  If you have a look at the first field in the CTUN message you can see the throttle in.  I'm not sure exactly what the issue is, it could be interference from an xbee or radio near by...it could be a loose wire...this is the cause though.  Hope this helps.



Did you solve your "spiking" issue ?

Ya, it turned out to be bad Spektrum Reciever AR8000.  I noticed while working on another issue, I'd see the throttle on the radio calibration page, just spike.  I switched to my spare AR600 reciever and no spikes.  Switched back and spikes.  I also found that I could access graph and document the spikes.  I called Spektrum and they said they would send me a new AR8000.  Still waiting on AR8000.  I really been happy with the support I've gotten from Spektrum.  I'll be even more happy when the AR8000 arrives.  LOL.

Glad you got your problem resolved, mine still continues and it's not the Rx :-(

See my other post for the latest update.

Thanks again

Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service