I had my taranis to set the flight mode channel to RTL as it's failsafe. I did not set the APM failsafe, I should have tested this, but it does not work and I'm not sure I understand why.

Testing on the bench, If I center all sticks and flip my RTL switch, CH5 goes to 1903 and it the flight mode changes to RTL. However if i turn the radio off I get the exact same change, but the flight mode does not change!! Why not? During the flight, the flight log even shows that the mode changes to RTL (the first 2 times, the 2 other were manual i think), but it definitely didn't behave that way. 

I've since turned on the APM throttle channel failsafe and it tests fine. 

About 30 seconds in I got a RSSI critical warning and it started to fall. It recovered but i definitely didn't have good control for about 15 seconds before it started to fly away.

My other question is what made it fly away? from about 0:55 to 1:30 it shows it was in stabilize but I had no control and I was watching it was fly away. I eventually powered cycled the Taranis and flip the RTL switch. This worked but I wasn't sure at the time, as it was just slowly desending. I got impatient, switch backed to STAB, and was suprised i had control again! I brought it back as fast as i could. I was panicking and landed it hard enough to break a landing leg and prop ( i was just glad it was dry)

I think my antenna position was bad, so i'm going to getting one of those printed V stands. I had it in a V but on the leg, maybe too close to the battery. 

Other than testing the fail safe and a walking range radio test, is there anything I could do before my next flight? I still don't feel like i really understand everything that happened. 

Thanks, 

https://www.youtube.com/watch?v=_kgMMOYS3js

Views: 960

Attachments:

Reply to This

Replies to This Discussion

Ok, where living on the wild side.  Well since your not using the flight controller failsafe then you loose all the fancy features of the flight controller.

You were luck here.  The receiver lost contact and did signal RTL but the throttle value went to 930 which would have signaled a failsafe except it was disabled.  This is where it get interesting in that the flight controller continue on in the current mode and throttle.  As the copter is flying out of sight the receiver kicks back in causing the throttle to go back up and the flight controller switches to RTL.

I think you may have hit a catch 22 in that if the values fall outside the range it ignores the receiver and continues on like if you had a long mission and you want it to continue even if your out of range.

I think it will work normal if you get the throttle minimum back in range 983 - 2006.

Also if you have a bad GPS at the time the receiver fails it could ignore your RTL command and continue on in whatever mode it was in and not switch to land.

What is odd is that it doesn't work regardless of whether the throttle goes to 930 or stays center stick. If you don't have the APM failsafe set the flight mode will not change even though it appears to me that the input signals (all 8 channels) do the exact same thing as flipping the RTL switch. There must be something else in the SBUS signal that it is picking up that makes it behave differently when the reciever's failsafe kicks in. 

Because the Pixhawk uses "last past the line" flight mode changes, it's not a good idea to set the RX failsafe and not use the onboard failsafe.  Basically the Pixhawk takes whatever flight mode it sees last, and sticks with it.  This is why you can switch to RTL from Stab, Auto, Loiter, etc, because the RTL signal comes after those other signals and changes the mode.  If you flip your RTL switch, and then change to another flight mode, the other flight mode will be selected and RTL deselected, even if the switch is still on.  Based on how the RX works, it could be sending both RTL and your Stab switch positions to the Pixhawk at nearly the same time during failsafe, but the Pixhawk sees the Stab command last, thus selecting it.

For this reason you should set your RX failsafe to a very minimum throttle, in the low 900s lower than your TX can transmit.  Then activate the Pixhawk to failsafe on low throttle.  This way whenever the RX failsafes, the Pixhawk will detect that directly, instead of seeing the RX send a switch command.  

Ideally you should invest in a UHF long range RC system if you want to push the boundaries and fly into failsafe often.

Don,t use the Taranis failsafe its a dangerous option for a multirotor. Set your Taranis TX to no pulse. When the APM senses no pulses from the RX it can select Flight controller failsafe if you have the PWM set correctly in the Mission planner FS line.

It works great if set correctly.

You still need to manually set the failsafe threshold in the Rx, by pushing the failsafe button on the receiver itself. As well as set the TX to no pulse.


That's how I setup my failsafe on my quadcopter and so far, there has been no danger.

In the Taranis plus setting the Fail safe does not need any button pressing when using the X8R receiver, its all done in the Tx or using Open Tx.

When flying a Multirotyor using RX or TX failsafe is dangerous and could lead to model fly-away etc, The flight controller needs to know when the Rx to Tx link is lost  so it can initiate its own failsafe.

I have a Frsky receiver and I have followed the instructions on this wiki. So if you think, my method is wrong, than this WiKi is also wrong.

http://ardupilot.org/copter/docs/radio-failsafe.html

Hi Francisco

The link you mention refers to a Futaba or Spektrum radio transmitter. Its not a Wiki just a suggestion related to these two transmitters. Which transmitter are you using, Its a shame you did not see I was relating to the Taranis Plus running Opentx. This uses the full functionality of both the Taranis Plus and the Frsky RX.

In the end setups are the choice of the flyer, have a great next fly.

In that link I mentioned, there's a video that shows how to setup the failsafe for the Frsky Receiver..


Also, I have done a field test, by turning off my transmitter and it did not incur in a flyaway. The drone did what it was supposed to do, return home.

Looking at your log file other than that i see you switched back and foward between RTL and stabilize your quad seems to be set up well your vibration levels are to high if you sort them out your quad will fly well 

FAILSAFE SETTINGS:
Main Battery = Not Activated
Ground Control = Activated, with always RTL
Receiver = Not Activated
GEO Fence = Not Activated

You can see by the logfiles the only failsafe you have set is from your GC and not from your radio

1

Attachments:

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service