Alt Hold help...

Hi all, 

First post, be gentle :)

I have a q450 (Flamewheel) running an APM 2.7.2 Micro and I'm having trouble with Alt Hold mode. 

The quad won't stay at a given alt. It will 'bounce' around the place, sometimes coming down to ground level and other times lifting off an just going up and up. 

I've checked my vibration levels which look fine (between +3 and -3) and I've put foam over the APM to protect the barometer from prop-wash. 


I have flashed the APM to 3.2.1 and reset all PIDs to factory defaults. No change. 

Can anyone suggest what else I can be looking at?

I've attached a log if anyone has the time to take a look...

2015-04-27 21-46-50 19.bin.log

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Activity

Liam left a comment on Agricultural UAVs
"Hi
I'm Liam from T-MOTOR. I would like to reach out to see if there is any possibility for us to work together.
We are a propulsion system manufacturer who offers motors, propellers and ESCs for all kinds of drone applications which vary from secur…"
Jun 30
Richard Cox left a comment on Australia
"Anyone in the DIYDRONES Australian subgroup based in Alice Springs, NT?
I am experimenting with Ardupilot (standard Arduplane), Pixhawk 4 FC in a 4-ch
RC "AXN Floater Jet" foamy plane..."
Jun 29
Omar Sykes left a comment on Australia
"Hi everyone, I am looking for someone who is good at drone building, repair and software in Adelaide. Please give me a call on 0477 319 219."
Jun 29
More…