Hi guys, I have not followed the last release, so I got very upset when I updated my old, steady 3.2.1 Octa-Quad multirotor with the new 3.3.2. Of course I do realize that my system is kind of a mess, because I am using that multirotor for research and testing, so I know there are some vibrations and even some magnetic disturbances. Besides, the 3.2.1 had been flowing just fine. 

I installed the firmware, did all the calibrations (accelerometers, magnetometers, motors, esc..) and went flying. 

https://www.youtube.com/watch?v=WMMURxY4pHo

I attached the telemetry, but here there are some figures:

Throttle Out:

3691267454?profile=original

AltHold:

3691267448?profile=original

Vibrations:

3691267471?profile=original

Accelerometer Bias

3691267382?profile=original

Here is the only bad result from an autotest:

Test: IMU Mismatch = FAIL - Check vibration or accelerometer calibration. (Mismatch: 2.61, WARN: 0.75, FAIL: 1.50)

I tried to play a little bit with the EKF parameters, but got worst, so I would like to share my experience for you guys can help me to find the best direction to move on and get rid of this (only) issue.

Thanks

2016-01-14 16-38-46.bin

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • Randy, that was really helpful. Today I downloaded the master revision and the altitude control was very good, even in Guided mode. The overall flight performance look even better. Tomorrow I'll post some data If I'll get the chance.

    Thanks

  • Here I tested the GUIDED mode. In the attached log you will see a flight where I keep switching GUIDED-LOITER. In GUIDED mode I have a Companion PC reading the Transmitter and providing a velocity reference (that was kept to zero, except for a minute where I tried to climb)

    THROTTLE

    3702169112?profile=original

    ALTITUDE CONTROL

    3702169180?profile=original

    CLIMB RATE

    3702169028?profile=original

    2016-01-26 12-22-42 - GUIDED MODE ISSUE.bin

    • Developer

      Tiziano,

      As mentioned on Gitter, I've looked at your logs and it's certainly clear the throttle output is very noisy.  You've uncovered a bit of a mess up in the Copter-3.3.2 release.  It looks like the fix to increased the Guided mode's velocity controller's update rate wasn't actually included in the release (despite the release notes saying it was!).  I'll add this fix to Copter-3.3.3-rc2 which will go out within a week.  Until then you may want to test with latest.

      Thanks for the report and sorry for the troubles!

  • Hi guys, here I am back with an update. I balanced the props carefully (actually I missed to balance them vertically and even if APC they were pretty off balanced) and here is the new VIBE graph:

    3702169266?profile=original

    It really looks better, even in flight I see a huge improvements. The altitude though is still oscillating of about 1 meter (slowly, maybe now it is only a matter of tuning)

    3702169145?profile=original

    Now a big issue I have been noticing. Whenever I set the system in GUIDED mode, the vertical control goes kind of crazy: the Throttle Out oscillates a lot and the vehicle bounces like crazy. I am using a standard message to setup the vehicle's velocity, but while the horizontal flight is nice and smooth, the vertical is not. Here is some figures:

    ALTITUDE IN GUIDED MODE

    3702169279?profile=original

    THROTTLE OUT IN GUIDED MODE

    3702169328?profile=original

    Just for comparison, check the Throttle Out in AltHold or LOITER mode

    NOT GUIDED THROTTLE OUT

    3702169406?profile=original

    Does someone know how to deal with it?

  • I want to share with you the Vertical speed and altitude graphs when the system is not armed end after the arming command. I am indoor, no GPS. As you can see while the vehicle is disarmed the altitude and velocity keep oscillating. The oscillations stops as soon as I ARM:

    3702164146?profile=original

    As soon as I disarm the oscillation starts again:

    3702164767?profile=original

    • Developer

      I had a quick check with Paul Riseborough (author of the EKF) and he says that he's seen this as well.  We use slightly different tuning parameters when armed or disarmed and it's likely that the default disarmed-parameters, which we want to quickly figure out the accelerometer and gyro offsets, are set a bit too aggressively which leads to some overshoot.

      Apparently "EKF2" which comes in Copter-3.4 doesn't have this problem.

    • Ia working with dronekit and streaming data at 20 Hz through udp. I have been always noticed some altitude oscillations before arming, but those looks very strong. I tried playing with the bark noise and accelerometers noise and the amplitude looks coherent with my changes. I am not into the code, so I ask to some developer why is it happening aand is it normal? Besides, after the vehicle had been armed for a while, I received a message on majority, kind "system calibrated" and the oscillations stopped even when disarmed
    • The way the oscillations are so uniform and consistent I would think maybe that's normal? Like it's just searching for input? Just a guess. 

    • GLUP!!!

      I did that test with Mission Planner but not noticed that.

  • ... I just realized the typos in my post.... hate automatic correction

This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…