We had an issue yesterday that I'm hoping someone will be able to help me with.

When trying to start a mission by activating Auto Mode we kept getting an "Altitude too high" error. It doesn't say what altitude it's referring to and everything we tried didn't help.

About 2 months ago we had the same issue after switching to 2.11, drove home switched back to 2.10 and the next day it was OK. We've been flying 2.10 up till about a week ago when I decided to try 2.11 again.

This time we had no problems and had several good flights (at a different location). Yesterday at the original site we had the same error.

I could switch back to 2.10 again but feel this is not really a good solution.

Anyone have any ideas?



Views: 170

Replies to This Discussion

Dear Colin,

Let me start with apologies for not answering sooner.

Nonetheless the drone and settings in software may have several limits of AGL.

Let’s take a look together to them:

The first limit is in the Properties of the route in UgCS. 

The second limit is in Profile of the drone in UgCS. 

The first and the second limits you may change in UgCS as you like.

But there is the third limit that exists in DJI Inspire1 Pro drone and it cannot be changed. Unfortunately you may fly not more than 500 m from Take-off AGL during one flight (from Take-off to Landing points).

Best regards,
Anna Moshkova

Thanks Anna, I seem to have 2 threads going, I originally started this thread with this problem then found another thread that was related so commented there as well. I'll try and keep to this one.

As far as the altitude settings go, in the vehicle profile we have 'Max AMSL' set to 3000m (actual elevation 1076m), 'Max AGL' set to 600m (we never got above 50m) and in the mission parameters we have "Max altitude above gnd' set to 600m. We are flying a Matrice 600 so the Inspire restriction shouldn't apply.

We had a waypoint next to the homepoint set at 50m then the area survey set at 200m. We normally take off manually after uploading the mission on the ground then at 30m or so we activate the mission. This usually works OK but not in this case.

Hi Colin,
most likely you exceeding limit set in DJI GO/DJI GO4 app. Please check limit here.
Here can be confusing situation. Suppose you have 50m limit set in DJI GO app. And all waypoints in the route will have 45m AGL for example. But if your flight area are isn't flat some waypoints can have altitude above take-off point bigger then 50m - in such case you will get error message "Altitude is too hight".

OK thanks Alexey,

I thought that since we were using UgCS, that it's altitude values overrode the DJI Go settings.

No, UgCS doesn't override max altitude/radius settings in DJI GO.

Parameters in vehicle profile and mission used to check route only.


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service