Hi all,

I just bought an FrSky Taranis for my quad copter and needed to get the Mavlink data up on the Taranis LCD telemetry display. So here is my solution using a Teensy3.1 as a converter between MavLink and the S.Port on FrSky X8R.

See attached file below...

Views: 309707


Reply to This

Replies to This Discussion

Re-flash the Taranis to the latest firmware.

Re-load the Teensie from the latest (V1.3) zip on this thread.

Check what is going back to Mission Planner via USB - GPS lock, voltages etc.

Sorry, that has about exhausted my knowledge of the subject. Don't give up.


had great probs to start with getting this to display anything.

Then I bound my X8R in D16 mode, and all worked. I originally bound as D8. May pay to update instructions with this.

Very cool now. Almost as good as my mates MikroKopter now!!

does it work also for Frsky D8R-II PLUS 2.4Ghz 8CH Receiver? if yes wich connection to rx has been made?

DUMB ME! I had the teensy plugged into the S-BUS and it should be connected to the SMART-PORT on the 8XR receiver.  Most things working now, but no GPS data yet.

My thanks to Rolf and all those who offered help.

Damn - I forgot that one

Run the check list again and re-load the Teensie.

There is something in this thread about no GPS display - possibly re-flashing the Taranis?


I don't think this solution works with previous Frsky telemetry receivers. The S-Port is slightly different to the old hub digital protocol. Someone please correct me if I am wrong or have missed something.

Would need a jD-io board from jdrones or an arduino mini pro for that to work. jDrones has a firmware that will work on either for the old hub protocol.

pls advise a link to such f/w as i have an unused D4R-II which I like for its small size/ great range. 

I have tried the version  0.5 with my jDrones-IO board v1.1 & D8R-II Plus and it works.



would be great  if you provide us with the link! many thanks john

I'm having quite often issues where the Teensy won't initialize. I have to unplug and replug Teensy to receiver, then it starts working.

To be precise, after plugging in main battery none the LED on Teensy won't light up at all. After re-plugging Teensy to receiver it starts working. Replugging the main battery doesn't help, I have to replug it to receiver (while main battery is connected).

Thoughts please? This is driving me crazy. ...FYI Teensy otherwise works nicely once it is initialized.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service