Hi all,

I just bought an FrSky Taranis for my quad copter and needed to get the Mavlink data up on the Taranis LCD telemetry display. So here is my solution using a Teensy3.1 as a converter between MavLink and the S.Port on FrSky X8R.

See attached file below...

Views: 308505

Attachments:

Reply to This

Replies to This Discussion

Its working now however the data does not show up as coming in over A2. A2 is all zeros in my telemetry setup screen.

What shows up Under A1 in the telemetry setup screen is the voltage the Receiver sees (in my case X8R) which is 3.x volts.

I set up my display to shows Cells, GPS, Compass Heading an in my model display screen and I am seeing Cells = 11.x volts (model telemetry display). I believe this is from the code running on the Teensy3.1.

Can you explain why in Telemetry Setup under Model I see data under A1, Nothing under A2 but in the Telemetry Display Screen I see everything?

Last question (maybe) I see that you are not yet supporting Cnsp however I do see this value incrementing if I display this variable it starts at 7000 and increments based on current drain.

If Cnsp is not yet supported or accurate what would be the best way to measure remaining power?

Thanks.

 

I have tx2 rx2 and gnd connected to the teensy as well as the 3dr telemetry unit. I am getting connected on my PC but the teensy doesn't seem to be getting any data. I just het a slow blinking orange LED. any ideas?

Is anyone selling these all built? I have tried and just cant seem to get it working.

If you see one of my previous replies where I list the current (as of 1.3 version) parameters and some previous posts on this thread A2 only has relevant data IF you connect some analog voltage to the Teensy A0 port (A2->Analog voltage from input A0 on Teensy 3.1). If you don't, just disregard the values of A2 on the Taranis.

I'm not sure about Cnsp but I believe its calculated by the Taranis based on the Curr (instant current) transmitted by the telemetry.

The same as Distance which is calculated by the Taranis and is the distance between the initial GPS position and current GPS position. 

On APM or PixHawk?

If on PixHawk just plug the Teensy to port 2 and 3dr radio to port 1.

If APM check previous comments on this thread.

Jared was selling pre soldered with the plugs and pre programmed on eBay, but I don't know if there are still available.


Any reason I cannot tap off the telemetry port leads?  I already have a 915MHz transmitter for telemetry now, sending data to a laptop (USB receiver), but on occasion I'd like to fly with less gear, so having the telemetry go both ways would be optimum.

Is it possible to implement some delay in reporting the initial distance, or to disregard the initial GPS alt when beginning to monitor distance travelled?

With the X9D already powered on, when the X8R starts transmitting back to the ground the true GPS alt is displayed and the baro alt will be zero (correct), but the initial distance value will be the first received GPS alt (incorrect). If I reset the telemetry/flight, or power cycle the X9D, the distance will be zero, but the GPS alt will begin at zero...

openTX 2.0.7 (happened on all previous versions incl. >2.0)

Rolf's 1.3

I've done this with my 3DR transmitter. I just soldered a Y-cable that only splits off GND and RX, TX should only be connected to one device. So to run both I have the connector with TX going to the radio and if I want to run without the radio at all I just move the connector with the TX to the Teensy connection.

Forgive me for being thick, but "TX" refers to the transmit line from the ground TO the APM, right? 

So the APM can SEND data to both radio and laptop, but only receive data from one source?

Thanks!

Yep, always confusing the crossed TX/RX. You're right, so from the flight controller's perspective it should only have one device connected to its RX. That is one device sending it heartbeats etc.

I upgrade my taranis x9d 2.0.5 firmware into 2.0.7 and after upgrading, cell and cells function in the teensy does not working. The value of cell and cells is always zero. When I used 2.0.5 taranis firmware, everything was working great. I think taranis 2.0.7 firmware has some problem with teensy 3.1. Please solve this problem.

Thanks.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service