Hi all,

I just bought an FrSky Taranis for my quad copter and needed to get the Mavlink data up on the Taranis LCD telemetry display. So here is my solution using a Teensy3.1 as a converter between MavLink and the S.Port on FrSky X8R.

See attached file below...

Views: 308060

Attachments:

Reply to This

Replies to This Discussion

Hello!

Thanks and appreciated!

I will investigate that branch in the comin evenings. :)

How could telemetry interfere with a Bgc?

Read here, page 87 in these Thread.

Thanks!

That will not apply to me. But I do appreciate you making the distinction!

First, thanks to all for the amazing work done on this project!

My question, can someone advise if there is a version of the software that provides data on the Armed/Disarmed state of the flight controller to the Taranis?

Accord to the read me this one does https://github.com/fnoopdogg/MavLink_FrSkySPort

Thanks Paul!

I read here : http://www.rcgroups.com/forums/showthread.php?t=2274401   "There is a bug in Arducopter 3.2 that might affect you if you are using pixhawk or a compatible that has two telem ports. If you use the second telem port (telem2) for the Teensy (or OSD), it will not start dumping data mavlink data automatically, even if you set the parameters shown above (SR2_). This seems to have been fixed in the 3.3 betas."  

I am using telemetry 1 for teensy and telemetry 2 for 3DR Radio and radio seems working fine: during range test I lose my Taranis link before than Radio telemetry!

You have been very helpful!  Just a question. How long does it take to your telemetry to refresh the flight mode, because at the moment this is the only issue I have. sometimes it takes 5/10 seconds to display the new flight mode. It's not a big issue but...

Cheers, Massimo

That link is a good find, however I am using 3.2.1 and the Pixhawk does send the mavlink data automatically to the Teensy on Telem2 port. There's just the odd occasion where no telem is sent, but a restart usually fixes this. I imagine this occasional mishap could be to do with the bug you mentioned, but that report suggests that it won't work at all, when this is simply not the case (not in 3.2.1 anyway - I suspect this bug is more specific to the APM controller rather than Pixhawk). I did try your option of putting the 3DR telem radio on the Telem2 port when I originally setup the Teensy, and with this setup, on several power ups I failed to get the 3DR radio to work on this port, hence returning it to Telem1, and putting Teensy and OSD back to Telem2. This could be due to what I detail below:

What should happen (but doesn't appear to work with Telem2) is that if you connect the Tx of the Teensy to the Rx cable on the Telem2 port of the Pixhawk, then there should be no need to configure the SR2_ parameters at all (they could all be set to 0 in MP), as the teensy code includes a routine for setting the refresh rates of the SR parameters it uses over that wire, and it should do this when the teensy code runs, overwriting the existing SR2 values with its own. But in practise, even connecting this wire up, that doesn't work, certainly not on Telem2, hence the need to manually configure the SR2_ parameters. The MinimOSD also has code to do this config using its own preferences for those SR2 parameters, hence the reason you should not connect this wire from both (Teensy and MinimOSD) devices to the Pixhawk at the same time. As an example of this auto config in practise, you should see that the 3DR radio makes this auto config if plugged into the Telem1 port (if you zero the SR1_ parameters then power up with the 3DR radio connected to Telem1, the radio applies the SR1_ parameters - you can then see values on those in MP. The fact you have your radio now connected to Telem2 port, I would probably suggest you check the SR2 parameters in Mission Planner to make sure they are correct for the 3DR telem radio. My SR1 params are these (so with your radios on Telam2, your SR2_ params should be set like this):

SR2_EXT_STAT 2
SR2_EXTRA1 5
SR2_EXTRA2 2
SR2_EXTRA3 3
SR2_PARAMS 0
SR2_POSITION 2
SR2_RAW_CTRL 2
SR2_RAW_SENS 2
SR2_RC_CHAN 0

Hope that's of use. I am looking forward to the 3.3. release. I have been following the Release Candidate thread, and did get involved at one stage (RC5 I think) but I had some issues so reverted to 3.2.1. If you switch to 3.3, then bear in mind that there are some issues with this telemetry script (something to do with voice files missing) when running it with 3.3 (I must admit that it did work OK when I tried it with 3.3, but I didn't realise that there were messages trying to be played which had no corresponding voice files available). Then we have the OpenTX 2.1 update to contend with. This is involving some major changes in the telemetry scripts which Wolke reports he will be updating shortly to comply with this. OpenTx 2.1 resolves some issues I have with FLVSS battery cell monitoring, so I'm looking forward to make the move to that once the Wolke Teensy script is done.

Cheers, Paul

Hello!I Hope YOUNDO not mind another question.

I grabbed the fmoopdogg package.

Hex is loaded. And I see messages on the serial console.

I have copied the files from ApmPositionDisplaynto to my Sd card. But I get nothing when log pressing menu.

Now, I will assume I need to config something to match my model names or such. I tested a bit but could not find what I needed to do.

Yes, I am a Taranis noob. :)

My model is "01" with name "Storfot". What should I change on the SD?

Thanks!

Thanks Jan. I set it up and it works perfectly. For those that are wondering a status of disarmed is shown displayed by blinking the current flight mode in the header bar. The flight mode turns solid as soon as the bird is armed. Same with the display of the GPS HDOP.

If you haven't already, you need to go into the SCRIPTS folder on the SD card and change the sub-folder "model_name" to "Storfot".

Tjat is one of the first things I tried. But, I must have messed something up then. Will try again tonight. Thanks for confirming :)

Hi Andre, did you get this working?

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service