Hi all,

I just bought an FrSky Taranis for my quad copter and needed to get the Mavlink data up on the Taranis LCD telemetry display. So here is my solution using a Teensy3.1 as a converter between MavLink and the S.Port on FrSky X8R.

See attached file below...

Views: 308086

Attachments:

Reply to This

Replies to This Discussion

Oh, sorry about that.  Here's the full file - note it's from the v1.3 zip in case that matters - perhaps it has updated libraries or something. I've tidied this up a bit and haven't recompiled to test, so apologies if it contains an error, i'll help if I can.

Attachments:

No need to apologize, I'm not educated on arduinio, I can filter and recognize some stuff but don't know the code, I compared both, and I just did some dots and dashes wrong. now it should work like a charm, I will try it outside in a minute!

I got another question from my own desire. Today during the first test flights my "cels" value did weird things, I'm flying a 4S pack but at some point my TX shows me 5 individual voltages, I can reset this by resetting the telemetry, but then I loose my mAH count as well.

I found the part in the code where it calculates the amount of cells and altered it a little bit, I only fly 4S so I made the bracked for 4S from 12 to 17 V instead of 12,6 to 16,8. This because i found out that a little callibration error of the power module and the input voltage of a full pack is above 16,8V and the taranis thinks it's 5S.

Now the question: there should be a better way to fix the script to 4S, can you tell me how?

(ofcourse I understand the need for the calculation for the big crowd, but my alarms are getting messed up.)

hi john

could you please provide me with some picture (connection) how you connected the board and D8R-II Plus ? i have loaded the jDrones-IO board v1.1 with 0.5 firmware and connected everything as shown, still have nothing displayed on my tel.-mod. 9x (opentx frsky).

many thanks

PM'd you as it is off topic.

PM'd you as it is off topic

Does this make the temetry link to the APM readonly?

I ask because I'm afraid of someone else connecting to my quad over mavlink while I'm flying, and taking over control.

Okay, I'm having issues with the data not showing up on my Taranis.

I'm running a TBS Disco on 4S and am using a Pixhawk. My 3DR radio is connected to Telemetry 1 on the FC and my Teensy is connected to Telemetry 2. The Teensy connections are the 3 for S.Port which I confirmed go to the proper port on my X6R, and the other connections are ground on the middle and right side of the board and also Pin 9 on the Teensy going to Pin 2 of Telemetry 2. The Vin and USB power trace has also been cut as well.

When I power things up, I find that the LED on the Teensy will blink slowly and then it will be "solid." I only say "solid" because it looks like it's flickering very fast. From everything I read, I assume that means it is receiving MavLink data.

I also have a telemetry connection from the X6R to the Taranis as if I turn off the quad, it'll tell me I don't have any telemetry connection anymore.

On Feb 4 page 4, you posted a response to micropet to make sure to set pins I'm using to output. If we following wiring you set out, shouldn't those pins already be set up properly?

Any other tips on what could possibly be wrong and how to get it working?

Hi,

I had the same issue few days ago with the same symptoms and I solved it by connecting teensy to Telemetry 1 (I just soldered a 3 way cable which is feeding 3dr radio, minimosd and teensy, just GND and RX for the last two are connected).

I did some debugging and it seemed that just heartbeat packets were arriving trough telemetry 2.

So I should just piggy back off the connector going to my telemetry radio then? I guess it's just two wires and should be easy enough to do. I'll give that a try.

Thanks.

Thanks for the tip. I soldered it to the 3DR radio connector (Rx, GND) and the data comes through just fine now. It's a little cleaner setup as well, which is nice for my quad.

Thanks again.

Fred,

I believe you can setup failsafe on the basis of a low battery as well, if you have the 3DR Power module or an Attopilot module fitted but I haven't set this up on my quad. See the failsafe page in Mission Planner.

Without access to telemetry displays


See if someone has something similar happened and can help me:
It turns out that I cann't access to telemetry screens (long press on the "page" button according to the manual) from the main view screen.
I got synchronized with a Teensy 3.1 board connected to the  telemetry  port on APM 2.6 but I cann't get into those screens. I was update firmware via companion9x a while but can not remember if I had access to previously. However companion9x with simulation using the same settings as I have in the station I can to access from the computer.
I have also tried to connect without connecting the receiver or other hardware and the same result. I have also tried to put the original firmware and I haven't succeeded.
Has anyone had problems with access to these screens, I am doing something wrong?
Thank you very much, greetings

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service