Hi all,

I just bought an FrSky Taranis for my quad copter and needed to get the Mavlink data up on the Taranis LCD telemetry display. So here is my solution using a Teensy3.1 as a converter between MavLink and the S.Port on FrSky X8R.

See attached file below...

Views: 308645


Reply to This

Replies to This Discussion

No joy in Telemetry town.

I only get telemetry when I am connected by USB to Mission Planner and Mavlink is connected.  I have tried all iterations on the pin connections to the APM.  Mission Planner must send the "heartbeat".  The only wiring I haven't changed are the TX1 Pin 1 with the RX1 Pin0. Any danger in switching RX1 with TX1? (0,1)

Could I ask what lights you get on the Teensy when everything is working?

Thanks again,


hey guys you really do not need to cut the trace on the boards, i have built over 30 now, not a single one has had a cut trace

Unless the code has changed, it should be pin 9 and 10, which is TX2 (10) and RX2 (9). That might be your problem?

When it's running properly, the LED blinks really fast to where it almost looks like it's just on solid.

I am using pins 9 and 10.  When hooked up to the battery the LED blinks very fast as you say, but the receiver never sends telemetry data.

When hooked up to the USB and Mission Planner connected the LED blinks like it should...very fast, same as with battery hook up but it sends telemetry to the Taranis.  One thing I noticed when I disconnected Mission Planner the Telemetry still works.

Mission Planner is providing something that causes everything to work...what ever that is?   

I tried re-binding the receiver (running out of options).  No change.

try usb power but do not connect to missionplanner, does this work?

it may be a faulty regulator.

USB power doesn't work unless I connect to Mission Planner and USB.  Then All is well.  

Hi Chris,

I suspect the reason it is working with mission planner is because this sends an initialisation packet to APM to start mavlink. The teensy does this too but maybe your teensy tx -> APM rx connection is not working. I would suggestion double checking that connection.


Hello Glenn,

I will follow your instructions.  When I pull that connection (teensy TX -> APM rx) (using pins) it doesn't seem to make any difference.  The light still flashes quickly.  Maybe I do have a bad connection.

This APM 2.5 board in the Walkera QR X350 doesn't have a telemetry plug but it does have tx, rx and GND on the board that have to be soldered to. Many people are using those connections for MINIM OSD, which works.  I'll dig in and see what I can come up with.

One quick question.  Does Mavlink exist in Mission Planner or does it reside on the APM side?  Still learning.

Thank you,


Definitely check your connections again as it really sounds like it's not getting the heartbeat correctly to get telemetry started.

Mavlink is the protocol used to communicate between the APM and whatever ground station it uses so it "exists" at both ends.

I would third that comment, 

I bought my board from pjrc.com and wired it like instructed in the thread and all works great.

No trace cutting.

alright, i just re-read all the posts.. some great stuff people have added to which i will add to mine now.. Thanks to all for work contributions and Rolf for birthing this.

Just one comment on the trace cut etc... 

I think its confusing to some that they need to do this... To be clear from my understanding. You only need to cut this trace if you plan on using the USB port on the Teensy along while having the board powered by the Rx SPort Jack.

Perhaps if you are testing, etc.. but when load and compile the Teensy, you should never need to have it powered in 2 places at once.

Hope this helps...

I now have a APM 2.6 board that I am going to try the Teensy 3.1 on.  I have a couple of questions.

1) Will Telemetry to the Taranis work when I am plugged into USB or do I need to power up with battery?  Currently I have everything wired up to USB but the LED is only flashing slowly.

2) The  Telemetry plug on the APM board, with the USB connector up and to the right I am trying to determine which telemetry plug on the board is ground?  Is it the top plug or the bottom plug on the board?  I bought a telemetry cable and when plugged in the ground is at the top (USB up orientation).

Thanks for your help and patience.


Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service